mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/thunderbird to 60.3.0-1
This commit is contained in:
parent
20f8fa2b9d
commit
e96bafe2a5
2 changed files with 3 additions and 49 deletions
|
@ -12,8 +12,8 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=thunderbird
|
||||
pkgver=60.2.1
|
||||
pkgrel=2
|
||||
pkgver=60.3.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone mail and news reader from mozilla.org"
|
||||
arch=(x86_64)
|
||||
license=(MPL GPL LGPL)
|
||||
|
@ -26,11 +26,9 @@ optdepends=('libcanberra: sound support')
|
|||
options=(!emptydirs !makeflags)
|
||||
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
|
||||
$pkgname.desktop
|
||||
thunderbird-60.2.1-buildfix.patch
|
||||
https://hg.mozilla.org/mozilla-central/raw-rev/537f4d1d837a)
|
||||
sha256sums=('d313f25cd7ddc016bf8e4d4115f14b34a66621c0feabbc0dd72f9304cb93d7bf'
|
||||
sha256sums=('23fc097a5aa62006919029df890e5e2bec38c2c3e6081723040ef702ff6e4a7b'
|
||||
'e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827'
|
||||
'884c5a6742677c83173812f7abb1e409a2b13371ba6079c4cb69b3e95010de05'
|
||||
'9fa42f3a4ccd255b56f4157119c08ff19df9f972aa25af4cbb685e3683139c24')
|
||||
|
||||
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
|
||||
|
@ -103,8 +101,6 @@ END
|
|||
|
||||
patch -Rp1 -i ../537f4d1d837a
|
||||
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
|
||||
patch -Np1 < ../thunderbird-60.2.1-buildfix.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User Chris Manchester <cmanchester@mozilla.com>
|
||||
# Date 1533063488 25200
|
||||
# Node ID bc651d3d910cbc0730d870c5436b29ddc01fef10
|
||||
# Parent e9dd9434ad9ac15284429d904a45e4daf567c03b
|
||||
Bug 1479540 - Accept "triplet" strings with only two parts in moz.configure. r=froydnj, a=jcristau
|
||||
|
||||
MozReview-Commit-ID: 7pFhoJgBMhQ
|
||||
|
||||
diff --git a/build/moz.configure/init.configure b/build/moz.configure/init.configure
|
||||
--- a/build/moz.configure/init.configure
|
||||
+++ b/build/moz.configure/init.configure
|
||||
@@ -586,17 +586,26 @@ option('--target', nargs=1,
|
||||
@imports(_from='__builtin__', _import='KeyError')
|
||||
@imports(_from='__builtin__', _import='ValueError')
|
||||
def split_triplet(triplet, allow_unknown=False):
|
||||
# The standard triplet is defined as
|
||||
# CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM
|
||||
# There is also a quartet form:
|
||||
# CPU_TYPE-MANUFACTURER-KERNEL-OPERATING_SYSTEM
|
||||
# But we can consider the "KERNEL-OPERATING_SYSTEM" as one.
|
||||
- cpu, manufacturer, os = triplet.split('-', 2)
|
||||
+ # Additionally, some may omit "unknown" when the manufacturer
|
||||
+ # is not specified and emit
|
||||
+ # CPU_TYPE-OPERATING_SYSTEM
|
||||
+ parts = triplet.split('-', 2)
|
||||
+ if len(parts) == 3:
|
||||
+ cpu, _, os = parts
|
||||
+ elif len(parts) == 2:
|
||||
+ cpu, os = parts
|
||||
+ else:
|
||||
+ die("Unexpected triplet string: %s" % triplet)
|
||||
|
||||
# Autoconf uses config.sub to validate and canonicalize those triplets,
|
||||
# but the granularity of its results has never been satisfying to our
|
||||
# use, so we've had our own, different, canonicalization. We've also
|
||||
# historically not been very consistent with how we use the canonicalized
|
||||
# values. Hopefully, this will help us make things better.
|
||||
# The tests are inherited from our decades-old autoconf-based configure,
|
||||
# which can probably be improved/cleaned up because they are based on a
|
||||
|
Loading…
Reference in a new issue