community/gdal to 1.11.1-1

This commit is contained in:
David Beauchamp 2014-10-03 08:38:58 -04:00
parent 46693fc2e1
commit e996d71968
4 changed files with 24 additions and 237 deletions

View file

@ -8,8 +8,8 @@
# - use uname in path in removing rpath in packaging
pkgname=gdal
pkgver=1.11.0
pkgrel=4
pkgver=1.11.1
pkgrel=1
pkgdesc="A translator library for raster geospatial data formats"
arch=('i686' 'x86_64')
url="http://www.gdal.org/"
@ -22,22 +22,14 @@ optdepends=('postgresql: postgresql database support'
'swig: perl binding support')
changelog=$pkgname.changelog
source=(http://download.osgeo.org/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz
fix_json_012.patch
gdal-1.5.1-python-install.patch
giflib51.patch)
sha256sums=('989db33ff411e2c888348e71edec5ad06c74ed68781ebfbc4e85179b9d65aafe'
'0ef2a20e9a0e86f85eab9a4a1e5caf7364f1d547deed6f2249fe542d4d2881f4'
'55a0a961b2d1caddf80f18b6763a96690b0b6443fbd5a0c89e29503ded3bcea6'
'99bb57b514101a53fda4f163efffb0d9859423c9bd51766bbf99313f1eb0cafc')
gdal-1.5.1-python-install.patch)
sha256sums=('f46b5944a8cabc8516673f231f466131cdfd2cdc6677dbee5d96ec7fc58a3340'
'55a0a961b2d1caddf80f18b6763a96690b0b6443fbd5a0c89e29503ded3bcea6')
prepare() {
cd "${srcdir}/$pkgname-$pkgver"
patch -Np0 -i "${srcdir}/gdal-1.5.1-python-install.patch"
# Fix compilation failure related to recent json-c changes. FS#40584
patch -Np0 -i "${srcdir}/fix_json_012.patch"
patch -Np0 -i ../giflib51.patch
# python2 fixes
sed -i 's_python python1.5_python2 python python1.5_' configure
@ -53,7 +45,7 @@ build() {
cd "${srcdir}/$pkgname-$pkgver"
export CFLAGS="$CFLAGS -fno-strict-aliasing"
# bug 23654
# bug #23654
export LDFLAGS="$LDFLAGS -Wl,--as-needed"
./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 \

View file

@ -1,84 +0,0 @@
Index: ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp
===================================================================
--- ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp (revision 27044)
+++ ogr/ogrsf_frmts/couchdb/ogrcouchdbdatasource.cpp (revision 27267)
@@ -1079,5 +1079,5 @@
CPLError( CE_Failure, CPLE_AppDefined,
"JSON parsing error: %s (at offset %d)",
- json_tokener_errors[jstok->err], jstok->char_offset);
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
json_tokener_free(jstok);
Index: ogr/ogrsf_frmts/gme/ogrgmejson.cpp
===================================================================
--- ogr/ogrsf_frmts/gme/ogrgmejson.cpp (revision 27208)
+++ ogr/ogrsf_frmts/gme/ogrgmejson.cpp (revision 27267)
@@ -515,5 +515,5 @@
CPLError( CE_Failure, CPLE_AppDefined,
"JSON parsing error: %s (at offset %d)",
- json_tokener_errors[jstok->err], jstok->char_offset);
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
json_tokener_free(jstok);
Index: ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp
===================================================================
--- ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp (revision 27044)
+++ ogr/ogrsf_frmts/geojson/ogrgeojsonreader.cpp (revision 27267)
@@ -78,5 +78,5 @@
CPLError( CE_Failure, CPLE_AppDefined,
"GeoJSON parsing error: %s (at offset %d)",
- json_tokener_errors[jstok->err], jstok->char_offset);
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
json_tokener_free(jstok);
@@ -1517,5 +1517,5 @@
CPLError( CE_Failure, CPLE_AppDefined,
"GeoJSON parsing error: %s (at offset %d)",
- json_tokener_errors[jstok->err], jstok->char_offset);
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
json_tokener_free(jstok);
return NULL;
Index: ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp
===================================================================
--- ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp (revision 27044)
+++ ogr/ogrsf_frmts/geojson/ogrtopojsonreader.cpp (revision 27267)
@@ -75,5 +75,5 @@
CPLError( CE_Failure, CPLE_AppDefined,
"TopoJSON parsing error: %s (at offset %d)",
- json_tokener_errors[jstok->err], jstok->char_offset);
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
json_tokener_free(jstok);
Index: ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp
===================================================================
--- ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp (revision 27050)
+++ ogr/ogrsf_frmts/geojson/ogresrijsonreader.cpp (revision 27267)
@@ -79,5 +79,5 @@
CPLError( CE_Failure, CPLE_AppDefined,
"ESRIJSON parsing error: %s (at offset %d)",
- json_tokener_errors[jstok->err], jstok->char_offset);
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
json_tokener_free(jstok);
Index: ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp
===================================================================
--- ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp (revision 27044)
+++ ogr/ogrsf_frmts/cartodb/ogrcartodbdatasource.cpp (revision 27267)
@@ -505,5 +505,5 @@
CPLError( CE_Failure, CPLE_AppDefined,
"JSON parsing error: %s (at offset %d)",
- json_tokener_errors[jstok->err], jstok->char_offset);
+ json_tokener_error_desc(jstok->err), jstok->char_offset);
json_tokener_free(jstok);
CPLHTTPDestroyResult(psResult);
Index: frmts/mbtiles/mbtilesdataset.cpp
===================================================================
--- frmts/mbtiles/mbtilesdataset.cpp (revision 27215)
+++ frmts/mbtiles/mbtilesdataset.cpp (revision 27267)
@@ -619,5 +619,5 @@
CPLError( CE_Failure, CPLE_AppDefined,
"JSON parsing error: %s (at offset %d)",
- json_tokener_errors[jstok->err],
+ json_tokener_error_desc(jstok->err),
jstok->char_offset);
json_tokener_free(jstok);

View file

@ -1,3 +1,21 @@
2014-10-03 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
* gdal 1.11.1-1
2014-07-28 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
* gdal 1.11.0-4 libspatialite soname rebuild
2014-05-27 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
* gdal 1.11.0-2 giflib soname rebuild
2014-04-27 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
* gdal 1.11.0-1
2013-11-11 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
* gdal 1.10.1-1
2013-09-29 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
* gdal 1.10.0-4 FS#36328 fix
2013-05-18 Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
* gdal 1.10.0-1

View file

@ -1,139 +0,0 @@
diff -ruN frmts/gif.orig/biggifdataset.cpp frmts/gif/biggifdataset.cpp
--- frmts/gif.orig/biggifdataset.cpp 2014-04-16 20:04:33.000000000 +0000
+++ frmts/gif/biggifdataset.cpp 2014-06-11 12:39:28.420405033 +0000
@@ -339,7 +339,11 @@
/* If the file is already open, close it so we can restart. */
/* -------------------------------------------------------------------- */
if( hGifFile != NULL )
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ DGifCloseFile( hGifFile, NULL );
+#else
DGifCloseFile( hGifFile );
+#endif
/* -------------------------------------------------------------------- */
/* If we are actually reopening, then we assume that access to */
@@ -413,7 +417,11 @@
if( RecordType != IMAGE_DESC_RECORD_TYPE )
{
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ DGifCloseFile( hGifFile, NULL );
+#else
DGifCloseFile( hGifFile );
+#endif
hGifFile = NULL;
CPLError( CE_Failure, CPLE_OpenFailed,
@@ -423,7 +431,11 @@
if (DGifGetImageDesc(hGifFile) == GIF_ERROR)
{
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ DGifCloseFile( hGifFile, NULL );
+#else
DGifCloseFile( hGifFile );
+#endif
hGifFile = NULL;
CPLError( CE_Failure, CPLE_OpenFailed,
diff -ruN frmts/gif.orig/gifabstractdataset.cpp frmts/gif/gifabstractdataset.cpp
--- frmts/gif.orig/gifabstractdataset.cpp 2014-04-16 20:04:33.000000000 +0000
+++ frmts/gif/gifabstractdataset.cpp 2014-06-11 12:54:25.609072106 +0000
@@ -82,7 +82,11 @@
}
if( hGifFile )
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ DGifCloseFile( hGifFile, NULL );
+#else
DGifCloseFile( hGifFile );
+#endif
if( fp != NULL )
VSIFCloseL( fp );
diff -ruN frmts/gif.orig/gifdataset.cpp frmts/gif/gifdataset.cpp
--- frmts/gif.orig/gifdataset.cpp 2014-04-16 20:04:33.000000000 +0000
+++ frmts/gif/gifdataset.cpp 2014-06-11 12:45:37.318469917 +0000
@@ -386,13 +386,21 @@
CPLDebug( "GIF",
"Due to limitations of the GDAL GIF driver we deliberately avoid\n"
"opening large GIF files (larger than 100 megapixels).");
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ DGifCloseFile( hGifFile, NULL );
+#else
DGifCloseFile( hGifFile );
+#endif
VSIFCloseL( fp );
return NULL;
}
}
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ DGifCloseFile( hGifFile, NULL );
+#else
DGifCloseFile( hGifFile );
+#endif
VSIFSeekL( fp, 0, SEEK_SET);
@@ -417,7 +425,11 @@
if( nGifErr != GIF_OK || hGifFile->SavedImages == NULL )
{
VSIFCloseL( fp );
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ DGifCloseFile(hGifFile, NULL);
+#else
DGifCloseFile(hGifFile);
+#endif
if( nGifErr == D_GIF_ERR_DATA_TOO_BIG )
{
@@ -649,7 +661,11 @@
{
GifFreeMapObject(psGifCT);
GDALPrintGifError(hGifFile, "Error writing gif file.");
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ EGifCloseFile(hGifFile, NULL);
+#else
EGifCloseFile(hGifFile);
+#endif
VSIFCloseL( fp );
return NULL;
}
@@ -673,7 +689,11 @@
if (EGifPutImageDesc(hGifFile, 0, 0, nXSize, nYSize, bInterlace, NULL) == GIF_ERROR )
{
GDALPrintGifError(hGifFile, "Error writing gif file.");
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ EGifCloseFile(hGifFile, NULL);
+#else
EGifCloseFile(hGifFile);
+#endif
VSIFCloseL( fp );
return NULL;
}
@@ -756,7 +776,11 @@
/* -------------------------------------------------------------------- */
/* cleanup */
/* -------------------------------------------------------------------- */
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ if (EGifCloseFile(hGifFile, NULL) == GIF_ERROR)
+#else
if (EGifCloseFile(hGifFile) == GIF_ERROR)
+#endif
{
CPLError( CE_Failure, CPLE_AppDefined,
"EGifCloseFile() failed.\n" );
@@ -807,7 +831,11 @@
error:
if (hGifFile)
+#if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5 && GIFLIB_MINOR >= 1
+ EGifCloseFile(hGifFile, NULL);
+#else
EGifCloseFile(hGifFile);
+#endif
if (fp)
VSIFCloseL( fp );
if (pabyScanline)