mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
community/cpuburn: fix
This commit is contained in:
parent
485ce87d93
commit
ea1caa1140
2 changed files with 57 additions and 7 deletions
|
@ -1,4 +1,4 @@
|
|||
# $Id: PKGBUILD 65092 2012-02-20 03:36:44Z spupykin $
|
||||
# $Id$
|
||||
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||
# Contributor: Filip Wojciechowski, filip at loka dot pl
|
||||
|
||||
|
@ -15,12 +15,21 @@ arch=('x86_64')
|
|||
url="https://launchpad.net/ubuntu/+source/cpuburn/"
|
||||
license=('GPL')
|
||||
depends=()
|
||||
source=("https://launchpad.net/ubuntu/+archive/primary/+files/cpuburn_$pkgver.orig.tar.gz")
|
||||
md5sums=('a9e1df40c660324eb08e91847cbc41b9')
|
||||
source=("https://launchpad.net/ubuntu/+archive/primary/+files/cpuburn_$pkgver.orig.tar.gz"
|
||||
cpuburn.patch)
|
||||
md5sums=('a9e1df40c660324eb08e91847cbc41b9'
|
||||
'f3c77db7592ac02ee83958f07ceb8986')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver/ARM"
|
||||
make CC=gcc
|
||||
install -Dm755 burnCortexA8 $pkgdir/usr/bin/burnCortexA8
|
||||
install -Dm755 burnCortexA9 $pkgdir/usr/bin/burnCortexA9
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
patch -Np1 -i ../cpuburn.patch
|
||||
make -C ARM CC=gcc
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
install -Dm755 ARM/burnCortexA8 $pkgdir/usr/bin/burnCortexA8
|
||||
install -Dm755 ARM/burnCortexA9 $pkgdir/usr/bin/burnCortexA9
|
||||
install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
|
||||
install -Dm644 Design "$pkgdir/usr/share/doc/$pkgname/Design"
|
||||
}
|
||||
|
|
41
community/cpuburn/cpuburn.patch
Normal file
41
community/cpuburn/cpuburn.patch
Normal file
|
@ -0,0 +1,41 @@
|
|||
--- cpuburn-1.4.orig/burnP6.S
|
||||
+++ cpuburn-1.4/burnP6.S
|
||||
@@ -69,6 +69,7 @@
|
||||
push %eax # *BSD syscall
|
||||
int $0x80
|
||||
#endif
|
||||
+.data # Data allocation
|
||||
.align 32,0
|
||||
half: .long 0x7fffffff,0
|
||||
e: .long 0xffffffff,0x3fdfffff
|
||||
--- cpuburn-1.4.orig/burnK6.S
|
||||
+++ cpuburn-1.4/burnK6.S
|
||||
@@ -68,6 +68,7 @@
|
||||
push %eax
|
||||
int $0x80
|
||||
#endif
|
||||
+.data # Data allocation
|
||||
.align 32,0
|
||||
half: .long 0x7fffffff,0
|
||||
e: .long 0xffffffff,0x3fdfffff
|
||||
--- cpuburn-1.4.orig/Makefile
|
||||
+++ cpuburn-1.4/Makefile
|
||||
@@ -1,3 +1,3 @@
|
||||
all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
|
||||
.S:
|
||||
- gcc -s -nostdlib -o $@ $<
|
||||
+ gcc -m32 -s -nostdlib -o $@ $<
|
||||
--- cpuburn-1.4.orig/burnK7.S
|
||||
+++ cpuburn-1.4/burnK7.S
|
||||
@@ -74,10 +74,9 @@
|
||||
push %eax
|
||||
int $0x80
|
||||
#endif
|
||||
+.data # Data allocation
|
||||
.align 32,0
|
||||
.fill 64
|
||||
half: .long 0x7fffffff,0
|
||||
e: .long 0xffffffff,0x3fdfffff
|
||||
rt: .long 0xffffffff,0x3fefffff
|
||||
-
|
||||
-
|
Loading…
Reference in a new issue