mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/libreoffice-fresh to 7.3.1-1
This commit is contained in:
parent
8e9744b84a
commit
ea6768fdb9
3 changed files with 6 additions and 150 deletions
|
@ -1,76 +0,0 @@
|
|||
From db43e8a2a02adaa3571137b82855c01fad4c2534 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Wed, 2 Feb 2022 16:21:43 +0000
|
||||
Subject: rhbz#2047319 drop the SolarMutex before QApplication::init()
|
||||
|
||||
https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/24#note_383915
|
||||
|
||||
reproducible with with qt5-qtwayland-5.15.2-17.fc35.x86_64 and
|
||||
export OOO_FORCE_DESKTOP=plasma5
|
||||
export SAL_USE_VCLPLUGIN=gtk3
|
||||
|
||||
Change-Id: Icdf6b8709865c723c266e6400169b33639a1b0e4
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/129428
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
|
||||
---
|
||||
shell/Library_kf5be.mk | 1 +
|
||||
shell/source/backends/kf5be/kf5backend.cxx | 23 +++++++++++++++--------
|
||||
2 files changed, 16 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/shell/Library_kf5be.mk b/shell/Library_kf5be.mk
|
||||
index 628145176e0f..157f8b9836f8 100644
|
||||
--- a/shell/Library_kf5be.mk
|
||||
+++ b/shell/Library_kf5be.mk
|
||||
@@ -20,6 +20,7 @@ $(eval $(call gb_Library_use_libraries,kf5be1,\
|
||||
cppu \
|
||||
cppuhelper \
|
||||
sal \
|
||||
+ vcl \
|
||||
))
|
||||
|
||||
$(eval $(call gb_Library_set_componentfile,kf5be1,shell/source/backends/kf5be/kf5be1))
|
||||
diff --git a/shell/source/backends/kf5be/kf5backend.cxx b/shell/source/backends/kf5be/kf5backend.cxx
|
||||
index e9e10e60fd27..2b41414c54cd 100644
|
||||
--- a/shell/source/backends/kf5be/kf5backend.cxx
|
||||
+++ b/shell/source/backends/kf5be/kf5backend.cxx
|
||||
@@ -41,6 +41,7 @@
|
||||
#include <rtl/ustring.hxx>
|
||||
#include <sal/types.h>
|
||||
#include <uno/current_context.hxx>
|
||||
+#include <vcl/svapp.hxx>
|
||||
|
||||
#include <osl/process.h>
|
||||
#include <osl/thread.h>
|
||||
@@ -172,14 +173,20 @@ void initQApp(std::map<OUString, css::beans::Optional<css::uno::Any>>& rSettings
|
||||
unsetenv("SESSION_MANAGER");
|
||||
}
|
||||
|
||||
- std::unique_ptr<QApplication> app(new QApplication(nFakeArgc, pFakeArgv));
|
||||
- QObject::connect(app.get(), &QObject::destroyed, app.get(), [nFakeArgc, pFakeArgv]() {
|
||||
- for (int i = 0; i < nFakeArgc; ++i)
|
||||
- free(pFakeArgv[i]);
|
||||
- delete[] pFakeArgv;
|
||||
- });
|
||||
-
|
||||
- readKDESettings(rSettings);
|
||||
+ {
|
||||
+ // rhbz#2047319 drop the SolarMutex during the execution of QApplication::init()
|
||||
+ // https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/24#note_383915
|
||||
+ SolarMutexReleaser aReleaser; // rhbz#2047319 drop the SolarMutex during the execution
|
||||
+
|
||||
+ std::unique_ptr<QApplication> app(new QApplication(nFakeArgc, pFakeArgv));
|
||||
+ QObject::connect(app.get(), &QObject::destroyed, app.get(), [nFakeArgc, pFakeArgv]() {
|
||||
+ for (int i = 0; i < nFakeArgc; ++i)
|
||||
+ free(pFakeArgv[i]);
|
||||
+ delete[] pFakeArgv;
|
||||
+ });
|
||||
+
|
||||
+ readKDESettings(rSettings);
|
||||
+ }
|
||||
|
||||
if (session_manager != nullptr)
|
||||
{
|
||||
--
|
||||
cgit v1.2.1
|
||||
|
|
@ -1,56 +0,0 @@
|
|||
From 5fd5e42bf28a7910321c6b6d76257e7386839fbc Mon Sep 17 00:00:00 2001
|
||||
From: Michael Weghorn <m.weghorn@posteo.de>
|
||||
Date: Wed, 16 Feb 2022 13:38:47 +0100
|
||||
Subject: configure.ac: Update kf5 include/lib check to work with KF5 >= 5.91
|
||||
|
||||
The 'kcoreaddons_version.h' header was moved to the 'KCoreAddons'
|
||||
subdirectory in kcoreaddons commit
|
||||
|
||||
commit d971ba9bb27a3e8f18a116692fdf98c1729ac244
|
||||
Author: Ahmad Samir <a.samirh78@gmail.com>
|
||||
Date: Sat Jan 15 14:14:13 2022 +0200
|
||||
|
||||
Install kcoreaddons_version.h in /usr/include/KF5/KCoreAddons/
|
||||
|
||||
Instead of /usr/include/KF5/kcoreaddons_version.h.
|
||||
|
||||
For more details see:
|
||||
https://invent.kde.org/frameworks/kservice/-/merge_requests/79
|
||||
|
||||
GIT_SILENT
|
||||
|
||||
Adapt the KF5 check to check for the 'KFileWidget' header and
|
||||
the 'libKF5KIOFileWidgets.so' library instead.
|
||||
This is more exact anyway, since we require KIOFileWidgets,
|
||||
and the previous check didn't ensure that.
|
||||
(So in case only KF5CoreAddons but not KIOFileWidgets was installed,
|
||||
configure would previously pass, but the build fail.)
|
||||
|
||||
[1] https://invent.kde.org/frameworks/kcoreaddons/-/commit/d971ba9bb27a3e8f18a116692fdf98c1729ac244
|
||||
|
||||
Change-Id: I7ecf7f29dce85e1a6e6b0d4f2519fa37ab04ca84
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/129996
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 6acb3107cea3..4e84f9a33980 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -13017,8 +13017,8 @@ then
|
||||
kf5_libdirs="$kf5_libdirs /usr/lib64 /usr/lib64/kf5 /usr/lib64/kf5/devel"
|
||||
fi
|
||||
|
||||
- kf5_test_include="KF5/kcoreaddons_version.h"
|
||||
- kf5_test_library="libKF5CoreAddons.so"
|
||||
+ kf5_test_include="KF5/KIOFileWidgets/KFileWidget"
|
||||
+ kf5_test_library="libKF5KIOFileWidgets.so"
|
||||
kf5_libdirs="$qt5_libdir $kf5_libdirs"
|
||||
|
||||
dnl kf5 KDE4 support compatibility installed
|
||||
--
|
||||
cgit v1.2.1
|
||||
|
|
@ -18,9 +18,9 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
|
|||
|
||||
pkgbase=libreoffice-fresh
|
||||
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
|
||||
_LOver=7.3.0.3
|
||||
pkgver=7.3.0
|
||||
pkgrel=7
|
||||
_LOver=7.3.1.3
|
||||
pkgver=7.3.1
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
license=('LGPL3')
|
||||
url="https://www.libreoffice.org/"
|
||||
|
@ -69,8 +69,6 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
|
|||
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
|
||||
poppler-22.03.0.patch
|
||||
make-pyuno-work-with-system-wide-module-install.diff
|
||||
0001_drop_the_SolarMutex_before_QApplication.patch
|
||||
0002_update_kf5_include_lib_check.patch
|
||||
0003_tdf147611_fix_indices.patch
|
||||
soffice-template.desktop.in
|
||||
libreoffice-fresh.sh libreoffice-fresh.csh)
|
||||
|
@ -86,7 +84,6 @@ noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
|||
dtoa-20180411.tgz
|
||||
lxml-4.1.1.tgz
|
||||
Firebird-3.0.7.33374-0.tar.bz2
|
||||
#zxing-cpp-1.1.1.tar.gz
|
||||
skia-m97-a7230803d64ae9d44f4e1282444801119a3ae967.tar.xz
|
||||
libcmis-0.5.2.tar.xz
|
||||
8249374c274932a21846fa7629c2aa9b-officeotron-0.7.4-master.jar # for test suite
|
||||
|
@ -95,11 +92,11 @@ noextract=(35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
|
|||
185d60944ea767075d27247c3162b3bc-unowinreg.dll
|
||||
)
|
||||
validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
|
||||
sha256sums=('98d369c9541f0c3286345b93f448f2ceb2e344865ee01bdd58f3bb27f08f3f25'
|
||||
sha256sums=('6b57f6822a8571a8bd984b4dc048f519c2143c769714dbd491f60b8cc71f51a2'
|
||||
'SKIP'
|
||||
'53b091291b1a857e98db9332386322ffa1410932b53215fa8eecb7acd96d931b'
|
||||
'34fb4c3f5ba76deefe409d14c027899a1014fd8ffff057238ba37c1dd17baaaa'
|
||||
'SKIP'
|
||||
'43e9d768af1a74242455741670a70bd9f3a1e01ec4599caddb16e0825614e7fe'
|
||||
'e9b4b8ccf89ba92ad031ab909cd1dc2419aa83948ed7bf4694215a247535124e'
|
||||
'SKIP'
|
||||
'64585ac36a81291a58269ec5347e7e3e2e8596dbacb9221015c208191333c6e1'
|
||||
'1fb458d6aab06932693cc8a9b6e4e70944ee1ff052fa63606e3131df34e21753'
|
||||
|
@ -121,8 +118,6 @@ sha256sums=('98d369c9541f0c3286345b93f448f2ceb2e344865ee01bdd58f3bb27f08f3f25'
|
|||
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
|
||||
'e61e2a266c7a4374377475254a2f095c1ce2376980b301955a4e5a0d32d3c25b'
|
||||
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
|
||||
'81a8551aaea0ab1750d36fb8bfbd04340a43eaab349a43c1384d21ef6504ab47'
|
||||
'1cc5aeac9b8e91786701727d97b58039afc3db3dbc7977a3651d3263240798b3'
|
||||
'a825f71f71658d18a31f2331351e9310d8996501cab79f411a0c7b9c1b53c70c'
|
||||
'd0be8099cbee3c9dfda694a828149b881c345b204ab68826f317580aafb50879'
|
||||
'cd1b25ff390e436c6bffa65c6e12382236e3ccbf8d3aae51b1b59bcaed79fd8a'
|
||||
|
@ -149,13 +144,6 @@ prepare() {
|
|||
# fix not upstreamable pyuno paths - FS#54250
|
||||
patch -Np1 -i "${srcdir}"/make-pyuno-work-with-system-wide-module-install.diff
|
||||
|
||||
# fix crash on start - FS#73471
|
||||
patch -Np1 -i "${srcdir}"/0001_drop_the_SolarMutex_before_QApplication.patch
|
||||
|
||||
# fix kf5 chances
|
||||
# https://cgit.freedesktop.org/libreoffice/core/commit/?id=5fd5e42bf28a7910321c6b6d76257e7386839fbc
|
||||
patch -Np1 -i "${srcdir}"/0002_update_kf5_include_lib_check.patch
|
||||
|
||||
# https://bugs.archlinux.org/task/73987
|
||||
# https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-7-3&id=e85d2140ae5e9a611754c29aa4e5cdb6ad7fcab0
|
||||
patch -Np1 -i "${srcdir}"/0003_tdf147611_fix_indices.patch
|
||||
|
|
Loading…
Reference in a new issue