mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/openscenegraph to 3.4.0-1
This commit is contained in:
parent
5ca634e482
commit
ea6a0115c5
2 changed files with 7 additions and 42 deletions
|
@ -8,37 +8,24 @@
|
|||
# - build v5/6/7 for GLES
|
||||
|
||||
pkgname=openscenegraph
|
||||
pkgver=3.2.3
|
||||
pkgver=3.4.0
|
||||
pkgrel=1
|
||||
pkgdesc="An Open Source, high performance real-time graphics toolkit"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('custom:OSGPL')
|
||||
url="http://www.openscenegraph.org"
|
||||
depends=('giflib' 'jasper' 'librsvg' 'xine-lib' 'curl' 'pth')
|
||||
makedepends=('cmake' 'libvncserver' 'qt5-base' 'ffmpeg-compat' 'mesa')
|
||||
optdepends=('libvncserver' 'gdal' 'openexr' 'poppler-glib' 'qt5-base' 'ffmpeg-compat')
|
||||
makedepends=('cmake' 'libvncserver' 'qt5-base' 'ffmpeg' 'mesa')
|
||||
optdepends=('libvncserver' 'gdal' 'openexr' 'poppler-glib' 'qt5-base' 'ffmpeg')
|
||||
conflicts=('openthreads')
|
||||
provides=('openthreads')
|
||||
#source=(http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-$pkgver/source/OpenSceneGraph-$pkgver.zip
|
||||
source=(http://trac.openscenegraph.org/downloads/developer_releases/OpenSceneGraph-$pkgver.zip
|
||||
https://github.com/openscenegraph/osg/commit/49d560f4d9d0641c98df67264b7ace4733c6b9a9.patch
|
||||
giflib.patch)
|
||||
md5sums=('02ffdad7744c747d8fad0d7babb58427'
|
||||
'6e3c75677f87113f18912916352c6cbd'
|
||||
'8c06c8410e8840e83c242b8b401cdad7')
|
||||
|
||||
prepare() {
|
||||
cd OpenSceneGraph-$pkgver
|
||||
# patch -p1 <$srcdir/giflib.patch
|
||||
# patch -p1 <$srcdir/49d560f4d9d0641c98df67264b7ace4733c6b9a9.patch
|
||||
}
|
||||
source=(http://trac.openscenegraph.org/downloads/developer_releases/OpenSceneGraph-$pkgver.zip)
|
||||
md5sums=('a5e762c64373a46932e444f6f7332496')
|
||||
|
||||
build() {
|
||||
cd OpenSceneGraph-$pkgver
|
||||
export PKG_CONFIG_PATH=/usr/lib/ffmpeg-compat/pkgconfig:$PKG_CONFIG_PATH
|
||||
LDFLAGS="$LDFLAGS -Wl,-rpath -Wl,/usr/lib/ffmpeg-compat"
|
||||
CFLAGS="$CFLAGS -D__STDC_CONSTANT_MACROS"
|
||||
CXXFLAGS="$CXXFLAGS -D__STDC_CONSTANT_MACROS"
|
||||
# CFLAGS="$CFLAGS -D__STDC_CONSTANT_MACROS"
|
||||
# CXXFLAGS="$CXXFLAGS -D__STDC_CONSTANT_MACROS"
|
||||
|
||||
if [[ $CARCH != "aarch64" ]]; then
|
||||
GLES_ONLY=(
|
||||
|
@ -62,16 +49,6 @@ build() {
|
|||
[ $NOEXTRACT -eq 1 ] || cmake . \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DFFMPEG_LIBAVCODEC_INCLUDE_DIRS=/usr/include/ffmpeg-compat \
|
||||
-DFFMPEG_LIBAVCODEC_LIBRARIES=/usr/lib/ffmpeg-compat/libavcodec.so \
|
||||
-DFFMPEG_LIBAVDEVICE_INCLUDE_DIRS=/usr/include/ffmpeg-compat \
|
||||
-DFFMPEG_LIBAVDEVICE_LIBRARIES=/usr/lib/ffmpeg-compat/libavdevice.so \
|
||||
-DFFMPEG_LIBAVFORMAT_INCLUDE_DIRS=/usr/include/ffmpeg-compat \
|
||||
-DFFMPEG_LIBAVFORMAT_LIBRARIES=/usr/lib/ffmpeg-compat/libavformat.so \
|
||||
-DFFMPEG_LIBAVUTIL_INCLUDE_DIRS=/usr/include/ffmpeg-compat \
|
||||
-DFFMPEG_LIBAVUTIL_LIBRARIES=/usr/lib/ffmpeg-compat/libavutil.so \
|
||||
-DFFMPEG_LIBSWSCALE_INCLUDE_DIRS=/usr/include/ffmpeg-compat \
|
||||
-DFFMPEG_LIBSWSCALE_LIBRARIES=/usr/lib/ffmpeg-compat/libswscale.so \
|
||||
${GLES_ONLY[@]}
|
||||
|
||||
# sed -i 's|#include <curl/types.h>|//#include <curl/types.h>|' src/osgPlugins/curl/ReaderWriterCURL.cpp
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff -wbBur OpenSceneGraph-3.2.0/src/osgPlugins/gif/ReaderWriterGIF.cpp OpenSceneGraph-3.2.0.q/src/osgPlugins/gif/ReaderWriterGIF.cpp
|
||||
--- OpenSceneGraph-3.2.0/src/osgPlugins/gif/ReaderWriterGIF.cpp 2013-06-03 18:04:02.000000000 +0400
|
||||
+++ OpenSceneGraph-3.2.0.q/src/osgPlugins/gif/ReaderWriterGIF.cpp 2014-05-29 19:00:40.163985068 +0400
|
||||
@@ -561,7 +561,7 @@
|
||||
*width_ret = giffile->SWidth;
|
||||
*height_ret = giffile->SHeight;
|
||||
*numComponents_ret = 4;
|
||||
- DGifCloseFile(giffile);
|
||||
+ DGifCloseFile(giffile, NULL);
|
||||
return buffer;
|
||||
}
|
||||
|
Loading…
Reference in a new issue