mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
added core/glib2
This commit is contained in:
parent
eba5bbda85
commit
ea6e7a6447
5 changed files with 152 additions and 0 deletions
25
core/glib2/0001-arm-atomic.patch
Normal file
25
core/glib2/0001-arm-atomic.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From 5a422c572991549f0d063af09b6fe0b6b7e958a3 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 7 Sep 2018 20:03:35 -0600
|
||||
Subject: [PATCH] arm atomic
|
||||
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index aa7d8e4f7..f102127fc 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1555,7 +1555,7 @@ else
|
||||
error('GLib must be built with -march=i486 or later.')
|
||||
endif
|
||||
endif
|
||||
-glibconfig_conf.set('G_ATOMIC_LOCK_FREE', have_atomic_lock_free)
|
||||
+#glibconfig_conf.set('G_ATOMIC_LOCK_FREE', have_atomic_lock_free)
|
||||
|
||||
# === Threads ===
|
||||
|
||||
--
|
||||
2.18.0
|
||||
|
80
core/glib2/PKGBUILD
Normal file
80
core/glib2/PKGBUILD
Normal file
|
@ -0,0 +1,80 @@
|
|||
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
|
||||
pkgbase=glib2
|
||||
pkgname=(glib2 glib2-docs)
|
||||
pkgver=2.58.0+31+g2a7d4d2dc
|
||||
pkgrel=1
|
||||
pkgdesc="Low level core library"
|
||||
url="https://wiki.gnome.org/Projects/GLib"
|
||||
license=(LGPL2.1)
|
||||
arch=(x86_64)
|
||||
depends=(pcre libffi libutil-linux zlib)
|
||||
makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux meson dbus)
|
||||
checkdepends=(desktop-file-utils)
|
||||
optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
|
||||
'libelf: gresource inspection tool')
|
||||
options=(!emptydirs)
|
||||
_commit=2a7d4d2dcb1f2fc018a433b039e4aaca91b4f0a6 # glib-2-58
|
||||
source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
|
||||
noisy-glib-compile-schemas.diff
|
||||
glib-compile-schemas.hook gio-querymodules.hook
|
||||
0001-arm-atomic.patch)
|
||||
sha256sums=('SKIP'
|
||||
'81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531'
|
||||
'e1123a5d85d2445faac33f6dae1085fdd620d83279a4e130a83fe38db52b62b3'
|
||||
'5ba204a2686304b1454d401a39a9d27d09dd25e4529664e3fd565be3d439f8b6'
|
||||
'fdd5e589e3c38903cfae63eaf37cd9c51304ce971c97553ca1f2c9083a0d61b0')
|
||||
|
||||
pkgver() {
|
||||
cd glib
|
||||
git describe --tags | sed 's/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd glib
|
||||
|
||||
# Suppress noise from glib-compile-schemas.hook
|
||||
patch -Np1 -i ../noisy-glib-compile-schemas.diff
|
||||
|
||||
if [[ $CARCH == "arm" ]]; then
|
||||
patch -Np1 -i ../0001-arm-atomic.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
arch-meson glib build \
|
||||
-D selinux=false \
|
||||
-D man=true \
|
||||
-D gtk_doc=true
|
||||
ninja -C build
|
||||
}
|
||||
|
||||
check() {
|
||||
meson test -C build -t 2
|
||||
}
|
||||
|
||||
package_glib2() {
|
||||
DESTDIR="$pkgdir" meson install -C build
|
||||
install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
|
||||
|
||||
python -m compileall -d /usr/share/glib-2.0/codegen "$pkgdir/usr/share/glib-2.0/codegen"
|
||||
python -O -m compileall -d /usr/share/glib-2.0/codegen "$pkgdir/usr/share/glib-2.0/codegen"
|
||||
|
||||
# Split docs
|
||||
mv "$pkgdir/usr/share/gtk-doc" "$srcdir"
|
||||
}
|
||||
|
||||
package_glib2-docs() {
|
||||
pkgdesc="Documentation for GLib"
|
||||
depends=()
|
||||
optdepends=()
|
||||
license+=(custom)
|
||||
|
||||
mkdir -p "$pkgdir/usr/share"
|
||||
mv gtk-doc "$pkgdir/usr/share"
|
||||
|
||||
install -Dt "$pkgdir/usr/share/licenses/glib2-docs" -m644 glib/docs/reference/COPYING
|
||||
}
|
||||
|
||||
# vim:set sw=2 et:
|
11
core/glib2/gio-querymodules.hook
Normal file
11
core/glib2/gio-querymodules.hook
Normal file
|
@ -0,0 +1,11 @@
|
|||
[Trigger]
|
||||
Type = File
|
||||
Operation = Install
|
||||
Operation = Upgrade
|
||||
Operation = Remove
|
||||
Target = usr/lib/gio/modules/*.so
|
||||
|
||||
[Action]
|
||||
Description = Updating GIO module cache...
|
||||
When = PostTransaction
|
||||
Exec = /usr/bin/gio-querymodules /usr/lib/gio/modules
|
12
core/glib2/glib-compile-schemas.hook
Normal file
12
core/glib2/glib-compile-schemas.hook
Normal file
|
@ -0,0 +1,12 @@
|
|||
[Trigger]
|
||||
Type = File
|
||||
Operation = Install
|
||||
Operation = Upgrade
|
||||
Operation = Remove
|
||||
Target = usr/share/glib-2.0/schemas/*.gschema.xml
|
||||
Target = usr/share/glib-2.0/schemas/*.gschema.override
|
||||
|
||||
[Action]
|
||||
Description = Compiling GSettings XML schema files...
|
||||
When = PostTransaction
|
||||
Exec = /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
|
24
core/glib2/noisy-glib-compile-schemas.diff
Normal file
24
core/glib2/noisy-glib-compile-schemas.diff
Normal file
|
@ -0,0 +1,24 @@
|
|||
diff --git i/gio/glib-compile-schemas.c w/gio/glib-compile-schemas.c
|
||||
index b8de0907248f6860..130f89b1728f7932 100644
|
||||
--- i/gio/glib-compile-schemas.c
|
||||
+++ w/gio/glib-compile-schemas.c
|
||||
@@ -1219,19 +1219,6 @@ parse_state_start_schema (ParseState *state,
|
||||
return;
|
||||
}
|
||||
|
||||
- if (path && (g_str_has_prefix (path, "/apps/") ||
|
||||
- g_str_has_prefix (path, "/desktop/") ||
|
||||
- g_str_has_prefix (path, "/system/")))
|
||||
- {
|
||||
- gchar *message = NULL;
|
||||
- message = g_strdup_printf (_("Warning: Schema “%s” has path “%s”. "
|
||||
- "Paths starting with "
|
||||
- "“/apps/”, “/desktop/” or “/system/” are deprecated."),
|
||||
- id, path);
|
||||
- g_printerr ("%s\n", message);
|
||||
- g_free (message);
|
||||
- }
|
||||
-
|
||||
state->schema_state = schema_state_new (path, gettext_domain,
|
||||
extends, extends_name, list_of);
|
||||
|
Loading…
Reference in a new issue