mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/jupyterlab to 3.3.2-3
This commit is contained in:
parent
e45fbe3c4c
commit
eac27b69db
2 changed files with 29 additions and 5 deletions
|
@ -6,19 +6,25 @@
|
|||
pkgname=jupyterlab
|
||||
_pipname=jupyterlab
|
||||
pkgver=3.3.2
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc='JupyterLab computational environment'
|
||||
arch=(any)
|
||||
url='https://github.com/jupyterlab/jupyterlab'
|
||||
license=(custom)
|
||||
makedepends=(python-build python-installer)
|
||||
depends=(python-jupyterlab_server python-jupyter_packaging jupyter-nbclassic nodejs)
|
||||
depends=(python-jupyterlab_server python-jupyter_packaging jupyter-notebook-shim nodejs)
|
||||
optdepends=('npm: to install extensions' 'jupyterlab-widgets: ipywidgets support')
|
||||
source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz)
|
||||
sha256sums=('3c716bf5592cb28c5c55c615c6e5bd3efc71898f6957d13719b56478bbbb587a')
|
||||
checkdepends=('python-pytest-tornasync' 'npm')
|
||||
source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz
|
||||
no-nbclassic.patch
|
||||
jupyterlab-fix-tests.patch::https://github.com/jupyterlab/jupyterlab/commit/56b437fc.patch)
|
||||
sha256sums=('3c716bf5592cb28c5c55c615c6e5bd3efc71898f6957d13719b56478bbbb587a'
|
||||
'923954cca5ac139091f3a6c7c922c3bf3b4173375bb28a1cc016f74f82869d7e'
|
||||
'5db8f09ecb71ca93c09d050940c9767218bf4ffc5368225eb7ebd72a7f02ed90')
|
||||
|
||||
prepare() {
|
||||
sed -e 's|nbclassic~=0.2|nbclassic|' -i $pkgname-$pkgver/setup.cfg # Remove dependency version constraint
|
||||
patch -d $pkgname-$pkgver -p1 < no-nbclassic.patch # Drop nbclassic dependency
|
||||
patch -d $pkgname-$pkgver -p1 < jupyterlab-fix-tests.patch # Fix tests
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -27,6 +33,11 @@ build() {
|
|||
python -m build --wheel --no-isolation
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname-$pkgver
|
||||
pytest -v -k 'not test_build'
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
python -m installer --destdir="$pkgdir" dist/*.whl
|
||||
|
|
13
community/jupyterlab/no-nbclassic.patch
Normal file
13
community/jupyterlab/no-nbclassic.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/jupyterlab/labapp.py b/jupyterlab/labapp.py
|
||||
index 75af58179c..df2bcdc4cd 100644
|
||||
--- a/jupyterlab/labapp.py
|
||||
+++ b/jupyterlab/labapp.py
|
||||
@@ -14,7 +14,7 @@ from jupyter_server.serverapp import flags
|
||||
from jupyter_server.utils import url_path_join as ujoin
|
||||
|
||||
from jupyterlab_server import LabServerApp, LicensesApp, WorkspaceExportApp, WorkspaceImportApp, WorkspaceListApp
|
||||
-from nbclassic.shim import NBClassicConfigShimMixin
|
||||
+from notebook_shim.shim import NotebookConfigShimMixin as NBClassicConfigShimMixin
|
||||
from traitlets import Bool, Instance, Unicode, default
|
||||
|
||||
from ._version import __version__
|
Loading…
Reference in a new issue