extra/firefox to 88.0-1

This commit is contained in:
Kevin Mihelich 2021-04-20 00:24:16 +00:00
parent e9c535f21e
commit eadb42d739
3 changed files with 6 additions and 45 deletions

View file

@ -9,10 +9,10 @@ Subject: [PATCH] Use remoting name for GDK application names
2 files changed, 6 insertions(+), 12 deletions(-)
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
index 27a81620e3ec5..0162744d5c54d 100644
index 5eb43aa0ae632..ff331c3b2076e 100644
--- a/toolkit/xre/nsAppRunner.cpp
+++ b/toolkit/xre/nsAppRunner.cpp
@@ -4285,11 +4285,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
@@ -4363,11 +4363,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
// consistently.
// Set program name to the one defined in application.ini.

View file

@ -1,34 +0,0 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Bryce Seager van Dyk <bvandyk@mozilla.com>
Date: Fri, 26 Mar 2021 19:06:00 +0000
Subject: [PATCH] Bug 1701089 - Accept "vp09" codec string in Widevine
manifest. r=mjf, a=RyanVM
Differential Revision: https://phabricator.services.mozilla.com/D109810
---
dom/media/gmp/GMPParent.cpp | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/dom/media/gmp/GMPParent.cpp b/dom/media/gmp/GMPParent.cpp
index 2e7f80d368134..1acb0ac18eff6 100644
--- a/dom/media/gmp/GMPParent.cpp
+++ b/dom/media/gmp/GMPParent.cpp
@@ -884,15 +884,16 @@ RefPtr<GenericPromise> GMPParent::ParseChromiumManifest(
//
// Google's code to parse manifests can be used as a reference for strings
// the manifest may contain
- // https://cs.chromium.org/chromium/src/chrome/common/media/cdm_manifest.cc?l=73&rcl=393e60bfc2299449db7ef374c0ef1c324716e562
+ // https://source.chromium.org/chromium/chromium/src/+/master:components/cdm/common/cdm_manifest.cc;l=74;drc=775880ced8a989191281e93854c7f2201f25068f
//
// Gecko's internal strings can be found at
// https://searchfox.org/mozilla-central/rev/ea63a0888d406fae720cf24f4727d87569a8cab5/dom/media/eme/MediaKeySystemAccess.cpp#149-155
for (const nsCString& chromiumCodec : codecs) {
nsCString codec;
if (chromiumCodec.EqualsASCII("vp8")) {
codec = "vp8"_ns;
- } else if (chromiumCodec.EqualsASCII("vp9.0")) {
+ } else if (chromiumCodec.EqualsASCII("vp9.0") || // Legacy string.
+ chromiumCodec.EqualsASCII("vp09")) {
codec = "vp9"_ns;
} else if (chromiumCodec.EqualsASCII("avc1")) {
codec = "h264"_ns;

View file

@ -10,8 +10,8 @@ buildarch=12
highmem=1
pkgname=firefox
pkgver=87.0
pkgrel=2
pkgver=88.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
@ -30,14 +30,12 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-
arm.patch
build-arm-libopus.patch
0001-Use-remoting-name-for-GDK-application-names.patch
0002-Bug-1701089-Accept-vp09-codec-string-in-Widevine-man.patch
$pkgname.desktop)
sha256sums=('ce98be0522f971b6950f22c738c4b2caf19cf7f48ab2ae2e6d46694af7fd58ab'
sha256sums=('6b50dbfb393f843e4401e23965a1d8f7fd44b5a7628d95138294094094eee297'
'SKIP'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'1375163e9a21f75cfadb8ee77ca3d7f5f2405bfa5ec3940d8153f89d55e94e5f'
'2af9ddd8969b7143f112caa24d07a88e5ea0ac17e8adc32f2e92a58830a18a68'
'1b6814e85f13dcf069482ad1acfc1a099661922c85e3344aa4ee059288506ccc'
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@ -61,9 +59,6 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1704022
patch -Np1 -i ../0002-Bug-1701089-Accept-vp09-codec-string-in-Widevine-man.patch
echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key