extra/chromium to 52.0.2743.116-1

This commit is contained in:
Kevin Mihelich 2016-08-17 12:31:59 +00:00
parent 46af3653ff
commit eaedc91d1d
2 changed files with 24 additions and 3 deletions

View file

@ -19,8 +19,8 @@ buildarch=12
highmem=1
pkgname=chromium
pkgver=52.0.2743.85
pkgrel=2
pkgver=52.0.2743.116
pkgrel=1
_launcher_ver=3
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
arch=('armv6h' 'armv7h')
@ -43,13 +43,15 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium.desktop
chromium-widevine.patch
PNGImageDecoder.patch
chromium-52.0.2743.116-unset-madv_free.patch
0001-system-ffmpeg-fixes.patch
0002-Linux-Sandbox-whitelist-arm64-syscalls.patch)
sha256sums=('b70e3e77d8d80fbe2303c889d557864f576709ebb543f402b77bad6d6c74edc3'
sha256sums=('a194ae1edb041024b3d4b6ba438f32fefdb6f1ecb24a96c50248a486b237a101'
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
'd9fd982ba6d50edb7743db6122b975ad1d3da5a9ad907c8ab7cf574395b186cd'
'3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227'
'2c9f39c04397898711ba9d5e008cf11e909d479e9af0627d4534206051cc77ef'
'b2d301f48f603bd7b9ae5802aa9211a6a7991ea94e0e725b4c4272bdfd6c35db')
@ -91,6 +93,10 @@ prepare() {
## https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/BNGvJc08B6Q
#find third_party/icu -type f \! -regex '.*\.\(gyp\|gypi\|isolate\)' -delete
# Disable MADV_FREE (if set by glibc)
# https://bugzilla.redhat.com/show_bug.cgi?id=1361157
patch -p1 -i "$srcdir"/chromium-52.0.2743.116-unset-madv_free.patch
[[ $CARCH == "armv7h" ]] && MAKEFLAGS=-j4
# Use Python 2

View file

@ -0,0 +1,15 @@
diff -up chromium-52.0.2743.116/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp.madv_free chromium-52.0.2743.116/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp
--- chromium-52.0.2743.116/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp.madv_free 2016-08-15 13:07:29.279655676 -0400
+++ chromium-52.0.2743.116/third_party/WebKit/Source/wtf/allocator/PageAllocator.cpp 2016-08-15 13:08:38.447317416 -0400
@@ -41,6 +41,11 @@
#include <errno.h>
#include <sys/mman.h>
+#if OS(LINUX) && defined(MADV_FREE)
+// Added in Linux 4.5, but it breaks the sandbox.
+#undef MADV_FREE
+#endif
+
#ifndef MADV_FREE
#define MADV_FREE MADV_DONTNEED
#endif