mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/krita to 4.1.1-1
This commit is contained in:
parent
d7111f0180
commit
eb4536fa9a
2 changed files with 5 additions and 28 deletions
|
@ -5,8 +5,8 @@
|
||||||
# - remove makedepend on vc
|
# - remove makedepend on vc
|
||||||
|
|
||||||
pkgname=krita
|
pkgname=krita
|
||||||
pkgver=4.1.0
|
pkgver=4.1.1
|
||||||
pkgrel=2
|
pkgrel=1
|
||||||
pkgdesc="Edit and paint images"
|
pkgdesc="Edit and paint images"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url="https://krita.org"
|
url="https://krita.org"
|
||||||
|
@ -17,17 +17,13 @@ optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations' 'opencolorio:
|
||||||
"krita-plugin-gmic: G'MIC plugin" 'python-pyqt5: for the Python plugins' 'libheif: HEIF filter')
|
"krita-plugin-gmic: G'MIC plugin" 'python-pyqt5: for the Python plugins' 'libheif: HEIF filter')
|
||||||
conflicts=(calligra-krita krita-l10n)
|
conflicts=(calligra-krita krita-l10n)
|
||||||
replaces=(calligra-krita krita-l10n)
|
replaces=(calligra-krita krita-l10n)
|
||||||
source=("https://download.kde.org/stable/krita/$pkgver/$pkgname-$pkgver.tar.gz"{,.sig}
|
source=("https://download.kde.org/stable/krita/$pkgver/$pkgname-$pkgver.tar.gz"{,.sig})
|
||||||
krita-pyqt5.11.patch)
|
sha256sums=('5cab10343f97a9944a1ab2e137cd0ade6029ce157118009660af286eb75ce9e3'
|
||||||
sha256sums=('78792df8165b986b806dcf9960a2679f683f2263e06f3ad5a24b0f78d8f27ed5'
|
'SKIP')
|
||||||
'SKIP'
|
|
||||||
'37aa93119c759d80829112f169f64c47450f218e0fe05fc2e16ae54ff8170db2')
|
|
||||||
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD') # Boudewijn Rempt <foundation@krita.org>
|
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD') # Boudewijn Rempt <foundation@krita.org>
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
mkdir -p build
|
mkdir -p build
|
||||||
cd $pkgname-$pkgver
|
|
||||||
patch -p1 -i ../krita-pyqt5.11.patch # Fix python plugins with PyQt 5.11
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
|
@ -1,19 +0,0 @@
|
||||||
diff --git a/plugins/extensions/pykrita/sip/CMakeLists.txt b/plugins/extensions/pykrita/sip/CMakeLists.txt
|
|
||||||
index 1f47f0af1c..d5a24f86ee 100644
|
|
||||||
--- a/plugins/extensions/pykrita/sip/CMakeLists.txt
|
|
||||||
+++ b/plugins/extensions/pykrita/sip/CMakeLists.txt
|
|
||||||
@@ -12,9 +12,13 @@ set(SIP_INCLUDES
|
|
||||||
${PYQT_SIP_DIR_OVERRIDE}
|
|
||||||
./krita)
|
|
||||||
|
|
||||||
+if(${PYQT5_VERSION} STRGREATER_EQUAL "050b00")
|
|
||||||
+ set(SIP_NAME -n PyQt5.sip)
|
|
||||||
+endif()
|
|
||||||
+
|
|
||||||
set(SIP_CONCAT_PARTS 1)
|
|
||||||
set(SIP_TAGS ALL WS_X11 ${PYQT5_VERSION_TAG})
|
|
||||||
-set(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector)
|
|
||||||
+set(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector ${SIP_NAME})
|
|
||||||
|
|
||||||
set(PYTHON_SITE_PACKAGES_INSTALL_DIR ${LIB_INSTALL_DIR}/krita-python-libs)
|
|
||||||
file(GLOB PYKRITA_KRITA_sip_files ./krita/*.sip)
|
|
Loading…
Reference in a new issue