mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/qt5-base to 5.7.1-1
This commit is contained in:
parent
fac06302a8
commit
eb664d29da
2 changed files with 3 additions and 39 deletions
|
@ -8,9 +8,9 @@
|
|||
# - use OpenGLES 2.0
|
||||
|
||||
pkgname=qt5-base
|
||||
_qtver=5.7.0
|
||||
_qtver=5.7.1
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=9
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL3' 'FDL' 'custom')
|
||||
|
@ -32,19 +32,9 @@ conflicts=('qtchooser')
|
|||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-opensource-src-${_qtver}"
|
||||
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||
qtbug-53071.patch::"https://github.com/qtproject/qtbase/commit/e9041c7fc.patch"
|
||||
qtbug-53071b.patch::"https://github.com/qtproject/qtbase/commit/cd25866f.patch"
|
||||
qtbug-53237.patch::"https://github.com/qtproject/qtbase/commit/8e889378.patch"
|
||||
qtbug-49452.patch::"https://github.com/qt/qtbase/commit/6f423555.patch"
|
||||
qtbase-memory-leak.patch::"https://github.com/qt/qtbase/commit/42283868.patch"
|
||||
qtbug-49061.patch::"https://github.com/qt/qtbase/commit/494376f9.patch"
|
||||
qtbug-55583.patch::"https://github.com/qt/qtbase/commit/84ea00d4.patch")
|
||||
md5sums=('184f9460b40752d71b15b827260580c2'
|
||||
'462f079cd46f869def6858903a718bf5'
|
||||
'da4fd787ea877516397a027412e975e1'
|
||||
'981255fb1aea0d3c0b5c5f306fe374da'
|
||||
'646aea77ca90031c453a65ef61db55f9'
|
||||
'9842c327b091b360da7a4d90f5fdf4da'
|
||||
md5sums=('f0809befe04160fbb73bbf38a06a2073'
|
||||
'c86af27562bbbe05c3defd63d00130fd'
|
||||
'7b11584d9ea1ccb6c419e9b9816dee63')
|
||||
|
||||
|
@ -65,19 +55,6 @@ prepare() {
|
|||
# Fix libsystemd-journal detection
|
||||
sed -e 's|libsystemd-journal|libsystemd|' -i config.tests/unix/journald/journald.pro -i src/corelib/global/global.pri
|
||||
|
||||
# Fix parsing of tzfile(5) POSIX rule zone names with bracket quotes
|
||||
patch -p1 -i ../qtbug-53071.patch
|
||||
patch -p1 -i ../qtbug-53071b.patch
|
||||
|
||||
# Fix UNSIGNED values in QMYSQL
|
||||
patch -p1 -i ../qtbug-53237.patch
|
||||
|
||||
# Fix freetype engine performance
|
||||
patch -p1 -i ../qtbug-49452.patch
|
||||
|
||||
# Fix memory leak
|
||||
patch -p1 -i ../qtbase-memory-leak.patch
|
||||
|
||||
# Don't unload plugins in QPluginLoader https://bugreports.qt.io/browse/QTBUG-49061
|
||||
patch -p1 -i ../qtbug-49061.patch
|
||||
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff --git a/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp b/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp
|
||||
index db264d1..e3cb2f3 100644
|
||||
--- a/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp
|
||||
+++ b/src/platformsupport/themes/genericunix/qgenericunixthemes.cpp
|
||||
@@ -814,7 +814,7 @@ QStringList QGenericUnixTheme::themeNames()
|
||||
#ifndef QT_NO_SETTINGS
|
||||
result.push_back(QLatin1String(QKdeTheme::name));
|
||||
#endif
|
||||
- } else if (gtkBasedEnvironments.contains(desktopName)) {
|
||||
+ } else if (gtkBasedEnvironments.contains(desktopName) && QString::fromLocal8Bit(qgetenv("XDG_SESSION_TYPE")) != QLatin1String("wayland")) {
|
||||
// prefer the GTK3 theme implementation with native dialogs etc.
|
||||
result.push_back(QStringLiteral("gtk3"));
|
||||
// fallback to the generic Gnome theme if loading the GTK3 theme fails
|
Loading…
Reference in a new issue