mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/irqbalance to 1.2.0-1
This commit is contained in:
parent
de30ac9181
commit
eba7b40852
3 changed files with 38 additions and 28 deletions
|
@ -0,0 +1,32 @@
|
|||
From b0f77c10fc4561463b59b12cba0bfd69d7c73934 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
|
||||
Date: Tue, 10 Jan 2017 09:51:32 +0200
|
||||
Subject: [PATCH] fix aarch64 compile error due to undefined variable
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
fixes #36
|
||||
|
||||
Signed-off-by: Timo Teräs <timo.teras@iki.fi>
|
||||
---
|
||||
procinterrupts.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/procinterrupts.c b/procinterrupts.c
|
||||
index 6b37a88..c5c034c 100644
|
||||
--- a/procinterrupts.c
|
||||
+++ b/procinterrupts.c
|
||||
@@ -148,6 +148,9 @@ GList* collect_full_irq_list()
|
||||
char *line = NULL;
|
||||
size_t size = 0;
|
||||
char *irq_name, *irq_mod, *savedptr, *last_token, *p;
|
||||
+#ifdef AARCH64
|
||||
+ char *tmp;
|
||||
+#endif
|
||||
|
||||
file = fopen("/proc/interrupts", "r");
|
||||
if (!file)
|
||||
--
|
||||
2.11.0
|
||||
|
|
@ -3,10 +3,10 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - removed dependency on numactl
|
||||
# - AArch64 patch
|
||||
# - upstream patch for AArch64
|
||||
|
||||
pkgname=irqbalance
|
||||
pkgver=1.1.0
|
||||
pkgver=1.2.0
|
||||
pkgrel=1
|
||||
pkgdesc="IRQ balancing daemon for SMP systems"
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -15,14 +15,14 @@ license=('GPL')
|
|||
depends=('glib2' 'libcap-ng')
|
||||
source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
|
||||
irqbalance.service
|
||||
irqbalance-fix-aarch64.patch)
|
||||
md5sums=('b15d975336080bcac4be0c1752d43cf3'
|
||||
0001-fix-aarch64-compile-error-due-to-undefined-variable.patch)
|
||||
md5sums=('d1b3f2c31389f2ab955dfa3d02f9f296'
|
||||
'767061c257b26cc3e3c4a5e462166579'
|
||||
'e3c0dce43ae1d68274c674ac3f91f250')
|
||||
'c926a091bc1a50102fd9d4c91eac4fe5')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
patch -p1 -i ../irqbalance-fix-aarch64.patch
|
||||
patch -p1 -i ../0001-fix-aarch64-compile-error-due-to-undefined-variable.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
diff --git a/procinterrupts.c b/procinterrupts.c
|
||||
index 63101d6..b70bfc2 100644
|
||||
--- a/procinterrupts.c
|
||||
+++ b/procinterrupts.c
|
||||
@@ -80,7 +80,7 @@ static int check_platform_device(char *name, struct irq_info *info)
|
||||
rc = 0;
|
||||
goto out;
|
||||
} else if (!strncmp(ent->d_name, "net", strlen("net"))) {
|
||||
- info->IRQ_TYPE_LEGACY;
|
||||
+ info->type = IRQ_TYPE_LEGACY;
|
||||
info->class = IRQ_ETH;
|
||||
rc = 0;
|
||||
goto out;
|
||||
@@ -94,7 +94,7 @@ static int check_platform_device(char *name, struct irq_info *info)
|
||||
|
||||
out:
|
||||
closedir(dirfd);
|
||||
- log(TO_ALL, LOG_DEBUG, "IRQ %s is of type %d and class %d\n", name, info->type, info->class)
|
||||
+ log(TO_ALL, LOG_DEBUG, "IRQ %s is of type %d and class %d\n", name, info->type, info->class);
|
||||
return rc;
|
||||
|
||||
}
|
Loading…
Reference in a new issue