extra/meson to 0.52.0-4

This commit is contained in:
Kevin Mihelich 2019-11-14 13:50:27 +00:00
parent d108eb16ea
commit ebe172feeb
2 changed files with 20 additions and 1 deletions

View file

@ -7,7 +7,7 @@
pkgname=meson
pkgver=0.52.0
pkgrel=1
pkgrel=4
pkgdesc='High productivity build system'
url='https://mesonbuild.com/'
arch=('any')
@ -21,10 +21,14 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
'libelf' 'python-pytest-xdist')
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
skip-test.diff
meson-python-3.8.patch
remove-duplicate-objects.patch::"https://github.com/mesonbuild/meson/commit/212a05b8.patch"
arch-meson)
sha512sums=('9efe962c60e21bf4159ce0b113caba0119751a5f6217cd116f6e43b0b4150af0eb7ab484a74d8e9438d78a5d0458dda4215e9b6b9c96bfc0d07e23d709d2929f'
'SKIP'
'fd1694e74cfa628bda81b1056061d75fa288e04d72bda733f3667be43cfb21c60f2e89455e4a101a7f6bef5754fe112dc84e18ec7a0807bc791015c34deea347'
'343d49889942d1cd3f5dc0c573dba226ca9a6c6c5845ff4e74d3c672532ba6fb7cbfeaadb6e053e8793cd7cbfbc936fb753c2dcd95dd236476f07129ac07f67c'
'78587f8d7ec758e433c81c2a656c7e337320dc199f97ee0fb2134e6a677bdd1c2d556e2912933d50211833d0efcc786965ee1f8c2e58f66c58d9911e9c103777'
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
@ -33,6 +37,8 @@ prepare() {
# Our containers do not allow sanitizers to run
patch -Np1 -i ../skip-test.diff
patch -p1 -i ../meson-python-3.8.patch # Fix boost test with python 3.8
patch -p1 -i ../remove-duplicate-objects.patch # Fix build of gnome-builder
}
build() {

View file

@ -0,0 +1,13 @@
diff --git a/test cases/frameworks/1 boost/meson.build b/test cases/frameworks/1 boost/meson.build
index 8f45dc7f..44bc376d 100644
--- a/test cases/frameworks/1 boost/meson.build
+++ b/test cases/frameworks/1 boost/meson.build
@@ -30,7 +30,7 @@ pymod = import('python')
python2 = pymod.find_installation('python2', required: host_machine.system() == 'linux', disabler: true)
python3 = pymod.find_installation('python3', required: host_machine.system() == 'linux', disabler: true)
python2dep = python2.dependency(required: host_machine.system() == 'linux', disabler: true)
-python3dep = python3.dependency(required: host_machine.system() == 'linux', disabler: true)
+python3dep = dependency('python3-embed', required: host_machine.system() == 'linux', disabler: true)
# compile python 2/3 modules only if we found a corresponding python version
if(python2dep.found() and host_machine.system() == 'linux')