mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed community/aircrack-ng
This commit is contained in:
parent
1c5e1396c3
commit
ec44c1a65b
2 changed files with 0 additions and 88 deletions
|
@ -1,28 +0,0 @@
|
|||
From 766a1b30fe39d397e239e37e77f66fa4cd999722 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 8 May 2018 23:54:19 +0000
|
||||
Subject: [PATCH] no neon
|
||||
|
||||
---
|
||||
src/Makefile.am | 5 -----
|
||||
1 file changed, 5 deletions(-)
|
||||
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 4b0e863f..c1db9e15 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -115,11 +115,6 @@ endif
|
||||
|
||||
pkglibexec_PROGRAMS = aircrack-ng--generic
|
||||
|
||||
-if ARM
|
||||
-pkglibexec_PROGRAMS += aircrack-ng--neon \
|
||||
- aircrack-ng--asimd
|
||||
-endif
|
||||
-
|
||||
if PPC
|
||||
pkglibexec_PROGRAMS += aircrack-ng--altivec \
|
||||
aircrack-ng--power8
|
||||
--
|
||||
2.17.0
|
||||
|
|
@ -1,60 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Jonathan Steel <jsteel at archlinux.org>
|
||||
# Contributor: Brad Fanella <bradfanella@archlinux.us>
|
||||
# Contributor: Daenyth <Daenyth+Arch [at] gmail [dot] com>
|
||||
# Contributor: Corrado Primier <bardo@aur.archlinux.org>
|
||||
# Contributor: ice-man <icemanf@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch out NEON variants
|
||||
|
||||
pkgname=aircrack-ng
|
||||
_pkgver=1.2
|
||||
pkgver=${_pkgver//-/}
|
||||
pkgrel=4
|
||||
pkgdesc="Key cracker for the 802.11 WEP and WPA-PSK protocols"
|
||||
arch=('x86_64')
|
||||
url="https://www.aircrack-ng.org"
|
||||
license=('GPL2')
|
||||
depends=('openssl' 'sqlite' 'iw' 'net-tools' 'wireless_tools' 'ethtool'
|
||||
'pcre' 'libpcap' 'python')
|
||||
conflicts=('aircrack-ng-scripts')
|
||||
replaces=('aircrack-ng-scripts')
|
||||
provides=('aircrack-ng-scripts')
|
||||
source=(https://download.aircrack-ng.org/$pkgname-$_pkgver.tar.gz
|
||||
0001-no-neon.patch)
|
||||
md5sums=('bb11ec14e1fe505d8d0d51cee0c54df9')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$_pkgver
|
||||
if [[ $CARCH != "aarch64" ]]; then
|
||||
patch -p1 -i ../0001-no-neon.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$_pkgver
|
||||
|
||||
./autogen.sh
|
||||
|
||||
./configure --prefix=/usr --libexecdir=/usr/lib
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname-$_pkgver
|
||||
|
||||
make check
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$_pkgver
|
||||
|
||||
make DESTDIR="$pkgdir" pkglibexecdir=/usr/lib/aircrack-ng \
|
||||
sbindir=/usr/bin install
|
||||
}
|
||||
md5sums=('bb11ec14e1fe505d8d0d51cee0c54df9'
|
||||
'061f085f09de3da97521d7a98b1ddfe3')
|
||||
md5sums=('bb11ec14e1fe505d8d0d51cee0c54df9'
|
||||
'ffc5b66caa339222d0af56e615c94bd1')
|
Loading…
Reference in a new issue