diff --git a/extra/pulseaudio/PKGBUILD b/extra/pulseaudio/PKGBUILD
index 3ddc6c748..41e57b91d 100644
--- a/extra/pulseaudio/PKGBUILD
+++ b/extra/pulseaudio/PKGBUILD
@@ -11,18 +11,18 @@
 pkgbase=pulseaudio
 pkgname=(pulseaudio libpulse)
 pkgdesc="A featureful, general-purpose sound server"
-pkgver=5.0
+pkgver=6.0
 pkgrel=1
 arch=(i686 x86_64)
 url="http://www.freedesktop.org/wiki/Software/PulseAudio"
 license=(LGPL AGPL3)
-makedepends=(libasyncns libcap attr libxtst libsm libsamplerate libtool rtkit
-             speex tdb systemd dbus avahi bluez bluez-libs gconf intltool jack2-dbus sbc
-             lirc-utils openssl fftw orc json-c gtk3 webrtc-audio-processing
-             check git)
+makedepends=(libasyncns libcap attr libxtst libsm libsndfile libtool rtkit
+             speexdsp tdb systemd dbus avahi bluez bluez-libs gconf intltool jack2-dbus sbc
+             lirc openssl fftw orc json-c gtk3 webrtc-audio-processing
+             check)
 options=(!emptydirs)
 source=(http://freedesktop.org/software/$pkgbase/releases/$pkgbase-$pkgver.tar.xz)
-sha256sums=('99c13a8b1249ddbd724f195579df79484e9af6418cecf6a15f003a7f36caf939')
+sha256sums=('b50640e0b80b1607600accfad2e45aabb79d379bf6354c9671efa2065477f6f6')
 
 prepare() {
   cd $pkgbase-$pkgver
@@ -39,6 +39,7 @@ build() {
     --with-database=tdb \
     --disable-tcpwrap \
     --disable-bluez4 \
+    --disable-samplerate \
     --disable-rpath \
     --disable-default-build-tests \
     --disable-neon-opt
@@ -50,15 +51,15 @@ build() {
 }
 
 package_pulseaudio() {
-  depends=("libpulse=$pkgver-$pkgrel" rtkit libltdl speex tdb fftw orc
-           libsamplerate webrtc-audio-processing sbc)
+  depends=("libpulse=$pkgver-$pkgrel" rtkit libltdl speexdsp tdb fftw orc
+           webrtc-audio-processing sbc)
   optdepends=('pulseaudio-alsa: ALSA configuration (recommended)'
               'avahi: zeroconf publishing and discovery'
               'bluez: Bluetooth'
               'bluez-libs: Bluetooth'
               'gconf: paprefs configuration'
               'jack2-dbus: JACK support'
-              'lirc-utils: IR control'
+              'lirc: IR control'
               'openssl: RAOP (AirPlay) output'
               'python-pyqt4: Equalizer GUI (qpaeq)')
   backup=(etc/pulse/{daemon.conf,default.pa,system.pa})
@@ -79,9 +80,6 @@ package_pulseaudio() {
 
   rm "$pkgdir/etc/dbus-1/system.d/pulseaudio-system.conf"
 
-  install -Dm644 shell-completion/pulseaudio-zsh-completion.zsh \
-    "$pkgdir/usr/share/zsh/site-functions/_pulseaudio"
-
 ### Split libpulse
 
   mkdir -p "$srcdir"/libpulse/{etc/pulse,usr/{bin,lib/pulseaudio,share/man/man{1,5}}}