mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
add alarm/xf86-video-armsoc-chromium
This commit is contained in:
parent
52e2c5ad6d
commit
ec66a45db7
2 changed files with 126 additions and 0 deletions
|
@ -0,0 +1,75 @@
|
||||||
|
From 63325d4c75fef68324036c0908c4cb074ac3cf4f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mauro Ribeiro <mauro.ribeiro@hardkernel.com>
|
||||||
|
Date: Sun, 5 Jan 2014 19:38:10 +0000
|
||||||
|
Subject: [PATCH] compat for newer xorg
|
||||||
|
|
||||||
|
---
|
||||||
|
src/compat-api.h | 2 +-
|
||||||
|
src/drmmode_display.c | 5 -----
|
||||||
|
src/omap_driver.c | 1 -
|
||||||
|
src/omap_driver.h | 1 -
|
||||||
|
4 files changed, 1 insertion(+), 8 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/compat-api.h b/src/compat-api.h
|
||||||
|
index fa0f352..b74a582 100644
|
||||||
|
--- a/src/compat-api.h
|
||||||
|
+++ b/src/compat-api.h
|
||||||
|
@@ -46,7 +46,7 @@
|
||||||
|
#define SCREEN_ARG_TYPE int
|
||||||
|
#define SCREEN_PTR(arg1) ScreenPtr pScreen = screenInfo.screens[(arg1)]
|
||||||
|
|
||||||
|
-#define SCREEN_INIT_ARGS_DECL int scrnIndex, ScreenPtr pScreen, int argc, char **argv
|
||||||
|
+#define SCREEN_INIT_ARGS_DECL int i, ScreenPtr pScreen, int argc, char **argv
|
||||||
|
|
||||||
|
#define BLOCKHANDLER_ARGS_DECL int arg, pointer blockData, pointer pTimeout, pointer pReadmask
|
||||||
|
#define BLOCKHANDLER_ARGS arg, blockData, pTimeout, pReadmask
|
||||||
|
diff --git a/src/drmmode_display.c b/src/drmmode_display.c
|
||||||
|
index edc4df4..9fbedb1 100644
|
||||||
|
--- a/src/drmmode_display.c
|
||||||
|
+++ b/src/drmmode_display.c
|
||||||
|
@@ -58,9 +58,6 @@
|
||||||
|
#include "compiler.h"
|
||||||
|
#include "mipointer.h"
|
||||||
|
|
||||||
|
-/* All drivers implementing backing store need this */
|
||||||
|
-#include "mibstore.h"
|
||||||
|
-
|
||||||
|
#include "micmap.h"
|
||||||
|
|
||||||
|
#include "xf86DDC.h"
|
||||||
|
@@ -1598,8 +1595,6 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd, int cpp)
|
||||||
|
|
||||||
|
TRACE_ENTER();
|
||||||
|
|
||||||
|
- pScrn->canDoBGNoneRoot = TRUE;
|
||||||
|
-
|
||||||
|
drmmode = calloc(1, sizeof *drmmode);
|
||||||
|
drmmode->fd = fd;
|
||||||
|
|
||||||
|
diff --git a/src/omap_driver.c b/src/omap_driver.c
|
||||||
|
index 8430e2c..1dc4c5a 100644
|
||||||
|
--- a/src/omap_driver.c
|
||||||
|
+++ b/src/omap_driver.c
|
||||||
|
@@ -655,7 +655,6 @@ OMAPScreenInit(SCREEN_INIT_ARGS_DECL)
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Initialize backing store: */
|
||||||
|
- miInitializeBackingStore(pScreen);
|
||||||
|
xf86SetBackingStore(pScreen);
|
||||||
|
|
||||||
|
/* Cause the cursor position to be updated by the mouse signal handler: */
|
||||||
|
diff --git a/src/omap_driver.h b/src/omap_driver.h
|
||||||
|
index b457985..32a510c 100644
|
||||||
|
--- a/src/omap_driver.h
|
||||||
|
+++ b/src/omap_driver.h
|
||||||
|
@@ -40,7 +40,6 @@
|
||||||
|
* XXX - figure out what can be removed..
|
||||||
|
*/
|
||||||
|
#include "mipointer.h"
|
||||||
|
-#include "mibstore.h"
|
||||||
|
#include "micmap.h"
|
||||||
|
#include "colormapst.h"
|
||||||
|
#include "xf86cmap.h"
|
||||||
|
--
|
||||||
|
1.8.3.2
|
||||||
|
|
51
alarm/xf86-video-armsoc-chromium/PKGBUILD
Normal file
51
alarm/xf86-video-armsoc-chromium/PKGBUILD
Normal file
|
@ -0,0 +1,51 @@
|
||||||
|
# ArmSoc (OMAP + Mali) FrameBuffer driver for Xorg from Chromium.
|
||||||
|
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# Contributor: Erik Andersson <erik.h.andersson@gmail.com>
|
||||||
|
# Contributor: Mauro Ribeiro <mauro.ribeiro@hardkernel.com>
|
||||||
|
|
||||||
|
# Official upstream is at
|
||||||
|
# http://git.linaro.org/gitweb?p=arm/xorg/driver/xf86-video-armsoc.git;a=summary
|
||||||
|
# https://chromium.googlesource.com/chromiumos/third_party/xf86-video-armsoc
|
||||||
|
|
||||||
|
buildarch=4
|
||||||
|
|
||||||
|
pkgname=xf86-video-armsoc-chromium
|
||||||
|
pkgver=0.0.0
|
||||||
|
pkgrel=1
|
||||||
|
epoch=1
|
||||||
|
arch=('armv7h')
|
||||||
|
url="https://chromium.googlesource.com/chromiumos/third_party/xf86-video-armsoc"
|
||||||
|
license=('GPL2')
|
||||||
|
makedepends=('git' 'pkgconfig' 'xorg-server-devel' 'resourceproto' 'scrnsaverproto')
|
||||||
|
options=('!libtool')
|
||||||
|
conflicts=(xf86-video-armsoc)
|
||||||
|
replaces=(xf86-video-armsoc)
|
||||||
|
provides=(xf86-video-armsoc)
|
||||||
|
source=("$pkgname::git+https://chromium.googlesource.com/chromiumos/third_party/xf86-video-armsoc"
|
||||||
|
'0001-compat-for-newer-xorg.patch')
|
||||||
|
md5sums=('SKIP'
|
||||||
|
'12361ef14f940d10c471f55104ada39d')
|
||||||
|
|
||||||
|
pkgver() {
|
||||||
|
cd "$srcdir/$pkgname"
|
||||||
|
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
||||||
|
}
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "$srcdir/$pkgname"
|
||||||
|
git apply "$srcdir/0001-compat-for-newer-xorg.patch"
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd "$srcdir/$pkgname"
|
||||||
|
|
||||||
|
./autogen.sh --prefix=/usr --with-drmmode=exynos
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
pkgdesc="armsoc framebuffer driver for X from chromium os git"
|
||||||
|
|
||||||
|
make -C "$srcdir/$pkgname" DESTDIR="${pkgdir}" install
|
||||||
|
}
|
||||||
|
|
Loading…
Reference in a new issue