community/polymake to 3.4-1

This commit is contained in:
Kevin Mihelich 2019-04-20 23:04:35 +00:00
parent 8d61681374
commit ec9dad6636
2 changed files with 5 additions and 25 deletions

View file

@ -7,11 +7,11 @@
highmem=1
pkgname=polymake
_pkgver=3.3
_patchver=4
_pkgver=3.4
_patchver=
#pkgver=$_pkgver.r$_patchver
pkgver=$_pkgver
pkgrel=3
pkgrel=1
pkgdesc="Open source software for research in polyhedral geometry"
arch=(x86_64)
url="https://polymake.org/"
@ -19,15 +19,8 @@ license=(GPL)
depends=(mpfr normaliz singular ppl lrs perl-xml-writer perl-xml-libxml perl-xml-libxslt perl-term-readline-gnu perl-term-readkey perl-json)
makedepends=(ninja cddlib ant boost bliss libnsl jdk8-openjdk)
optdepends=('java-runtime: java module')
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-${_pkgver}-minimal.tar.bz2"
polymake-fix-lib-loading.patch)
sha256sums=('f7867137f99d5e8b86035ba05b59a63c5b73a95b21b88059fd2439216c128792'
'491cf7ea37e58e9289b81feb5604473b960e3688969a8d7854378fd6f9deb93a')
prepare() {
cd polymake-$_pkgver
patch -p1 -i ../polymake-fix-lib-loading.patch # Fix loading shared library from external programs
}
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-${_pkgver}-minimal.tar.bz2")
sha256sums=('f4ddfd8275b5b9fbf953e6b24f707d00081a1a6d32ac0e6a52165d016609b1e8')
build() {
cd polymake-$_pkgver

View file

@ -1,13 +0,0 @@
diff --git a/lib/callable/src/perl/Main.cc b/lib/callable/src/perl/Main.cc
index 6267025..2c96dc1 100644
--- a/lib/callable/src/perl/Main.cc
+++ b/lib/callable/src/perl/Main.cc
@@ -109,7 +109,7 @@ void deduce_install_dirs(std::string lib_path, std::string& install_top, std::st
{
const char stem_name[]="libpolymake";
constexpr size_t stem_size=sizeof(stem_name)-1;
- auto basename_start=lib_path.find(stem_name, stem_size);
+ auto basename_start=lib_path.find(stem_name);
if (basename_start == std::string::npos)
throw std::runtime_error("polymake::Main - weird callable library path " + lib_path);