diff --git a/community/ocaml-integers/PKGBUILD b/community/ocaml-integers/PKGBUILD
new file mode 100644
index 000000000..8b883b715
--- /dev/null
+++ b/community/ocaml-integers/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jürgen Hötzel <juergen@archlinux.org>
+
+# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
+#  - add missing makedepend on dune
+
+pkgname=ocaml-integers
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='Library for binding to C libraries using pure OCaml'
+arch=('i686' 'x86_64')
+url=https://github.com/ocamllabs/ocaml-integers
+license=('custom')
+options=('!strip')
+makedepends=('ocaml-topkg' 'ocaml-findlib' 'ocaml-compiler-libs' 'ocamlbuild' 'opam' 'dune')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ocamllabs/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('28715567848f07aa688a09496041731b')
+
+
+build() {
+  cd ${pkgname}-$pkgver
+  dune build --profile release
+}
+
+package() {
+  cd ${pkgname}-$pkgver
+
+  opam-installer --prefix="${pkgdir}/usr" \
+    --libdir="${pkgdir}$(ocamlc -where)" \
+    --docdir="${pkgdir}/usr/share/doc" \
+    --stubsdir="${pkgdir}$(ocamlc -where)/stublibs"
+
+  install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE.md
+}