Merge pull request #315 from tgc-dk/master

Fix libcec-rpi build, including patch
This commit is contained in:
Kevin Mihelich 2012-11-27 10:18:35 -08:00
commit ecb29092c2
2 changed files with 40 additions and 3 deletions

View file

@ -1,4 +1,6 @@
# Contributor: tomasgroth at yahoo.dk
# $Id$
# Maintainer: BlackIkeEagle <ike DOT devolder AT gmail DOT com>
# Contributor: Philippe Cherel <philippe.cherel@mayenne.org>
buildarch=16
@ -12,15 +14,17 @@ license=('GPL')
depends=('udev' 'lockdev' 'raspberrypi-firmware')
conflicts=('libcec')
provides=('libcec')
source=("libcec-2.0.4.tar.gz::https://github.com/Pulse-Eight/libcec/tarball/libcec-2.0.4")
source=("libcec-2.0.4.tar.gz::https://github.com/Pulse-Eight/libcec/tarball/libcec-2.0.4" "fix-boot_t.patch")
_srcfolder=Pulse-Eight-libcec-178d498
sha256sums=('652f8bddf8629eb4d14c93bc97efbeb7406482f69626302c8489df8e1fd8431f')
sha256sums=('652f8bddf8629eb4d14c93bc97efbeb7406482f69626302c8489df8e1fd8431f'
'ba9b4030f3c2aa092a7c513629b60e82eeca7daf044576fa89b117409a8e883f')
options=(!libtool)
build() {
mv "$_srcfolder" "$pkgname-$pkgver"
cd "$pkgname-$pkgver"
patch -p1 -i ../fix-boot_t.patch
autoreconf -vif
./configure --prefix=/usr --enable-rpi \
--with-rpi-include-path="/opt/vc/include" \

View file

@ -0,0 +1,33 @@
diff -ur Pulse-Eight-libcec-178d498/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp libcec-rpi-2.0.4/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp
--- Pulse-Eight-libcec-178d498/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp 2012-11-17 02:33:33.000000000 +0000
+++ libcec-rpi-2.0.4/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp 2012-11-27 07:36:53.510561048 +0000
@@ -264,7 +264,7 @@
if (bStartListening)
{
// enable passive mode
- vc_cec_set_passive(true);
+ vc_cec_set_passive((bool_t)true);
// register the callback
vc_cec_register_callback(((CECSERVICE_CALLBACK_T)rpi_cec_callback), (void*)this);
@@ -320,7 +320,7 @@
UnregisterLogicalAddress();
// disable passive mode
- vc_cec_set_passive(false);
+ vc_cec_set_passive((bool_t)false);
if (!g_bHostInited)
{
diff -ur Pulse-Eight-libcec-178d498/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp libcec-rpi-2.0.4/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp
--- Pulse-Eight-libcec-178d498/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp 2012-11-17 02:33:33.000000000 +0000
+++ libcec-rpi-2.0.4/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp 2012-11-27 07:40:36.500150455 +0000
@@ -182,7 +182,7 @@
LIB_CEC->AddLog(CEC_LOG_DEBUG, "sending data: %s", strDump.c_str());
#endif
- int iReturn = vc_cec_send_message((uint32_t)command.destination, (uint8_t*)&payload, iLength, bIsReply);
+ int iReturn = vc_cec_send_message((uint32_t)command.destination, (uint8_t*)&payload, iLength, (bool_t)bIsReply);
#endif
if (iReturn != VCHIQ_SUCCESS)