extra/chromium to 89.0.4389.82-1

This commit is contained in:
Kevin Mihelich 2021-03-06 13:41:04 +00:00
parent c744836ba2
commit ece3ff5613
3 changed files with 6 additions and 71 deletions

View file

@ -15,10 +15,10 @@ buildarch=12
highmem=1
pkgname=chromium
pkgver=89.0.4389.72
pkgrel=2
pkgver=89.0.4389.82
pkgrel=1
_launcher_ver=7
_gcc_patchset=6
_gcc_patchset=7
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('x86_64')
url="https://www.chromium.org/Home"
@ -36,20 +36,16 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
add-dependency-on-opus-in-webcodecs.patch
don-t-crash-on-reentrant-RunMoveLoop-call.patch
add-ctime-for-std-time.patch
chromium-glibc-2.33.patch
use-oauth2-client-switches-as-default.patch
0001-crashpad-include-limits.patch
0002-Fix-sandbox-Aw-snap-for-sycalls-403-and-407.patch
0003-Run-blink-bindings-generation-single-threaded.patch
0004-widevine-support-for-arm.patch)
sha256sums=('946a0b65aad10e0f77a539103892099b7238310c733f25b41d58b76f6ac0bc4f'
sha256sums=('df4914407b68afdc6449cb8e3f1b08d110eb8689ac41f86490e337fa4d1be379'
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
'359d2847e775d8cf6f4e0b12c94c8f2718f0fd562427859c596ce1c3711dbd8e'
'f8b1558f6c87b33423da854d42f0f69d47885a96d6bf6ce7f26373e93d47442f'
'b86b11de8db438c47f0a84c7956740f648d21035f4ee46bfbd50c3348d369121'
'615f5fefc94da605957edb34b6c000f32953fb5ff6ffb321f062dab8e0fef9d3'
'102e0c976c0d7fd1fbe2f2978ec621499a97b62457b3fde4daf84f026d1a53a7'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
'112671743908fa9e69e30eb4ddc9539f76f2cc28a3b038df6b610e5b210a77d1'
@ -127,11 +123,10 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../add-dependency-on-opus-in-webcodecs.patch
patch -Np1 -i ../don-t-crash-on-reentrant-RunMoveLoop-call.patch
patch -Np1 -i ../add-ctime-for-std-time.patch
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-89-quiche-dcheck.patch
patch -Np1 -i ../patches/chromium-89-AXTreeSerializer-include.patch
# Force script incompatible with Python 3 to use /usr/bin/python2
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py

View file

@ -1,27 +0,0 @@
From c06ddc4935bf1394812c011ce5d93898ccc8a53a Mon Sep 17 00:00:00 2001
From: Stephan Hartmann <stha09@googlemail.com>
Date: Tue, 9 Feb 2021 19:22:57 +0000
Subject: [PATCH] IWYU: add ctime for std::time
Bug: None
Change-Id: I8bdae43209984242b9f5e538d74ece4409b65e3c
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2679610
Reviewed-by: Katie Dektar <katie@chromium.org>
Commit-Queue: Katie Dektar <katie@chromium.org>
Cr-Commit-Position: refs/heads/master@{#852287}
---
ui/accessibility/ax_tree_serializer.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/ui/accessibility/ax_tree_serializer.h b/ui/accessibility/ax_tree_serializer.h
index ddbbdcdc25c53..1790e3b791967 100644
--- a/ui/accessibility/ax_tree_serializer.h
+++ b/ui/accessibility/ax_tree_serializer.h
@@ -8,6 +8,7 @@
#include <stddef.h>
#include <stdint.h>
+#include <ctime>
#include <ostream>
#include <unordered_map>
#include <unordered_set>

View file

@ -1,33 +0,0 @@
From 4b05247f43d592ce748933963df923d9a40705f8 Mon Sep 17 00:00:00 2001
From: Sigurdur Asgeirsson <siggi@chromium.org>
Date: Mon, 8 Feb 2021 18:36:10 +0000
Subject: [PATCH] Don't crash on reentrant RunMoveLoop call.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Bug: 1173484
Change-Id: Ia75b200d2826586080c26089751bef1d12c8fbce
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2680089
Reviewed-by: Scott Violet <sky@chromium.org>
Commit-Queue: Sigurður Ásgeirsson <siggi@chromium.org>
Cr-Commit-Position: refs/heads/master@{#851799}
---
chrome/browser/ui/views/tabs/tab_drag_controller.cc | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/chrome/browser/ui/views/tabs/tab_drag_controller.cc b/chrome/browser/ui/views/tabs/tab_drag_controller.cc
index 16c3c1e9df8c2..d2ccc2b965237 100644
--- a/chrome/browser/ui/views/tabs/tab_drag_controller.cc
+++ b/chrome/browser/ui/views/tabs/tab_drag_controller.cc
@@ -1397,6 +1397,10 @@ void TabDragController::RunMoveLoop(const gfx::Vector2d& drag_offset) {
move_loop_widget_ = GetAttachedBrowserWidget();
DCHECK(move_loop_widget_);
+
+ // RunMoveLoop can be called reentrantly from within another RunMoveLoop,
+ // in which case the observation is already established.
+ widget_observation_.Reset();
widget_observation_.Observe(move_loop_widget_);
current_state_ = DragState::kDraggingWindow;
base::WeakPtr<TabDragController> ref(weak_factory_.GetWeakPtr());