mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/valgrind to 3.11.0-1
This commit is contained in:
parent
88e3fb0245
commit
ed1f820adb
3 changed files with 7 additions and 132 deletions
|
@ -9,28 +9,19 @@ buildarch=4
|
|||
#noautobuild=1
|
||||
|
||||
pkgname=valgrind
|
||||
pkgver=3.10.1
|
||||
pkgrel=4
|
||||
pkgver=3.11.0
|
||||
pkgrel=1
|
||||
pkgdesc='A tool to help find memory-management problems in programs'
|
||||
arch=(i686 x86_64)
|
||||
license=(GPL)
|
||||
url='http://valgrind.org/'
|
||||
depends=('glibc>=2.22' 'glibc<2.23' 'perl')
|
||||
makedepends=('gdb' 'openmpi')
|
||||
makedepends=(gdb openmpi)
|
||||
optdepends=('openmpi: MPI support')
|
||||
options=('!emptydirs')
|
||||
source=(http://valgrind.org/downloads/$pkgname-$pkgver.tar.bz2
|
||||
valgrind-glibc.patch
|
||||
valgrind-kernel-version.patch)
|
||||
sha1sums=('15518427de842547ffa84eff8b2b67f3b16581a8'
|
||||
'1fa127ef24630ad5f4901ea0e37ea2acb12d3d17'
|
||||
'08b71e1ebc3e3906d0ff273db0aba2177a857c47')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
patch -p1 -i "$srcdir"/valgrind-glibc.patch
|
||||
patch -p1 -i "$srcdir"/valgrind-kernel-version.patch
|
||||
}
|
||||
# valgrind does not like stack protector flags
|
||||
options=(!emptydirs)
|
||||
source=(http://valgrind.org/downloads/$pkgname-$pkgver.tar.bz2)
|
||||
sha1sums=('340757e91d9e83591158fe8bb985c6b11bc53de5')
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
|
|
@ -1,69 +0,0 @@
|
|||
From 8e520f21445e7c376c2606826affb20be92bfe8d Mon Sep 17 00:00:00 2001
|
||||
From: Anatol Pomozov <anatol.pomozov@gmail.com>
|
||||
Date: Thu, 6 Aug 2015 09:04:44 -0700
|
||||
Subject: [PATCH 1/2] glibc
|
||||
|
||||
---
|
||||
configure | 20 ++++++++++++++++++++
|
||||
configure.ac | 14 ++++++++++++++
|
||||
2 files changed, 34 insertions(+)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 78ddf3e..6ab06b3 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -6842,6 +6842,26 @@ $as_echo "#define GLIBC_2_20 1" >>confdefs.h
|
||||
DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||
DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||
;;
|
||||
+ 2.21)
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.21 family" >&5
|
||||
+$as_echo "2.21 family" >&6; }
|
||||
+
|
||||
+$as_echo "#define GLIBC_2_21 1" >>confdefs.h
|
||||
+
|
||||
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||
+ ;;
|
||||
+ 2.22)
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.22 family" >&5
|
||||
+$as_echo "2.22 family" >&6; }
|
||||
+
|
||||
+$as_echo "#define GLIBC_2_22 1" >>confdefs.h
|
||||
+
|
||||
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||
+ ;;
|
||||
darwin)
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: Darwin" >&5
|
||||
$as_echo "Darwin" >&6; }
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 0fd2a41..7f389c2 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1018,6 +1018,20 @@ case "${GLIBC_VERSION}" in
|
||||
DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||
DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||
;;
|
||||
+ 2.21)
|
||||
+ AC_MSG_RESULT(2.21 family)
|
||||
+ AC_DEFINE([GLIBC_2_21], 1, [Define to 1 if you're using glibc 2.21.x])
|
||||
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||
+ ;;
|
||||
+ 2.22)
|
||||
+ AC_MSG_RESULT(2.22 family)
|
||||
+ AC_DEFINE([GLIBC_2_22], 1, [Define to 1 if you're using glibc 2.22.x])
|
||||
+ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
|
||||
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
|
||||
+ ;;
|
||||
darwin)
|
||||
AC_MSG_RESULT(Darwin)
|
||||
AC_DEFINE([DARWIN_LIBC], 1, [Define to 1 if you're using Darwin])
|
||||
--
|
||||
2.5.0
|
||||
|
|
@ -1,47 +0,0 @@
|
|||
From 88d02c44361bf4d9b354eea7e20559a4a57b866f Mon Sep 17 00:00:00 2001
|
||||
From: Anatol Pomozov <anatol.pomozov@gmail.com>
|
||||
Date: Thu, 6 Aug 2015 09:06:25 -0700
|
||||
Subject: [PATCH 2/2] kernel
|
||||
|
||||
---
|
||||
configure | 6 +++---
|
||||
configure.ac | 6 +++---
|
||||
2 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 6ab06b3..a59ef12 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -5553,9 +5553,9 @@ $as_echo_n "checking for the kernel version... " >&6; }
|
||||
kernel=`uname -r`
|
||||
|
||||
case "${kernel}" in
|
||||
- 2.6.*|3.*)
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.6.x/3.x family (${kernel})" >&5
|
||||
-$as_echo "2.6.x/3.x family (${kernel})" >&6; }
|
||||
+ 2.6.*|3.*|4.*)
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: 2.6.x/3.x/4.x family (${kernel})" >&5
|
||||
+$as_echo "2.6.x/3.x/4.x family (${kernel})" >&6; }
|
||||
|
||||
$as_echo "#define KERNEL_2_6 1" >>confdefs.h
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 7f389c2..b0bb449 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -303,9 +303,9 @@ case "${host_os}" in
|
||||
kernel=`uname -r`
|
||||
|
||||
case "${kernel}" in
|
||||
- 2.6.*|3.*)
|
||||
- AC_MSG_RESULT([2.6.x/3.x family (${kernel})])
|
||||
- AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x])
|
||||
+ 2.6.*|3.*|4.*)
|
||||
+ AC_MSG_RESULT([2.6.x/3.x/4.x family (${kernel})])
|
||||
+ AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x or Linux 4.x])
|
||||
;;
|
||||
|
||||
2.4.*)
|
||||
--
|
||||
2.5.0
|
||||
|
Loading…
Reference in a new issue