mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
added community/mimetic
This commit is contained in:
parent
c3feeff6c8
commit
ed3e9b8c4a
2 changed files with 69 additions and 0 deletions
38
community/mimetic/PKGBUILD
Normal file
38
community/mimetic/PKGBUILD
Normal file
|
@ -0,0 +1,38 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
# Contributor: Andreas Baumann <mail@andreasbaumann.cc>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix signed char usage
|
||||
|
||||
pkgname=mimetic
|
||||
pkgver=0.9.8
|
||||
pkgrel=1
|
||||
pkgdesc="A free, MIT licensed, Email library (MIME) written in C++"
|
||||
url="http://www.codesink.org/mimetic_mime_library.html"
|
||||
arch=(i686 x86_64)
|
||||
license=(MIT)
|
||||
depends=(gcc-libs)
|
||||
source=(http://www.codesink.org/download/$pkgname-$pkgver.tar.gz
|
||||
signed-char.patch)
|
||||
sha256sums=('3a07d68d125f5e132949b078c7275d5eb0078dd649079bd510dd12b969096700'
|
||||
'fc7cad20839fa5ea50b9189eed9a628470051ad594a55b228c302947eb6f91b2')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
patch -p1 -i ../signed-char.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
make DESTDIR="$pkgdir" install
|
||||
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
|
||||
}
|
31
community/mimetic/signed-char.patch
Normal file
31
community/mimetic/signed-char.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
Description: fix FTBFS on architectures where char is unsigned
|
||||
Fix error
|
||||
base64.cxx:30:1: error: narrowing conversion of '-1' from 'int' to 'char' inside { } [-Wnarrowing]
|
||||
by making Base64::sDecTable a signed char.
|
||||
Bug-Debian: https://bugs.debian.org/859963
|
||||
Forwarded: via email
|
||||
Author: gregor herrmann <gregoa@debian.org>
|
||||
Last-Update: 2017-04-10
|
||||
|
||||
--- a/mimetic/codec/base64.cxx
|
||||
+++ b/mimetic/codec/base64.cxx
|
||||
@@ -13,7 +13,7 @@
|
||||
"abcdefghijklmnopqrstuvwxyz"
|
||||
"0123456789+/=";
|
||||
|
||||
-const char Base64::sDecTable[] = {
|
||||
+const signed char Base64::sDecTable[] = {
|
||||
-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
|
||||
-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
|
||||
-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
|
||||
--- a/mimetic/codec/base64.h
|
||||
+++ b/mimetic/codec/base64.h
|
||||
@@ -20,7 +20,7 @@
|
||||
enum { default_maxlen = 76 };
|
||||
enum { eq_sign = 100 };
|
||||
static const char sEncTable[];
|
||||
- static const char sDecTable[];
|
||||
+ static const signed char sDecTable[];
|
||||
static const int sDecTableSz;
|
||||
public:
|
||||
class Encoder; class Decoder;
|
Loading…
Reference in a new issue