extra/vtk to 9.2.6-11

This commit is contained in:
Kevin Mihelich 2023-11-05 01:24:10 +00:00
parent 887c64d948
commit ed7c85fae3
4 changed files with 74 additions and 4 deletions

View file

@ -1,7 +1,7 @@
pkgbase = vtk
pkgdesc = Software system for 3D computer graphics, image processing, and visualization
pkgver = 9.2.6
pkgrel = 10
pkgrel = 11
url = https://www.vtk.org/
arch = x86_64
license = BSD
@ -106,9 +106,13 @@ pkgbase = vtk
source = https://github.com/Kitware/VTK/commit/1233ceec.patch
source = https://github.com/Kitware/VTK/commit/4d8283bc.patch
source = fmt-10.patch
source = 47ceab32.patch
source = fdb93d3e9.patch
sha256sums = 06fc8d49c4e56f498c40fcb38a563ed8d4ec31358d0101e8988f0bb4d539dd12
sha256sums = 5f662d5052dc07ee43d690c5ffdc1880c5c6c4236945c03a40177ae3a6dc5917
sha256sums = 82eae5864704b1d955c905d75e565380829b05bb6300c4614da2d19834e15014
sha256sums = c60aa3276a3d7c0e6ae4db5f18a8023ab319ac7d2ff66616936012097e6cebbe
sha256sums = d9e9eb9ebadd3ca066729732165f4420b0df10759defc17458a1b0b71255b36e
sha256sums = 79eae9ff919a36f79ba91916fdc8b2c7312713ad13a6972a6d38220f229b1887
pkgname = vtk

28
extra/vtk/47ceab32.patch Normal file
View file

@ -0,0 +1,28 @@
From 47ceab32e3af877045a96ef58c1f30ab72bf8260 Mon Sep 17 00:00:00 2001
From: Caitlin Ross <caitlin.ross@kitware.com>
Date: Tue, 6 Dec 2022 10:49:34 -0600
Subject: [PATCH] adios debug mode deprecated
---
fides/DataSetWriter.cxx | 4 ++--
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/fides/DataSetWriter.cxx b/fides/DataSetWriter.cxx
index 94c79126..6ca00bdd 100644
--- a/fides/DataSetWriter.cxx
+++ b/fides/DataSetWriter.cxx
@@ -71,9 +71,9 @@ public:
: DataSets(dataSets)
, OutputFileName(fname)
#ifdef FIDES_USE_MPI
- , Adios(MPI_COMM_WORLD, adios2::DebugON)
+ , Adios(MPI_COMM_WORLD)
#else
- , Adios(true)
+ , Adios()
#endif
, FieldsToWriteSet(false)
{
--
GitLab

View file

@ -15,7 +15,7 @@
pkgname=vtk
pkgver=9.2.6
pkgrel=10
pkgrel=11
pkgdesc="Software system for 3D computer graphics, image processing, and visualization"
arch=(x86_64)
url="https://www.vtk.org/"
@ -123,11 +123,15 @@ options=(staticlibs)
source=(${url}/files/release/${pkgver%.*}/VTK-${pkgver}.tar.gz
https://github.com/Kitware/VTK/commit/1233ceec.patch
https://github.com/Kitware/VTK/commit/4d8283bc.patch
fmt-10.patch)
fmt-10.patch
47ceab32.patch
fdb93d3e9.patch)
sha256sums=('06fc8d49c4e56f498c40fcb38a563ed8d4ec31358d0101e8988f0bb4d539dd12'
'5f662d5052dc07ee43d690c5ffdc1880c5c6c4236945c03a40177ae3a6dc5917'
'82eae5864704b1d955c905d75e565380829b05bb6300c4614da2d19834e15014'
'c60aa3276a3d7c0e6ae4db5f18a8023ab319ac7d2ff66616936012097e6cebbe')
'c60aa3276a3d7c0e6ae4db5f18a8023ab319ac7d2ff66616936012097e6cebbe'
'd9e9eb9ebadd3ca066729732165f4420b0df10759defc17458a1b0b71255b36e'
'79eae9ff919a36f79ba91916fdc8b2c7312713ad13a6972a6d38220f229b1887')
prepare() {
cd ${pkgname^^}-${pkgver}
@ -137,6 +141,9 @@ prepare() {
patch -p1 -i ../1233ceec.patch # Fix build with GCC 13
patch -p1 -i ../4d8283bc.patch
patch -p1 -i ../fmt-10.patch # Fix build with fmt 10
# Fix build with adios2 2.9
patch -d ThirdParty/fides/vtkfides -p1 < ../47ceab32.patch
patch -p1 < ../fdb93d3e9.patch
}
build() {

31
extra/vtk/fdb93d3e9.patch Normal file
View file

@ -0,0 +1,31 @@
From fdb93d3e9d447b9dd6ce5c77aca18396cf9b6aa3 Mon Sep 17 00:00:00 2001
From: Vicente Bolea <vicente.bolea@kitware.com>
Date: Mon, 3 Apr 2023 12:58:58 -0400
Subject: [PATCH] Update IO/ADIOS2/vtkADIOS2CoreImageReader.cxx
---
IO/ADIOS2/vtkADIOS2CoreImageReader.cxx | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/IO/ADIOS2/vtkADIOS2CoreImageReader.cxx b/IO/ADIOS2/vtkADIOS2CoreImageReader.cxx
index 5d58905a881..3ce039345a9 100644
--- a/IO/ADIOS2/vtkADIOS2CoreImageReader.cxx
+++ b/IO/ADIOS2/vtkADIOS2CoreImageReader.cxx
@@ -361,12 +361,12 @@ bool vtkADIOS2CoreImageReader::OpenAndReadMetaData()
vtkMPICommunicator* comm =
static_cast<vtkMPICommunicator*>(this->Controller->GetCommunicator());
- this->Impl->Adios.reset(new adios2::ADIOS(*comm->GetMPIComm()->GetHandle(), adios2::DebugON));
+ this->Impl->Adios.reset(new adios2::ADIOS(*comm->GetMPIComm()->GetHandle()));
#else
// Make sure the ADIOS subsystem is initialized before processing any
// sort of request.
- this->Impl->Adios.reset(new adios2::ADIOS(adios2::DebugON));
+ this->Impl->Adios.reset(new adios2::ADIOS());
// Before processing any request, read the meta data first
#endif
}
--
GitLab