mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/linux-tools to 4.7-2
This commit is contained in:
parent
6a09b21be3
commit
edc222d949
2 changed files with 36 additions and 1 deletions
31
community/linux-tools/01-cpupower-governor-fix.patch
Normal file
31
community/linux-tools/01-cpupower-governor-fix.patch
Normal file
|
@ -0,0 +1,31 @@
|
||||||
|
diff --git a/tools/power/cpupower/utils/cpufreq-set.c b/tools/power/cpupower/utils/cpufreq-set.c
|
||||||
|
index b4bf769..f2d1bbd 100644
|
||||||
|
--- a/tools/power/cpupower/utils/cpufreq-set.c
|
||||||
|
+++ b/tools/power/cpupower/utils/cpufreq-set.c
|
||||||
|
@@ -296,9 +296,10 @@ int cmd_freq_set(int argc, char **argv)
|
||||||
|
struct cpufreq_affected_cpus *cpus;
|
||||||
|
|
||||||
|
if (!bitmask_isbitset(cpus_chosen, cpu) ||
|
||||||
|
- cpupower_is_cpu_online(cpu))
|
||||||
|
+ cpupower_is_cpu_online(cpu) != 1)
|
||||||
|
continue;
|
||||||
|
|
||||||
|
+
|
||||||
|
cpus = cpufreq_get_related_cpus(cpu);
|
||||||
|
if (!cpus)
|
||||||
|
break;
|
||||||
|
@@ -316,11 +317,10 @@ int cmd_freq_set(int argc, char **argv)
|
||||||
|
cpu <= bitmask_last(cpus_chosen); cpu++) {
|
||||||
|
|
||||||
|
if (!bitmask_isbitset(cpus_chosen, cpu) ||
|
||||||
|
- cpupower_is_cpu_online(cpu))
|
||||||
|
- continue;
|
||||||
|
-
|
||||||
|
- if (cpupower_is_cpu_online(cpu) != 1)
|
||||||
|
+ cpupower_is_cpu_online(cpu) != 1) {
|
||||||
|
+ printf(_("Ignoring cpu: %d\n"), cpu);
|
||||||
|
continue;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
printf(_("Setting cpu: %d\n"), cpu);
|
||||||
|
ret = do_one_cpu(cpu, &new_pol, freq, policychange);
|
|
@ -17,7 +17,7 @@ pkgname=(
|
||||||
'usbip'
|
'usbip'
|
||||||
)
|
)
|
||||||
pkgver=4.7
|
pkgver=4.7
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
license=('GPL2')
|
license=('GPL2')
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
url='http://www.kernel.org'
|
url='http://www.kernel.org'
|
||||||
|
@ -40,6 +40,7 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.xz"
|
||||||
'cpupower.systemd'
|
'cpupower.systemd'
|
||||||
'cpupower.service'
|
'cpupower.service'
|
||||||
'usbipd.service'
|
'usbipd.service'
|
||||||
|
'01-cpupower-governor-fix.patch'
|
||||||
'02-archlinux-paths.patch'
|
'02-archlinux-paths.patch'
|
||||||
'04-fix-usip-h-path.patch')
|
'04-fix-usip-h-path.patch')
|
||||||
md5sums=('SKIP'
|
md5sums=('SKIP'
|
||||||
|
@ -47,11 +48,14 @@ md5sums=('SKIP'
|
||||||
'34f5ecc19770a1abbcd0fd65bfd1f065'
|
'34f5ecc19770a1abbcd0fd65bfd1f065'
|
||||||
'86c4e419e4ba80835c330d49ba3f56ad'
|
'86c4e419e4ba80835c330d49ba3f56ad'
|
||||||
'bb35634f480325a78b943f7e10165e86'
|
'bb35634f480325a78b943f7e10165e86'
|
||||||
|
'33c871519adfd4e5575643c4579d019b'
|
||||||
'1bc4f8c7a21a30e1a873d07e69fb698b'
|
'1bc4f8c7a21a30e1a873d07e69fb698b'
|
||||||
'a73ea3ea6d9c9ecb1cc910871eead3ff')
|
'a73ea3ea6d9c9ecb1cc910871eead3ff')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd linux-$pkgver
|
cd linux-$pkgver
|
||||||
|
# apply stable kernel patch
|
||||||
|
#xz -kcd "$srcdir"/patch-4.7.1.xz | patch -p1 -N
|
||||||
# apply patch from the source array (should be a pacman feature)
|
# apply patch from the source array (should be a pacman feature)
|
||||||
local filename
|
local filename
|
||||||
for filename in "${source[@]}"; do
|
for filename in "${source[@]}"; do
|
||||||
|
|
Loading…
Reference in a new issue