extra/suitesparse: fix

This commit is contained in:
Kevin Mihelich 2021-10-16 23:19:38 +00:00
parent 2d5a04a44d
commit ede431b571
2 changed files with 5 additions and 5 deletions

View file

@ -21,7 +21,7 @@ source=($pkgname-$pkgver.tar.gz::"https://github.com/DrTimothyAldenDavis/SuiteSp
libatomic.patch)
sha256sums=('acb4d1045f48a237e70294b950153e48dce5b5f9ca8190e86c2b8c54ce00a7ee'
'409b32e546ec4936d0d88e39c59ee68dfd9f630d8c454ce1e3d58243df7ad396'
'b91e5ee92c027a5b216debccee2d37712b31a4fb2a544d7721060ccf2f60a7da')
'e4dd670b8406483a7b69e8ba5bdd37b83f4d08c867fd86cc0b4f2dad623e07bc')
prepare() {
cd SuiteSparse-$pkgver

View file

@ -7,19 +7,19 @@ Last-Update: 2020-02-28
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/GraphBLAS/CMakeLists.txt
+++ b/GraphBLAS/CMakeLists.txt
@@ -294,6 +294,7 @@ SET_TARGET_PROPERTIES ( graphblas PROPER
@@ -270,6 +270,7 @@ SET_TARGET_PROPERTIES ( graphblas PROPER
C_STANDARD_REQUIRED 11
PUBLIC_HEADER "Include/GraphBLAS.h" )
set_property ( TARGET graphblas PROPERTY C_STANDARD 11 )
+target_link_libraries(graphblas atomic)
+target_link_libraries(graphblas PUBLIC atomic)
#-------------------------------------------------------------------------------
# static graphblas library properties
@@ -308,6 +309,7 @@ if ( BUILD_GRB_STATIC_LIBRARY )
@@ -284,6 +285,7 @@ if ( BUILD_GRB_STATIC_LIBRARY )
C_STANDARD_REQUIRED 11
PUBLIC_HEADER "Include/GraphBLAS.h" )
set_property ( TARGET graphblas_static PROPERTY C_STANDARD 11 )
+ target_link_libraries(graphblas_static atomic)
+ target_link_libraries(graphblas_static PUBLIC atomic)
endif ( )
#-------------------------------------------------------------------------------