extra/thunderbird to 60.7.0-1

This commit is contained in:
Kevin Mihelich 2019-05-21 23:26:15 +00:00
parent 9753488e68
commit eded1fa6e2
2 changed files with 4 additions and 35 deletions

View file

@ -13,8 +13,8 @@ buildarch=12
highmem=1
pkgname=thunderbird
pkgver=60.6.1
pkgrel=2
pkgver=60.7.0
pkgrel=1
pkgdesc='Standalone mail and news reader from mozilla.org'
url='https://www.mozilla.org/thunderbird/'
arch=(x86_64)
@ -29,8 +29,8 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/sou
rust-1.33.patch
$pkgname.desktop
Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch)
sha256sums=('17aef9232a76bdc812422883c02b01b4ecb7633c3ee9870da5e4ec0e20ba5f67'
'97bdb978d59cf5f0f967750e9d8dfbc8fc73367b08437838c44a308fe2ee5442'
sha256sums=('377ca762624df103dd768dc36b7632537b46aa83ddc9d336a157cadcde8bb51d'
'2b0244a9f7a30f28bcc12055f171e5506c7e3b929d85c3b3514b7e4e4c251784'
'36a655ce3987159990d46a13d9955305a72a8a737e6af983eb170c4f652eb39a')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)

View file

@ -9,17 +9,6 @@ diff -up thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py.rust-1.3
#[macro_export]
macro_rules! atom {{
{}
diff -up thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs
--- thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs.rust-1.33-build 2019-03-04 19:17:27.000000000 +0100
+++ thunderbird-60.5.3/servo/components/style/gecko_string_cache/namespace.rs 2019-03-13 15:05:58.966726107 +0100
@@ -11,6 +11,7 @@ use std::fmt;
use std::ops::Deref;
use string_cache::{Atom, WeakAtom};
+/// Macro text
#[macro_export]
macro_rules! ns {
() => { $crate::string_cache::Namespace(atom!("")) };
diff -up thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs
--- thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build 2019-03-04 19:17:30.000000000 +0100
+++ thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs 2019-03-13 15:05:58.966726107 +0100
@ -48,23 +37,3 @@ diff -up thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs
#[macro_export]
macro_rules! longhand_properties_idents {
($macro_name: ident) => {
diff -up thunderbird-60.5.3/servo/components/style_traits/values.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style_traits/values.rs
--- thunderbird-60.5.3/servo/components/style_traits/values.rs.rust-1.33-build 2019-03-04 19:17:27.000000000 +0100
+++ thunderbird-60.5.3/servo/components/style_traits/values.rs 2019-03-13 15:37:34.077560034 +0100
@@ -135,6 +135,7 @@ where
}
}
+/// Neco
#[macro_export]
macro_rules! serialize_function {
($dest: expr, $name: ident($( $arg: expr, )+)) => {
@@ -404,7 +405,7 @@ impl_to_css_for_predefined_type!(::csspa
impl_to_css_for_predefined_type!(::cssparser::Color);
impl_to_css_for_predefined_type!(::cssparser::UnicodeRange);
-#[macro_export]
+/// Define an enum type with unit variants that each correspond to a CSS keyword.
macro_rules! define_css_keyword_enum {
(pub enum $name:ident { $($variant:ident = $css:expr,)+ }) => {
#[allow(missing_docs)]