mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/gcc to 4.8.0-1
This commit is contained in:
parent
e2cf21495f
commit
edfd195113
2 changed files with 36 additions and 51 deletions
|
@ -5,51 +5,43 @@
|
|||
# NOTE: libtool requires rebuilt with each new gcc version
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - removed ada, go packages
|
||||
# - removed ada packages
|
||||
# - removed gnat (ada stuff) from gcc packaging
|
||||
# - disabled make check, too much stress, kills plugs :(
|
||||
# - specifid build host, disabled distcc
|
||||
# - patch for v6h/v7h gnueabihf triplet
|
||||
# - replaced bugurl with our GitHub issue page
|
||||
|
||||
noautobuild=1
|
||||
|
||||
pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc' 'gcc-go')
|
||||
pkgver=4.7.2
|
||||
pkgrel=4
|
||||
pkgver=4.8.0
|
||||
pkgrel=1
|
||||
#_snapshot=4.7-20120721
|
||||
pkgdesc="The GNU Compiler Collection"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL' 'LGPL' 'FDL' 'custom')
|
||||
url="http://gcc.gnu.org"
|
||||
makedepends=('binutils>=2.23' 'libmpc' 'cloog' 'ppl' 'doxygen')
|
||||
makedepends=('binutils>=2.23' 'libmpc' 'cloog' 'doxygen')
|
||||
checkdepends=('dejagnu')
|
||||
options=('!libtool' '!emptydirs' '!distcc')
|
||||
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
|
||||
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
|
||||
gcc-4.7.1-libgo-write.patch
|
||||
armhf-triplet-trunk.diff)
|
||||
md5sums=('cc308a0891e778cfda7a151ab8a6e762'
|
||||
'5647f5bbbb74fab3013b396da1749d2a'
|
||||
md5sums=('e6040024eb9e761c3bea348d1fa5abb0'
|
||||
'bd7330bd41845929f1e0efb3b7d0a060')
|
||||
|
||||
if [ -n "${_snapshot}" ]; then
|
||||
_basedir="${srcdir}/gcc-${_snapshot}"
|
||||
_basedir=gcc-${_snapshot}
|
||||
else
|
||||
_basedir="${srcdir}/gcc-${pkgver}"
|
||||
_basedir=gcc-${pkgver}
|
||||
fi
|
||||
|
||||
build() {
|
||||
cd ${_basedir}
|
||||
|
||||
# Do not install libiberty
|
||||
sed -i 's/install_to_$(INSTALL_DEST) //' libiberty/Makefile.in
|
||||
cd ${srcdir}/${_basedir}
|
||||
|
||||
# Do not run fixincludes
|
||||
sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
|
||||
|
||||
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53679
|
||||
patch -p1 -i ${srcdir}/gcc-4.7.1-libgo-write.patch
|
||||
|
||||
echo ${pkgver} > gcc/BASE-VER
|
||||
|
||||
# using -pipe causes spurious test-suite failures
|
||||
|
@ -66,23 +58,21 @@ build() {
|
|||
cd ${srcdir}
|
||||
mkdir gcc-build && cd gcc-build
|
||||
|
||||
${_basedir}/configure --prefix=/usr \
|
||||
${srcdir}/${_basedir}/configure --prefix=/usr \
|
||||
--libdir=/usr/lib --libexecdir=/usr/lib \
|
||||
--mandir=/usr/share/man --infodir=/usr/share/info \
|
||||
--with-bugurl=https://bugs.archlinux.org/ \
|
||||
--with-bugurl=https://github.com/archlinuxarm/PKGBUILDs/issues \
|
||||
--enable-languages=c,c++,fortran,go,lto,objc,obj-c++ \
|
||||
--enable-shared --enable-threads=posix \
|
||||
--with-system-zlib --enable-__cxa_atexit \
|
||||
--disable-libunwind-exceptions --enable-clocale=gnu \
|
||||
--disable-libstdcxx-pch --enable-libstdcxx-time \
|
||||
--disable-libstdcxx-pch \
|
||||
--enable-gnu-unique-object --enable-linker-build-id \
|
||||
--with-ppl --enable-cloog-backend=isl \
|
||||
--disable-ppl-version-check --disable-cloog-version-check \
|
||||
--enable-cloog-backend=isl --disable-cloog-version-check \
|
||||
--enable-lto --enable-gold --enable-ld=default \
|
||||
--enable-plugin --with-plugin-ld=ld.gold \
|
||||
--with-linker-hash-style=gnu \
|
||||
--disable-multilib --disable-libssp \
|
||||
--disable-build-with-cxx --disable-build-poststage1-with-cxx \
|
||||
--with-linker-hash-style=gnu --disable-install-libiberty \
|
||||
--disable-multilib --disable-libssp --disable-werror \
|
||||
--enable-checking=release $CONFIGFLAG
|
||||
make
|
||||
|
||||
|
@ -100,7 +90,7 @@ check() {
|
|||
|
||||
# do not abort on error as some are "expected"
|
||||
#make -k check || true
|
||||
#${_basedir}/contrib/test_summary
|
||||
#${srcdir}/${_basedir}/contrib/test_summary
|
||||
}
|
||||
|
||||
package_gcc-libs()
|
||||
|
@ -112,7 +102,7 @@ package_gcc-libs()
|
|||
|
||||
cd ${srcdir}/gcc-build
|
||||
make -j1 -C $CHOST/libgcc DESTDIR=${pkgdir} install-shared
|
||||
for lib in libmudflap libgomp libstdc++-v3/src libitm; do
|
||||
for lib in libmudflap libgomp libstdc++-v3/src libitm libsanitizer/asan; do
|
||||
make -j1 -C $CHOST/$lib DESTDIR=${pkgdir} install-toolexeclibLTLIBRARIES
|
||||
done
|
||||
make -j1 -C $CHOST/libstdc++-v3/po DESTDIR=${pkgdir} install
|
||||
|
@ -129,14 +119,14 @@ package_gcc-libs()
|
|||
find ${pkgdir} -name *.a -delete
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${_basedir}/COPYING.RUNTIME \
|
||||
install -Dm644 ${srcdir}/${_basedir}/COPYING.RUNTIME \
|
||||
${pkgdir}/usr/share/licenses/gcc-libs/RUNTIME.LIBRARY.EXCEPTION
|
||||
}
|
||||
|
||||
package_gcc()
|
||||
{
|
||||
pkgdesc="The GNU Compiler Collection - C and C++ frontends"
|
||||
depends=("gcc-libs=$pkgver-$pkgrel" 'binutils>=2.23' 'libmpc' 'cloog' 'ppl')
|
||||
depends=("gcc-libs=$pkgver-$pkgrel" 'binutils>=2.23' 'libmpc' 'cloog')
|
||||
groups=('base-devel')
|
||||
install=gcc.install
|
||||
|
||||
|
@ -145,18 +135,18 @@ package_gcc()
|
|||
make -j1 DESTDIR=${pkgdir} install
|
||||
|
||||
install -d $pkgdir/usr/share/gdb/auto-load/usr/lib
|
||||
mv $pkgdir{,/usr/share/gdb/auto-load}/usr/lib/libstdc++.so.6.0.17-gdb.py
|
||||
mv $pkgdir{,/usr/share/gdb/auto-load}/usr/lib/libstdc++.so.6.0.18-gdb.py
|
||||
|
||||
# unfortunately it is much, much easier to install the lot and clean-up the mess...
|
||||
rm -f $pkgdir/usr/bin/{{$CHOST-,}gfortran,{$CHOST-,}gccgo}
|
||||
rm -f $pkgdir/usr/lib/*.so*
|
||||
rm -f $pkgdir/usr/lib/lib{ffi,gfortran,go{,begin},objc}.a
|
||||
rm -f $pkgdir/usr/lib/lib{atomic,ffi,gfortran,go{,begin},iberty,objc}.a
|
||||
rm -f $pkgdir/usr/lib/libgfortran.spec
|
||||
rm -f -r $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{finclude,include/objc}
|
||||
rm -f $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/include/{ffi{,target}.h}
|
||||
rm -f $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{cc1obj{,plus},f951,go1}
|
||||
rm -f $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{libcaf_single,libgfortranbegin}.a
|
||||
rm -f $pkgdir/usr/share/info/{gccgo,gfortran,libgomp,libitm}.info
|
||||
rm -f $pkgdir/usr/share/info/{gccgo,gfortran,libffi,libgomp,libquadmath,libitm}.info
|
||||
rm -f -r $pkgdir/usr/lib/go
|
||||
rm -f $pkgdir/usr/share/locale/{de,fr}/LC_MESSAGES/libstdc++.mo
|
||||
rm -f $pkgdir/usr/share/man/man1/{gccgo,gfortran}.1
|
||||
|
@ -201,7 +191,7 @@ EOF
|
|||
${CHOST}/libstdc++-v3/doc/doxygen/man/man3/*.3
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${_basedir}/COPYING.RUNTIME \
|
||||
install -Dm644 ${srcdir}/${_basedir}/COPYING.RUNTIME \
|
||||
${pkgdir}/usr/share/licenses/gcc/RUNTIME.LIBRARY.EXCEPTION
|
||||
}
|
||||
|
||||
|
@ -219,10 +209,15 @@ package_gcc-fortran()
|
|||
|
||||
ln -s gfortran ${pkgdir}/usr/bin/f95
|
||||
|
||||
rm -f ${pkgdir}/usr/lib/libgfortran.so*
|
||||
# remove files included in gcc-libs or gcc
|
||||
rm -f ${pkgdir}/usr/lib/lib{gfortran,gcc_s}.so*
|
||||
rm -f ${pkgdir}/usr/lib/libquadmath.{a,so*}
|
||||
rm -f ${pkgdir}/usr/lib/gcc/$CHOST/${pkgver}/{*.o,libgc*}
|
||||
rm -f ${pkgdir}/usr/share/info/libquadmath.info
|
||||
rm -rf ${pkgdir}/usr/lib/gcc/$CHOST/${pkgver}/include
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${_basedir}/COPYING.RUNTIME \
|
||||
install -Dm644 ${srcdir}/${_basedir}/COPYING.RUNTIME \
|
||||
${pkgdir}/usr/share/licenses/gcc-fortran/RUNTIME.LIBRARY.EXCEPTION
|
||||
}
|
||||
|
||||
|
@ -236,11 +231,13 @@ package_gcc-objc()
|
|||
install -dm755 $pkgdir/usr/lib/gcc/$CHOST/$pkgver/
|
||||
install -m755 gcc/cc1obj{,plus} $pkgdir/usr/lib/gcc/$CHOST/$pkgver/
|
||||
|
||||
# remove libraries included in gcc-libs
|
||||
rm -f ${pkgdir}/usr/lib/libobjc.so*
|
||||
# remove files included in gcc-libs or gcc
|
||||
rm ${pkgdir}/usr/lib/lib{gcc_s,objc}.so*
|
||||
rm $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{*.o,lib*}
|
||||
rm $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/include/unwind.h
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${_basedir}/COPYING.RUNTIME \
|
||||
install -Dm644 ${srcdir}/${_basedir}/COPYING.RUNTIME \
|
||||
${pkgdir}/usr/share/licenses/gcc-objc/RUNTIME.LIBRARY.EXCEPTION
|
||||
}
|
||||
|
||||
|
@ -256,6 +253,6 @@ package_gcc-go()
|
|||
install -Dm755 gcc/go1 $pkgdir/usr/lib/gcc/$CHOST/$pkgver/go1
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${_basedir}/COPYING.RUNTIME \
|
||||
install -Dm644 ${srcdir}/${_basedir}/COPYING.RUNTIME \
|
||||
${pkgdir}/usr/share/licenses/gcc-go/RUNTIME.LIBRARY.EXCEPTION
|
||||
}
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff -Naur gcc-4.7.1-orig/libgo/runtime/print.c gcc-4.7.1/libgo/runtime/print.c
|
||||
--- gcc-4.7.1-orig/libgo/runtime/print.c 2012-05-26 04:22:14.000000000 +1000
|
||||
+++ gcc-4.7.1/libgo/runtime/print.c 2012-06-16 15:06:28.553138502 +1000
|
||||
@@ -17,7 +17,8 @@
|
||||
G* g = runtime_g();
|
||||
|
||||
if(g == nil || g->writebuf == nil) {
|
||||
- runtime_write(2, v, n);
|
||||
+ ssize_t bytesWritten = runtime_write(2, v, n);
|
||||
+ (void)bytesWritten;
|
||||
return;
|
||||
}
|
Loading…
Reference in a new issue