community/blender to 3.4.1-13

This commit is contained in:
Kevin Mihelich 2023-02-07 00:57:41 +00:00
parent eda49be591
commit ee9982b7cc
2 changed files with 19 additions and 1 deletions

View file

@ -16,7 +16,7 @@ buildarch=8
pkgname=blender
pkgver=3.4.1
pkgrel=12
pkgrel=13
epoch=17
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('x86_64')
@ -37,6 +37,7 @@ source=("git+https://git.blender.org/blender.git#tag=v$pkgver"
"git+https://git.blender.org/blender-translations.git"
"git+https://git.blender.org/blender-dev-tools.git"
https://developer.download.nvidia.com/redist/optix/v7.5/OptiX-7.5-Include.zip
blender-numpy.patch
force-draco1.patch
force-draco2.patch)
sha512sums=('SKIP'
@ -45,6 +46,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'32a77c7a64c5d38f2af76b2c0d09c6b53b7adcc7d85a0b271ba09647858b21fb8f534da5dc4143079359cbedc8074a58715ff2cea0b85019596531a7dca8dbf7'
'a39d9a13515b71d3b686d8f011b3eb9ee45de04f716627d711c5119317cb130c587da1b806f276f97064f814cfce3790b201731f047e5ec01e7d6f65acd04b3b'
'e239da4f3906f1b54265435181cf770bae3d269c8d915df9a73861e6ee71ec70bf2339426e7c81a91e5a567273b3b3742d7a99feefd3398d821b26e1ff3a56d0'
'527ab66e5eace777de0043c1ca5787a488f6471450ce67fd6d08137ad0ef56177bc0c17696f30a5fca23fa55d8ca9c3f30cb7b17550dba2dbd8e89ca0b361990')
@ -64,6 +66,9 @@ prepare() {
patch -p1 -i "$srcdir"/force-draco1.patch
patch -p1 -d release/scripts/addons -i "$srcdir"/force-draco2.patch
# fix for FS#77376
patch -p1 -d release/scripts/addons -i "$srcdir"/blender-numpy.patch
}
get_pyver() {

View file

@ -0,0 +1,13 @@
diff --git a/io_scene_gltf2/blender/imp/gltf2_blender_mesh.py b/io_scene_gltf2/blender/imp/gltf2_blender_mesh.py
index 41dd4d03..a97f9d38 100755
--- a/io_scene_gltf2/blender/imp/gltf2_blender_mesh.py
+++ b/io_scene_gltf2/blender/imp/gltf2_blender_mesh.py
@@ -572,7 +572,7 @@ def set_poly_smoothing(gltf, pymesh, mesh, vert_normals, loop_vidxs):
# Try to guess which polys should be flat based on the fact that all the
# loop normals for a flat poly are = the poly's normal.
- poly_smooths = np.empty(num_polys, dtype=np.bool)
+ poly_smooths = np.empty(num_polys, dtype=np.bool_)
poly_normals = np.empty(num_polys * 3, dtype=np.float32)
mesh.polygons.foreach_get('normal', poly_normals)