mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/mesa to 12.0.1-2
This commit is contained in:
parent
37c4f854cd
commit
eec0eb170f
3 changed files with 125 additions and 3 deletions
|
@ -0,0 +1,76 @@
|
|||
From 9ce52baf7f479d506bcea17a371dcf2fad92f139 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Christian=20K=C3=B6nig?= <christian.koenig@amd.com>
|
||||
Date: Wed, 13 Jul 2016 14:54:31 +0200
|
||||
Subject: [PATCH] st/mesa: fix reference counting bug in st_vdpau
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Otherwise we leak the resources created for the DMA-buf descriptors.
|
||||
|
||||
Signed-off-by: Christian König <christian.koenig@amd.com>
|
||||
Cc: 12.0 <mesa-stable@lists.freedesktop.org>
|
||||
Tested-and-Reviewed by: Leo Liu <leo.liu@amd.com>
|
||||
Ack-by: Tom St Denis <tom.stdenis@amd.com>
|
||||
---
|
||||
src/mesa/state_tracker/st_vdpau.c | 10 ++++++++--
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/mesa/state_tracker/st_vdpau.c b/src/mesa/state_tracker/st_vdpau.c
|
||||
index dffa52f..4f599dd 100644
|
||||
--- a/src/mesa/state_tracker/st_vdpau.c
|
||||
+++ b/src/mesa/state_tracker/st_vdpau.c
|
||||
@@ -65,6 +65,7 @@ st_vdpau_video_surface_gallium(struct gl_context *ctx, const void *vdpSurface,
|
||||
|
||||
struct pipe_video_buffer *buffer;
|
||||
struct pipe_sampler_view **samplers;
|
||||
+ struct pipe_resource *res = NULL;
|
||||
|
||||
getProcAddr = (void *)ctx->vdpGetProcAddress;
|
||||
if (getProcAddr(device, VDP_FUNC_ID_VIDEO_SURFACE_GALLIUM, (void**)&f))
|
||||
@@ -82,7 +83,8 @@ st_vdpau_video_surface_gallium(struct gl_context *ctx, const void *vdpSurface,
|
||||
if (!sv)
|
||||
return NULL;
|
||||
|
||||
- return sv->texture;
|
||||
+ pipe_resource_reference(&res, sv->texture);
|
||||
+ return res;
|
||||
}
|
||||
|
||||
static struct pipe_resource *
|
||||
@@ -90,13 +92,15 @@ st_vdpau_output_surface_gallium(struct gl_context *ctx, const void *vdpSurface)
|
||||
{
|
||||
int (*getProcAddr)(uint32_t device, uint32_t id, void **ptr);
|
||||
uint32_t device = (uintptr_t)ctx->vdpDevice;
|
||||
+ struct pipe_resource *res = NULL;
|
||||
VdpOutputSurfaceGallium *f;
|
||||
|
||||
getProcAddr = (void *)ctx->vdpGetProcAddress;
|
||||
if (getProcAddr(device, VDP_FUNC_ID_OUTPUT_SURFACE_GALLIUM, (void**)&f))
|
||||
return NULL;
|
||||
|
||||
- return f((uintptr_t)vdpSurface);
|
||||
+ pipe_resource_reference(&res, f((uintptr_t)vdpSurface));
|
||||
+ return res;
|
||||
}
|
||||
|
||||
static struct pipe_resource *
|
||||
@@ -208,6 +212,7 @@ st_vdpau_map_surface(struct gl_context *ctx, GLenum target, GLenum access,
|
||||
/* do we have different screen objects ? */
|
||||
if (res->screen != st->pipe->screen) {
|
||||
_mesa_error(ctx, GL_INVALID_OPERATION, "VDPAUMapSurfacesNV");
|
||||
+ pipe_resource_reference(&res, NULL);
|
||||
return;
|
||||
}
|
||||
|
||||
@@ -241,6 +246,7 @@ st_vdpau_map_surface(struct gl_context *ctx, GLenum target, GLenum access,
|
||||
stObj->surface_format = res->format;
|
||||
|
||||
_mesa_dirty_texobj(ctx, texObj);
|
||||
+ pipe_resource_reference(&res, NULL);
|
||||
}
|
||||
|
||||
static void
|
||||
--
|
||||
2.9.0
|
||||
|
|
@ -0,0 +1,38 @@
|
|||
From 134d6e4e4f980d738361bfcae1daedb8cc58b5df Mon Sep 17 00:00:00 2001
|
||||
From: Leo Liu <leo.liu@amd.com>
|
||||
Date: Thu, 14 Jul 2016 09:19:59 -0400
|
||||
Subject: [PATCH] vl/dri3: fix a memory leak from front buffer
|
||||
|
||||
Inspired by fix for mem leak of vdpau interop, resource_from_handle
|
||||
set texture reference count, that need to be decreased and released,
|
||||
recall there is a similar case for DRI3, that is with VA-API glx
|
||||
extension, there is temporary TFP(texture from pixmap), we target it
|
||||
through dma-buf. leak happens when without count down the reference.
|
||||
|
||||
Checked and found with mpv vo=opengl case, there only one static TFP,
|
||||
the leak happens once, but for totem player using gstreamer VA-API glx,
|
||||
the dynamic TFP for each frame, so leak quite a bit.
|
||||
|
||||
This fixes mem leak for mpv and totem.
|
||||
|
||||
Signed-off-by: Leo Liu <leo.liu@amd.com>
|
||||
Cc: "12.0" <mesa-stable@lists.freedesktop.org>
|
||||
---
|
||||
src/gallium/auxiliary/vl/vl_winsys_dri3.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/gallium/auxiliary/vl/vl_winsys_dri3.c b/src/gallium/auxiliary/vl/vl_winsys_dri3.c
|
||||
index f7f572e..493e645 100644
|
||||
--- a/src/gallium/auxiliary/vl/vl_winsys_dri3.c
|
||||
+++ b/src/gallium/auxiliary/vl/vl_winsys_dri3.c
|
||||
@@ -89,6 +89,7 @@ dri3_free_front_buffer(struct vl_dri3_screen *scrn,
|
||||
{
|
||||
xcb_sync_destroy_fence(scrn->conn, buffer->sync_fence);
|
||||
xshmfence_unmap_shm(buffer->shm_fence);
|
||||
+ pipe_resource_reference(&buffer->texture, NULL);
|
||||
FREE(buffer);
|
||||
}
|
||||
|
||||
--
|
||||
2.9.0
|
||||
|
|
@ -11,7 +11,7 @@
|
|||
pkgbase=mesa
|
||||
pkgname=('mesa' 'mesa-libgl' 'libva-mesa-driver')
|
||||
pkgver=12.0.1
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
|
||||
'libxshmfence' 'libxxf86vm' 'libxdamage' 'libvdpau' 'libva' 'wayland' 'elfutils' 'llvm'
|
||||
|
@ -21,11 +21,15 @@ license=('custom')
|
|||
options=('!libtool')
|
||||
source=(ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/mesa-${pkgver}.tar.xz{,.sig}
|
||||
LICENSE
|
||||
remove-libpthread-stubs.patch)
|
||||
remove-libpthread-stubs.patch
|
||||
0001-st-mesa-fix-reference-counting-bug-in-st_vdpau.patch
|
||||
0002-vl-dri3-fix-a-memory-leak-from-front-buffer.patch)
|
||||
sha256sums=('bab24fb79f78c876073527f515ed871fc9c81d816f66c8a0b051d8d653896389'
|
||||
'SKIP'
|
||||
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2'
|
||||
'd82c329e89754266eb1538df29b94d33692a66e3b6882b2cee78f4d5aab4a39c')
|
||||
'd82c329e89754266eb1538df29b94d33692a66e3b6882b2cee78f4d5aab4a39c'
|
||||
'ccc8ea7f4e38f2dc26fd29150929e943aac5bc9b56bd3eddec882c6ccd1d64a5'
|
||||
'f6c17257e96182ce51b85ef75cef4f6c205b00dfbf8fc1089cd77c4a3eda6981')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D') # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
|
||||
prepare() {
|
||||
|
@ -34,6 +38,10 @@ prepare() {
|
|||
# Now mesa checks for libpthread-stubs - so remove the check
|
||||
patch -Np1 -i ../remove-libpthread-stubs.patch
|
||||
|
||||
# fix memory leaks - merged upstream
|
||||
patch -Np1 -i ../0001-st-mesa-fix-reference-counting-bug-in-st_vdpau.patch
|
||||
patch -Np1 -i ../0002-vl-dri3-fix-a-memory-leak-from-front-buffer.patch
|
||||
|
||||
autoreconf -fiv
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue