core/pacman to 5.0.0-1

This commit is contained in:
Kevin Mihelich 2016-02-01 13:19:58 +00:00
parent f019743e90
commit ef05696029
5 changed files with 54 additions and 20 deletions

View file

@ -1,7 +1,7 @@
From d78f14170b2950fd3a252bec1ecc808a6de433b1 Mon Sep 17 00:00:00 2001
From 25b7d2243038723c95402c0e6e1bdaa38817c92f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 13 Sep 2014 18:58:16 -0600
Subject: [PATCH] Sychronize filesystem
Subject: [PATCH 1/2] Sychronize filesystem
Since many problems arise from improper flushing of the filesystem,
particularly package installations followed by a reboot very shorly after,
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+)
diff --git a/lib/libalpm/trans.c b/lib/libalpm/trans.c
index e680feb..1e103f2 100644
index 239d6a1..8a6260a 100644
--- a/lib/libalpm/trans.c
+++ b/lib/libalpm/trans.c
@@ -211,6 +211,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
@@ -230,6 +230,9 @@ int SYMEXPORT alpm_trans_commit(alpm_handle_t *handle, alpm_list_t **data)
trans->state = STATE_COMMITED;
@ -28,5 +28,5 @@ index e680feb..1e103f2 100644
}
--
2.2.1
2.7.0

View file

@ -0,0 +1,32 @@
From 4a773b741fd6aca6e6f7183e40d40a06e9c65ee3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 30 Jan 2016 17:19:03 -0700
Subject: [PATCH 2/2] Revert "close stdin before running install scripts"
This reverts commit e374e6829cea3512f0b4a4069c5a6168f0f8d8a0.
Arch Linux ARM packages have use cases for this feature, such as
prompting the user to flash a new kernel to a bare partition. Removing
this feature will undoubtedly cause more problems than it intends to
solve.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
lib/libalpm/util.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/lib/libalpm/util.c b/lib/libalpm/util.c
index 001c042..f2d43ee 100644
--- a/lib/libalpm/util.c
+++ b/lib/libalpm/util.c
@@ -602,7 +602,6 @@ int _alpm_run_chroot(alpm_handle_t *handle, const char *cmd, char *const argv[],
if(pid == 0) {
/* this code runs for the child only (the actual chroot/exec) */
- close(0);
close(1);
close(2);
while(dup2(child2parent_pipefd[1], 1) == -1 && errno == EINTR);
--
2.7.0

View file

@ -1,23 +1,23 @@
# vim: set ts=2 sw=2 et:
# $Id: PKGBUILD 146700 2012-01-16 19:48:37Z dreisner $
# $Id$
# Maintainer: Dan McGee <dan@archlinux.org>
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - arch/host/flags for arm, armv6h, and armv7h
# - pacman.conf: architecture=arm/armv6h/armv7h, added our aur and alarm repos
# - arch/host/flags for arm, armv6h, armv7h, and aarch64
# - pacman.conf: architecture=arm/armv6h/armv7h/aarch64, added our aur and alarm repos
# - makepkg.conf: adjusted C/CXX/LDFLAGS
# - patch to sync filesystem after install/remove
pkgname=pacman
pkgver=4.2.1
pkgrel=4
pkgver=5.0.0
pkgrel=1
pkgdesc="A library-based package manager with dependency support"
arch=('i686' 'x86_64')
url="http://www.archlinux.org/pacman/"
license=('GPL')
groups=('base' 'base-devel')
depends=('bash' 'glibc' 'libarchive>=3.1.2' 'curl>=7.39.0'
depends=('bash' 'glibc' 'libarchive' 'curl'
'gpgme' 'pacman-mirrorlist')
makedepends=('asciidoc') # roundup patch alters docs
checkdepends=('python2' 'fakechroot')
@ -28,23 +28,23 @@ replaces=('pacman-contrib')
backup=(etc/pacman.conf etc/makepkg.conf)
options=('strip' 'debug')
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
ensure-matching-database-and-package-version.patch
0001-Sychronize-filesystem.patch
0002-Revert-close-stdin-before-running-install-scripts.patch
pacman.conf
makepkg.conf)
md5sums=('2a596fc8f723e99660c0869a74afcf47'
md5sums=('9ecf8a5b659c0e02232c945ab198e6e1'
'SKIP'
'e8f72afe6f417d11bd36ada042744fe4'
'291123878ec33ca8a3020ac85f2e91d1'
'5c491b27bae54d93d6ba972ce0fccfa7'
'c88c41076f26e97c6915d8b967df96e7')
'11869a104d0944cc86215098cf5a32bf'
'd4692c3add0b0dab87036edad3f59626'
'372fa63a5333ef22a0197d44b2a454ca'
'ace945b12a7a429af48b7a50f4119c4c')
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD') # Allan McRae <allan@archlinux.org>
prepare() {
cd $srcdir/$pkgname-$pkgver
patch -p1 -i $srcdir/ensure-matching-database-and-package-version.patch
patch -p1 -i ../0001-Sychronize-filesystem.patch
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch
}
build() {

View file

@ -74,7 +74,7 @@ BUILDENV=(!distcc color !ccache check !sign)
# These are default values for the options=() settings
#########################################################################
#
# Default: OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !upx !debug)
# Default: OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
# A negated option will do the opposite of the comments below.
#
#-- strip: Strip symbols from binaries/libraries
@ -85,9 +85,10 @@ BUILDENV=(!distcc color !ccache check !sign)
#-- zipman: Compress manual (man and info) pages in MAN_DIRS with gzip
#-- purge: Remove files specified by PURGE_TARGETS
#-- upx: Compress binary executable files using UPX
#-- optipng: Optimize PNG images with optipng
#-- debug: Add debugging flags as specified in DEBUG_* variables
#
OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !upx !debug)
OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
INTEGRITY_CHECK=(md5)

View file

@ -14,6 +14,7 @@
#CacheDir = /var/cache/pacman/pkg/
#LogFile = /var/log/pacman.log
#GPGDir = /etc/pacman.d/gnupg/
#HookDir = /etc/pacman.d/hooks/
HoldPkg = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u