mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/libgda to 5.2.10-2
This commit is contained in:
parent
fdfd9b364b
commit
ef0d6a9ad2
3 changed files with 76 additions and 3 deletions
67
community/libgda/0002-Use-goocanvas-3.0.patch
Normal file
67
community/libgda/0002-Use-goocanvas-3.0.patch
Normal file
|
@ -0,0 +1,67 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Sun, 14 Mar 2021 23:41:28 +0000
|
||||
Subject: [PATCH] Use goocanvas-3.0
|
||||
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
tools/browser/canvas/browser-canvas-text.c | 12 ++++++------
|
||||
2 files changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index b9e973617..fd03152ea 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -240,7 +240,7 @@ then
|
||||
|
||||
if test "$with_goo" = "auto" -o "$with_goo" = "yes"
|
||||
then
|
||||
- PKG_CHECK_MODULES(GOOCANVAS, "goocanvas-2.0", [
|
||||
+ PKG_CHECK_MODULES(GOOCANVAS, "goocanvas-3.0", [
|
||||
AC_DEFINE(HAVE_GOOCANVAS, [1], [GooCanvas support enabled])
|
||||
have_goocanvas=yes], [
|
||||
if test "$with_goo" = "yes"
|
||||
diff --git a/tools/browser/canvas/browser-canvas-text.c b/tools/browser/canvas/browser-canvas-text.c
|
||||
index 644bca9a8..4f0649443 100644
|
||||
--- a/tools/browser/canvas/browser-canvas-text.c
|
||||
+++ b/tools/browser/canvas/browser-canvas-text.c
|
||||
@@ -231,7 +231,7 @@ browser_canvas_text_set_property (GObject *object,
|
||||
const gchar *cstr = NULL;
|
||||
gchar *str;
|
||||
gdouble size = 0;
|
||||
- gboolean bool = FALSE;
|
||||
+ gboolean abool = FALSE;
|
||||
|
||||
ct = BROWSER_CANVAS_TEXT (object);
|
||||
|
||||
@@ -269,25 +269,25 @@ browser_canvas_text_set_property (GObject *object,
|
||||
ct->priv->highlight_color = g_strdup (BROWSER_CANVAS_ENTITY_COLOR);
|
||||
break;
|
||||
case PROP_UNDERLINE:
|
||||
- bool = g_value_get_boolean (value);
|
||||
- ct->priv->underline = bool;
|
||||
+ abool = g_value_get_boolean (value);
|
||||
+ ct->priv->underline = abool;
|
||||
adjust_text_pango_attributes (ct);
|
||||
if (ct->priv->text_item) {
|
||||
- if (bool) {
|
||||
+ if (abool) {
|
||||
str = g_strdup_printf ("<u>%s</u>", ct->priv->text);
|
||||
g_object_set (G_OBJECT (ct->priv->text_item),
|
||||
"text", str,
|
||||
"use-markup", TRUE, NULL);
|
||||
g_free (str);
|
||||
}
|
||||
else
|
||||
g_object_set (G_OBJECT (ct->priv->text_item),
|
||||
"text", ct->priv->text,
|
||||
"use-markup", FALSE, NULL);
|
||||
}
|
||||
case PROP_BOLD:
|
||||
- bool = g_value_get_boolean (value);
|
||||
- ct->priv->bold = bool;
|
||||
+ abool = g_value_get_boolean (value);
|
||||
+ ct->priv->bold = abool;
|
||||
adjust_text_pango_attributes (ct);
|
||||
break;
|
||||
default:
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgname=(libgda libgda-{jdbc,mysql,postgres})
|
||||
pkgver=5.2.10
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="Database access library"
|
||||
url="https://www.gnome-db.org/"
|
||||
arch=(x86_64)
|
||||
|
@ -17,9 +17,11 @@ makedepends=(glade mariadb-libs postgresql-libs jdk8-openjdk intltool
|
|||
gobject-introspection gtk-doc vala itstool gnome-common git)
|
||||
_commit=85a2532df64698306fd3be324bb2052fb1b80fd3 # tags/LIBGDA_5_2_10^0
|
||||
source=("git+https://gitlab.gnome.org/GNOME/libgda.git#commit=$_commit"
|
||||
0001-Use-single-header-with-GtkSource.patch)
|
||||
0001-Use-single-header-with-GtkSource.patch
|
||||
0002-Use-goocanvas-3.0.patch)
|
||||
sha256sums=('SKIP'
|
||||
'104594a6034b041d87c1129b0b5544c8899393d66a6a0fb7a8b55f7fcb77e560')
|
||||
'104594a6034b041d87c1129b0b5544c8899393d66a6a0fb7a8b55f7fcb77e560'
|
||||
'81ab26fd12f7174e880815f6aa624c24821b1f9c7f386ae566293df7f041b25b')
|
||||
|
||||
_apiver=5.0
|
||||
|
||||
|
@ -42,11 +44,15 @@ prepare() {
|
|||
# Fix use of gtksourceview headers
|
||||
git apply -3 ../0001-Use-single-header-with-GtkSource.patch
|
||||
|
||||
# Port to goocanvas-3.0
|
||||
git apply -3 ../0002-Use-goocanvas-3.0.patch
|
||||
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname
|
||||
CFLAGS+=" -Wno-deprecated-declarations"
|
||||
./configure --prefix=/usr --sysconfdir=/etc --disable-static \
|
||||
--with-bdb=/usr --with-bdb-libdir-name=lib \
|
||||
--enable-json --enable-system-sqlite --enable-binreloc \
|
Loading…
Reference in a new issue