mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/chromium to 20.0.1180.57-1
This commit is contained in:
parent
2d083f7b4d
commit
ef2d9a16f3
6 changed files with 588 additions and 128 deletions
|
@ -15,8 +15,8 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=chromium
|
||||
pkgver=20.0.1132.57
|
||||
pkgrel=2
|
||||
pkgver=20.0.1180.57
|
||||
pkgrel=1
|
||||
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.chromium.org/"
|
||||
|
@ -37,18 +37,16 @@ source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgna
|
|||
chromium.desktop
|
||||
chromium.default
|
||||
chromium.sh
|
||||
chromium-gcc47.patch
|
||||
chromium-20.0.1132.57-bison-2.6-remove-yyparse-decl.patch
|
||||
chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch
|
||||
sqlite-3.7.6.3-fix-out-of-scope-memory-reference.patch)
|
||||
sha256sums=('1225c6b6306e89c8892bc0d18e94567d6081d777dee9b8c90efd0da9f6f2641b'
|
||||
'0137e738cad095aeb03da0e4eb92df4ab8f4693c81d462eb5a413de6ecd875d1'
|
||||
chromium-20.0.1132.57-bison-2.6-fix.patch
|
||||
chromium-ppapi-r0.patch)
|
||||
sha256sums=('311ba95249ea994747355596885c9ad583e55bcbe7220a47ea096898e7aeb145'
|
||||
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
|
||||
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
|
||||
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
|
||||
'f607347ba8477d3c8e60eb3803d26f3c9869f77fd49986c60887c59a6aa7d30d'
|
||||
'8d0e0c53562eee3400606365e33aab035c487d7d958063bc25eea550c6fa3793'
|
||||
'c1baf14121502efbc2a31b64029dcafa0e28ca5b71ad0e28a3c6342d18198615'
|
||||
'a700aa054800d1b21d84eaba27c38a703dfa023e9226d11a942690c2a0630aff')
|
||||
'd7aecc17e1eb582fe791c3e5fb2ca3f0efcb9bf5379309c1c27be35be4363bba'
|
||||
'1f4b57670d317959bc2dc60e5d2a44aa8fc6028f7ed540cdb502fa0aa99c81bd')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/chromium-$pkgver"
|
||||
|
@ -56,23 +54,17 @@ build() {
|
|||
# Fix build with glibc 2.16
|
||||
patch -Np1 -i "$srcdir/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch"
|
||||
|
||||
# Fix build with bison 2.6 (XXX: hacky; waiting on proper upstream fix)
|
||||
# http://crbug.com/138243 / https://bugs.webkit.org/show_bug.cgi?id=91943
|
||||
patch -Np1 -i \
|
||||
"$srcdir/chromium-20.0.1132.57-bison-2.6-remove-yyparse-decl.patch"
|
||||
# Fix build with bison 2.6 (patch from Alexis Menard)
|
||||
# http://crbug.com/138243 / https://bugs.webkit.org/show_bug.cgi?id=92264
|
||||
patch -d third_party/WebKit -Np1 -i \
|
||||
"$srcdir/chromium-20.0.1132.57-bison-2.6-fix.patch"
|
||||
|
||||
# Fix build with gcc 4.7 (patch from openSUSE)
|
||||
patch -Np2 -i "$srcdir/chromium-gcc47.patch"
|
||||
# Fix build without NaCl glibc toolchain (patch from Gentoo)
|
||||
patch -Np0 -i "$srcdir/chromium-ppapi-r0.patch"
|
||||
|
||||
# http://code.google.com/p/chromium/issues/detail?id=109527
|
||||
sed -i 's|glib/gutils.h|glib.h|' ui/base/l10n/l10n_util.cc
|
||||
|
||||
# SQLite: Fix a problem in fts3_write.c causing stack memory to be referenced
|
||||
# after it is out of scope (http://www.sqlite.org/src/info/f9c4a7c8f4)
|
||||
# (http://code.google.com/p/chromium/issues/detail?id=122525)
|
||||
patch -i "$srcdir/sqlite-3.7.6.3-fix-out-of-scope-memory-reference.patch" \
|
||||
third_party/sqlite/amalgamation/sqlite3.c
|
||||
|
||||
# Use Python 2
|
||||
find . -type f -exec sed -i -r \
|
||||
-e 's|/usr/bin/python$|&2|g' \
|
||||
|
@ -83,7 +75,7 @@ build() {
|
|||
ln -s /usr/bin/python2 "$srcdir/python2-path/python"
|
||||
export PATH="$srcdir/python2-path:$PATH"
|
||||
|
||||
ln -s "$srcdir/pepper_${pkgver%%.*}/toolchain/linux_x86_newlib" \
|
||||
ln -s "$srcdir/pepper_${_nacl_sdk%%.*}/toolchain/linux_x86_newlib" \
|
||||
native_client/toolchain/linux_x86_newlib
|
||||
|
||||
# CFLAGS are passed through release_extra_cflags below
|
||||
|
@ -111,6 +103,7 @@ build() {
|
|||
-Duse_system_yasm=1 \
|
||||
-Duse_system_zlib=1 \
|
||||
-Duse_gconf=0 \
|
||||
-Ddisable_glibc=1 \
|
||||
-Ddisable_sse2=1 \
|
||||
-Dtarget_arch=arm \
|
||||
-Darmv7=1 \
|
||||
|
@ -136,20 +129,23 @@ package() {
|
|||
# Allow users to override command-line options
|
||||
install -Dm644 "$srcdir/chromium.default" "$pkgdir/etc/chromium/default"
|
||||
|
||||
cp -a out/Release/locales out/Release/resources "$pkgdir/usr/lib/chromium/"
|
||||
|
||||
find "$pkgdir/usr/lib/chromium/" -name '*.d' -type f -delete
|
||||
cp -a out/Release/locales "$pkgdir/usr/lib/chromium/"
|
||||
|
||||
install -Dm644 out/Release/chrome.1 "$pkgdir/usr/share/man/man1/chromium.1"
|
||||
|
||||
install -Dm644 "$srcdir/chromium.desktop" \
|
||||
"$pkgdir/usr/share/applications/chromium.desktop"
|
||||
|
||||
for size in 16 22 24 32 48 64 128 256; do
|
||||
for size in 22 24 48 64 128 256; do
|
||||
install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
|
||||
"$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
|
||||
done
|
||||
|
||||
for size in 16 32; do
|
||||
install -Dm644 "chrome/app/theme/default_100_percent/chromium/product_logo_$size.png" \
|
||||
"$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
|
||||
done
|
||||
|
||||
install -D "$srcdir/chromium.sh" "$pkgdir/usr/bin/chromium"
|
||||
|
||||
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
|
||||
|
|
554
extra/chromium/chromium-20.0.1132.57-bison-2.6-fix.patch
Normal file
554
extra/chromium/chromium-20.0.1132.57-bison-2.6-fix.patch
Normal file
|
@ -0,0 +1,554 @@
|
|||
diff --git a/Source/WebCore/css/CSSGrammar.y b/Source/WebCore/css/CSSGrammar.y
|
||||
index c7c10b541cd46ad4febc6efe289e81b2cfb0861e..1c604e76b4da4cc65f395bc4a73b112561bd5c84 100644
|
||||
--- a/Source/WebCore/css/CSSGrammar.y
|
||||
+++ b/Source/WebCore/css/CSSGrammar.y
|
||||
@@ -53,14 +53,13 @@ using namespace HTMLNames;
|
||||
#define YYMAXDEPTH 10000
|
||||
#define YYDEBUG 0
|
||||
|
||||
-// FIXME: Replace with %parse-param { CSSParser* parser } once we can depend on bison 2.x
|
||||
-#define YYPARSE_PARAM parser
|
||||
-#define YYLEX_PARAM parser
|
||||
-
|
||||
%}
|
||||
|
||||
%pure_parser
|
||||
|
||||
+%parse-param { CSSParser* parser }
|
||||
+%lex-param { CSSParser* parser }
|
||||
+
|
||||
%union {
|
||||
bool boolean;
|
||||
char character;
|
||||
@@ -89,7 +88,7 @@ using namespace HTMLNames;
|
||||
|
||||
%{
|
||||
|
||||
-static inline int cssyyerror(const char*)
|
||||
+static inline int cssyyerror(void*, const char*)
|
||||
{
|
||||
return 1;
|
||||
}
|
||||
diff --git a/Source/WebCore/css/CSSParser.cpp b/Source/WebCore/css/CSSParser.cpp
|
||||
index 650844060477cfc6ea6fdeaf11ec63b34ac646e7..8369549dbff25537cf93a11237a9bbbac4fe50f2 100644
|
||||
--- a/Source/WebCore/css/CSSParser.cpp
|
||||
+++ b/Source/WebCore/css/CSSParser.cpp
|
||||
@@ -114,7 +114,7 @@
|
||||
extern int cssyydebug;
|
||||
#endif
|
||||
|
||||
-extern int cssyyparse(void* parser);
|
||||
+extern int cssyyparse(WebCore::CSSParser*);
|
||||
|
||||
using namespace std;
|
||||
using namespace WTF;
|
||||
diff --git a/Source/WebCore/xml/XPathGrammar.y b/Source/WebCore/xml/XPathGrammar.y
|
||||
index 2eba5b35bd2338272a0f4ec756d137e47d2d59c8..d558211db2d89ea13716762a51397755560f66f3 100644
|
||||
--- a/Source/WebCore/xml/XPathGrammar.y
|
||||
+++ b/Source/WebCore/xml/XPathGrammar.y
|
||||
@@ -34,6 +34,7 @@
|
||||
#include "XPathParser.h"
|
||||
#include "XPathPath.h"
|
||||
#include "XPathPredicate.h"
|
||||
+#include "XPathStep.h"
|
||||
#include "XPathVariableReference.h"
|
||||
#include <wtf/FastMalloc.h>
|
||||
|
||||
@@ -44,8 +45,6 @@
|
||||
#define YYLTYPE_IS_TRIVIAL 1
|
||||
#define YYDEBUG 0
|
||||
#define YYMAXDEPTH 10000
|
||||
-#define YYPARSE_PARAM parserParameter
|
||||
-#define PARSER static_cast<Parser*>(parserParameter)
|
||||
|
||||
using namespace WebCore;
|
||||
using namespace XPath;
|
||||
@@ -53,6 +52,7 @@ using namespace XPath;
|
||||
%}
|
||||
|
||||
%pure_parser
|
||||
+%parse-param { WebCore::XPath::Parser* parser }
|
||||
|
||||
%union
|
||||
{
|
||||
@@ -71,7 +71,7 @@ using namespace XPath;
|
||||
%{
|
||||
|
||||
static int xpathyylex(YYSTYPE* yylval) { return Parser::current()->lex(yylval); }
|
||||
-static void xpathyyerror(const char*) { }
|
||||
+static void xpathyyerror(void*, const char*) { }
|
||||
|
||||
%}
|
||||
|
||||
@@ -118,7 +118,7 @@ static void xpathyyerror(const char*) { }
|
||||
Expr:
|
||||
OrExpr
|
||||
{
|
||||
- PARSER->m_topExpr = $1;
|
||||
+ parser->m_topExpr = $1;
|
||||
}
|
||||
;
|
||||
|
||||
@@ -138,7 +138,7 @@ AbsoluteLocationPath:
|
||||
'/'
|
||||
{
|
||||
$$ = new LocationPath;
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
'/' RelativeLocationPath
|
||||
@@ -150,7 +150,7 @@ AbsoluteLocationPath:
|
||||
{
|
||||
$$ = $2;
|
||||
$$->insertFirstStep($1);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($1);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -159,22 +159,22 @@ RelativeLocationPath:
|
||||
{
|
||||
$$ = new LocationPath;
|
||||
$$->appendStep($1);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
RelativeLocationPath '/' Step
|
||||
{
|
||||
$$->appendStep($3);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
+ parser->unregisterParseNode($3);
|
||||
}
|
||||
|
|
||||
RelativeLocationPath DescendantOrSelf Step
|
||||
{
|
||||
$$->appendStep($2);
|
||||
$$->appendStep($3);
|
||||
- PARSER->unregisterParseNode($2);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
+ parser->unregisterParseNode($2);
|
||||
+ parser->unregisterParseNode($3);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -183,58 +183,58 @@ Step:
|
||||
{
|
||||
if ($2) {
|
||||
$$ = new Step(Step::ChildAxis, *$1, *$2);
|
||||
- PARSER->deletePredicateVector($2);
|
||||
+ parser->deletePredicateVector($2);
|
||||
} else
|
||||
$$ = new Step(Step::ChildAxis, *$1);
|
||||
- PARSER->deleteNodeTest($1);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->deleteNodeTest($1);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
NAMETEST OptionalPredicateList
|
||||
{
|
||||
String localName;
|
||||
String namespaceURI;
|
||||
- if (!PARSER->expandQName(*$1, localName, namespaceURI)) {
|
||||
- PARSER->m_gotNamespaceError = true;
|
||||
+ if (!parser->expandQName(*$1, localName, namespaceURI)) {
|
||||
+ parser->m_gotNamespaceError = true;
|
||||
YYABORT;
|
||||
}
|
||||
|
||||
if ($2) {
|
||||
$$ = new Step(Step::ChildAxis, Step::NodeTest(Step::NodeTest::NameTest, localName, namespaceURI), *$2);
|
||||
- PARSER->deletePredicateVector($2);
|
||||
+ parser->deletePredicateVector($2);
|
||||
} else
|
||||
$$ = new Step(Step::ChildAxis, Step::NodeTest(Step::NodeTest::NameTest, localName, namespaceURI));
|
||||
- PARSER->deleteString($1);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->deleteString($1);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
AxisSpecifier NodeTest OptionalPredicateList
|
||||
{
|
||||
if ($3) {
|
||||
$$ = new Step($1, *$2, *$3);
|
||||
- PARSER->deletePredicateVector($3);
|
||||
+ parser->deletePredicateVector($3);
|
||||
} else
|
||||
$$ = new Step($1, *$2);
|
||||
- PARSER->deleteNodeTest($2);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->deleteNodeTest($2);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
AxisSpecifier NAMETEST OptionalPredicateList
|
||||
{
|
||||
String localName;
|
||||
String namespaceURI;
|
||||
- if (!PARSER->expandQName(*$2, localName, namespaceURI)) {
|
||||
- PARSER->m_gotNamespaceError = true;
|
||||
+ if (!parser->expandQName(*$2, localName, namespaceURI)) {
|
||||
+ parser->m_gotNamespaceError = true;
|
||||
YYABORT;
|
||||
}
|
||||
|
||||
if ($3) {
|
||||
$$ = new Step($1, Step::NodeTest(Step::NodeTest::NameTest, localName, namespaceURI), *$3);
|
||||
- PARSER->deletePredicateVector($3);
|
||||
+ parser->deletePredicateVector($3);
|
||||
} else
|
||||
$$ = new Step($1, Step::NodeTest(Step::NodeTest::NameTest, localName, namespaceURI));
|
||||
- PARSER->deleteString($2);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->deleteString($2);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
AbbreviatedStep
|
||||
@@ -259,23 +259,23 @@ NodeTest:
|
||||
else if (*$1 == "comment")
|
||||
$$ = new Step::NodeTest(Step::NodeTest::CommentNodeTest);
|
||||
|
||||
- PARSER->deleteString($1);
|
||||
- PARSER->registerNodeTest($$);
|
||||
+ parser->deleteString($1);
|
||||
+ parser->registerNodeTest($$);
|
||||
}
|
||||
|
|
||||
PI '(' ')'
|
||||
{
|
||||
$$ = new Step::NodeTest(Step::NodeTest::ProcessingInstructionNodeTest);
|
||||
- PARSER->deleteString($1);
|
||||
- PARSER->registerNodeTest($$);
|
||||
+ parser->deleteString($1);
|
||||
+ parser->registerNodeTest($$);
|
||||
}
|
||||
|
|
||||
PI '(' LITERAL ')'
|
||||
{
|
||||
$$ = new Step::NodeTest(Step::NodeTest::ProcessingInstructionNodeTest, $3->stripWhiteSpace());
|
||||
- PARSER->deleteString($1);
|
||||
- PARSER->deleteString($3);
|
||||
- PARSER->registerNodeTest($$);
|
||||
+ parser->deleteString($1);
|
||||
+ parser->deleteString($3);
|
||||
+ parser->registerNodeTest($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -293,14 +293,14 @@ PredicateList:
|
||||
{
|
||||
$$ = new Vector<Predicate*>;
|
||||
$$->append(new Predicate($1));
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->registerPredicateVector($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->registerPredicateVector($$);
|
||||
}
|
||||
|
|
||||
PredicateList Predicate
|
||||
{
|
||||
$$->append(new Predicate($2));
|
||||
- PARSER->unregisterParseNode($2);
|
||||
+ parser->unregisterParseNode($2);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -315,7 +315,7 @@ DescendantOrSelf:
|
||||
SLASHSLASH
|
||||
{
|
||||
$$ = new Step(Step::DescendantOrSelfAxis, Step::NodeTest(Step::NodeTest::AnyNodeTest));
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -323,13 +323,13 @@ AbbreviatedStep:
|
||||
'.'
|
||||
{
|
||||
$$ = new Step(Step::SelfAxis, Step::NodeTest(Step::NodeTest::AnyNodeTest));
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
DOTDOT
|
||||
{
|
||||
$$ = new Step(Step::ParentAxis, Step::NodeTest(Step::NodeTest::AnyNodeTest));
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -337,8 +337,8 @@ PrimaryExpr:
|
||||
VARIABLEREFERENCE
|
||||
{
|
||||
$$ = new VariableReference(*$1);
|
||||
- PARSER->deleteString($1);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->deleteString($1);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
'(' Expr ')'
|
||||
@@ -349,15 +349,15 @@ PrimaryExpr:
|
||||
LITERAL
|
||||
{
|
||||
$$ = new StringExpression(*$1);
|
||||
- PARSER->deleteString($1);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->deleteString($1);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
NUMBER
|
||||
{
|
||||
$$ = new Number($1->toDouble());
|
||||
- PARSER->deleteString($1);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->deleteString($1);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
FunctionCall
|
||||
@@ -369,8 +369,8 @@ FunctionCall:
|
||||
$$ = createFunction(*$1);
|
||||
if (!$$)
|
||||
YYABORT;
|
||||
- PARSER->deleteString($1);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->deleteString($1);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
FUNCTIONNAME '(' ArgumentList ')'
|
||||
@@ -378,9 +378,9 @@ FunctionCall:
|
||||
$$ = createFunction(*$1, *$3);
|
||||
if (!$$)
|
||||
YYABORT;
|
||||
- PARSER->deleteString($1);
|
||||
- PARSER->deleteExpressionVector($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->deleteString($1);
|
||||
+ parser->deleteExpressionVector($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -389,14 +389,14 @@ ArgumentList:
|
||||
{
|
||||
$$ = new Vector<Expression*>;
|
||||
$$->append($1);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->registerExpressionVector($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->registerExpressionVector($$);
|
||||
}
|
||||
|
|
||||
ArgumentList ',' Argument
|
||||
{
|
||||
$$->append($3);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
+ parser->unregisterParseNode($3);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -412,9 +412,9 @@ UnionExpr:
|
||||
$$ = new Union;
|
||||
$$->addSubExpression($1);
|
||||
$$->addSubExpression($3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -430,9 +430,9 @@ PathExpr:
|
||||
{
|
||||
$3->setAbsolute(true);
|
||||
$$ = new Path(static_cast<Filter*>($1), $3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
FilterExpr DescendantOrSelf RelativeLocationPath
|
||||
@@ -440,10 +440,10 @@ PathExpr:
|
||||
$3->insertFirstStep($2);
|
||||
$3->setAbsolute(true);
|
||||
$$ = new Path(static_cast<Filter*>($1), $3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($2);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($2);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -453,9 +453,9 @@ FilterExpr:
|
||||
PrimaryExpr PredicateList
|
||||
{
|
||||
$$ = new Filter($1, *$2);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->deletePredicateVector($2);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->deletePredicateVector($2);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -465,9 +465,9 @@ OrExpr:
|
||||
OrExpr OR AndExpr
|
||||
{
|
||||
$$ = new LogicalOp(LogicalOp::OP_Or, $1, $3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -477,9 +477,9 @@ AndExpr:
|
||||
AndExpr AND EqualityExpr
|
||||
{
|
||||
$$ = new LogicalOp(LogicalOp::OP_And, $1, $3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -489,9 +489,9 @@ EqualityExpr:
|
||||
EqualityExpr EQOP RelationalExpr
|
||||
{
|
||||
$$ = new EqTestOp($2, $1, $3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -501,9 +501,9 @@ RelationalExpr:
|
||||
RelationalExpr RELOP AdditiveExpr
|
||||
{
|
||||
$$ = new EqTestOp($2, $1, $3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -513,17 +513,17 @@ AdditiveExpr:
|
||||
AdditiveExpr PLUS MultiplicativeExpr
|
||||
{
|
||||
$$ = new NumericOp(NumericOp::OP_Add, $1, $3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
|
|
||||
AdditiveExpr MINUS MultiplicativeExpr
|
||||
{
|
||||
$$ = new NumericOp(NumericOp::OP_Sub, $1, $3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -533,9 +533,9 @@ MultiplicativeExpr:
|
||||
MultiplicativeExpr MULOP UnaryExpr
|
||||
{
|
||||
$$ = new NumericOp($2, $1, $3);
|
||||
- PARSER->unregisterParseNode($1);
|
||||
- PARSER->unregisterParseNode($3);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($1);
|
||||
+ parser->unregisterParseNode($3);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
@@ -546,8 +546,8 @@ UnaryExpr:
|
||||
{
|
||||
$$ = new Negative;
|
||||
$$->addSubExpression($2);
|
||||
- PARSER->unregisterParseNode($2);
|
||||
- PARSER->registerParseNode($$);
|
||||
+ parser->unregisterParseNode($2);
|
||||
+ parser->registerParseNode($$);
|
||||
}
|
||||
;
|
||||
|
||||
diff --git a/Source/WebCore/xml/XPathParser.cpp b/Source/WebCore/xml/XPathParser.cpp
|
||||
index 62d8ee37fd6ebb74a580a00c59beb6cd40c5a8b7..b5e6a9237593b4aaa2a243f2ff9d86e57f930a97 100644
|
||||
--- a/Source/WebCore/xml/XPathParser.cpp
|
||||
+++ b/Source/WebCore/xml/XPathParser.cpp
|
||||
@@ -32,24 +32,21 @@
|
||||
#include "XPathEvaluator.h"
|
||||
#include "XPathException.h"
|
||||
#include "XPathNSResolver.h"
|
||||
+#include "XPathPath.h"
|
||||
#include "XPathStep.h"
|
||||
#include <wtf/StdLibExtras.h>
|
||||
#include <wtf/text/StringHash.h>
|
||||
|
||||
-int xpathyyparse(void*);
|
||||
-
|
||||
+using namespace WebCore;
|
||||
using namespace WTF;
|
||||
using namespace Unicode;
|
||||
+using namespace XPath;
|
||||
|
||||
-namespace WebCore {
|
||||
-namespace XPath {
|
||||
-
|
||||
-class LocationPath;
|
||||
-
|
||||
-#include "XPathGrammar.h"
|
||||
+extern int xpathyyparse(WebCore::XPath::Parser*);
|
||||
+#include "XPathGrammar.h"
|
||||
|
||||
Parser* Parser::currentParser = 0;
|
||||
-
|
||||
+
|
||||
enum XMLCat { NameStart, NameCont, NotPartOfName };
|
||||
|
||||
typedef HashMap<String, Step::Axis> AxisNamesMap;
|
||||
@@ -630,5 +627,3 @@ void Parser::deleteNodeTest(Step::NodeTest* t)
|
||||
delete t;
|
||||
}
|
||||
|
||||
-}
|
||||
-}
|
|
@ -1,22 +0,0 @@
|
|||
diff -upr chromium-20.0.1132.57.orig/third_party/WebKit/Source/WebCore/WebCore.gyp/scripts/rule_bison.py chromium-20.0.1132.57/third_party/WebKit/Source/WebCore/WebCore.gyp/scripts/rule_bison.py
|
||||
--- chromium-20.0.1132.57.orig/third_party/WebKit/Source/WebCore/WebCore.gyp/scripts/rule_bison.py 2012-07-10 10:51:56.000000000 +0300
|
||||
+++ chromium-20.0.1132.57/third_party/WebKit/Source/WebCore/WebCore.gyp/scripts/rule_bison.py 2012-07-24 20:20:48.316103484 +0300
|
||||
@@ -87,7 +87,7 @@ assert outputHTmp != None
|
||||
|
||||
# Read the header file in under the generated name and remove it.
|
||||
outputHFile = open(outputHTmp)
|
||||
-outputHContents = outputHFile.read()
|
||||
+outputHContents = outputHFile.readlines()
|
||||
outputHFile.close()
|
||||
os.unlink(outputHTmp)
|
||||
|
||||
@@ -97,6 +97,8 @@ outputH = os.path.join(outputDir, inputR
|
||||
outputHFile = open(outputH, 'w')
|
||||
print >>outputHFile, '#ifndef %sH' % inputRoot
|
||||
print >>outputHFile, '#define %sH' % inputRoot
|
||||
-print >>outputHFile, outputHContents
|
||||
+print >>outputHFile, ''.join(filter(
|
||||
+ lambda line: not line.startswith('int %sparse' % prefix),
|
||||
+ outputHContents))
|
||||
print >>outputHFile, '#endif'
|
||||
outputHFile.close()
|
|
@ -1,53 +0,0 @@
|
|||
--- chromium-17.0.963.46/src/base/message_pump_libevent.cc.gcc47 2012-02-17 14:52:00.527217354 -0500
|
||||
+++ chromium-17.0.963.46/src/base/message_pump_libevent.cc 2012-02-17 14:52:10.172135400 -0500
|
||||
@@ -6,6 +6,7 @@
|
||||
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include "base/auto_reset.h"
|
||||
#include "base/compiler_specific.h"
|
||||
--- chromium-17.0.963.46/src/chrome/browser/policy/policy_path_parser_linux.cc.gcc47 2012-02-17 15:26:32.086746278 -0500
|
||||
+++ chromium-17.0.963.46/src/chrome/browser/policy/policy_path_parser_linux.cc 2012-02-17 15:26:53.039544290 -0500
|
||||
@@ -3,6 +3,7 @@
|
||||
// found in the LICENSE file.
|
||||
|
||||
#include <pwd.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include "chrome/browser/policy/policy_path_parser.h"
|
||||
|
||||
--- chromium-17.0.963.46/src/ipc/ipc_channel.h.gcc47 2012-01-27 03:02:07.000000000 -0500
|
||||
+++ chromium-17.0.963.46/src/ipc/ipc_channel.h 2012-02-17 14:46:31.821010460 -0500
|
||||
@@ -9,6 +9,7 @@
|
||||
#include "base/process.h"
|
||||
#include "ipc/ipc_channel_handle.h"
|
||||
#include "ipc/ipc_message.h"
|
||||
+#include <sys/types.h>
|
||||
|
||||
namespace IPC {
|
||||
|
||||
--- chromium-17.0.963.46/src/ipc/ipc_platform_file.cc.gcc47 2012-01-27 03:02:07.000000000 -0500
|
||||
+++ chromium-17.0.963.46/src/ipc/ipc_platform_file.cc 2012-02-17 14:46:31.824010435 -0500
|
||||
@@ -3,10 +3,7 @@
|
||||
// found in the LICENSE file.
|
||||
|
||||
#include "ipc/ipc_platform_file.h"
|
||||
-
|
||||
-#if defined(OS_ANDROID)
|
||||
#include <unistd.h>
|
||||
-#endif
|
||||
|
||||
namespace IPC {
|
||||
|
||||
--- chromium-17.0.963.46/src/seccompsandbox/library.h.gcc47 2012-01-27 03:03:35.000000000 -0500
|
||||
+++ chromium-17.0.963.46/src/seccompsandbox/library.h 2012-02-17 14:46:31.826010418 -0500
|
||||
@@ -12,6 +12,7 @@
|
||||
#include <string>
|
||||
#include <string.h>
|
||||
#include <sys/mman.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
#include "maps.h"
|
||||
|
11
extra/chromium/chromium-ppapi-r0.patch
Normal file
11
extra/chromium/chromium-ppapi-r0.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ppapi/ppapi_untrusted.gyp.orig 2012-06-12 10:20:16.000000000 +0200
|
||||
+++ ppapi/ppapi_untrusted.gyp 2012-06-12 10:20:52.000000000 +0200
|
||||
@@ -80,7 +80,7 @@
|
||||
],
|
||||
},
|
||||
'conditions': [
|
||||
- ['target_arch!="arm"', {
|
||||
+ ['target_arch!="arm" and disable_glibc==0', {
|
||||
'variables': {
|
||||
'build_glibc': 1,
|
||||
# NOTE: Use /lib, not /lib64 here; it is a symbolic link which
|
|
@ -1,26 +0,0 @@
|
|||
--- ext/fts3/fts3_write.c.orig 2012-05-08 21:05:03.000000000 +0300
|
||||
+++ ext/fts3/fts3_write.c 2012-05-08 21:07:08.000000000 +0300
|
||||
@@ -1238,13 +1238,13 @@ int sqlite3Fts3SegReaderPending(
|
||||
Fts3SegReader **ppReader /* OUT: SegReader for pending-terms */
|
||||
){
|
||||
Fts3SegReader *pReader = 0; /* Fts3SegReader object to return */
|
||||
+ Fts3HashElem *pE; /* Iterator variable */
|
||||
Fts3HashElem **aElem = 0; /* Array of term hash entries to scan */
|
||||
int nElem = 0; /* Size of array at aElem */
|
||||
int rc = SQLITE_OK; /* Return Code */
|
||||
|
||||
if( isPrefix ){
|
||||
int nAlloc = 0; /* Size of allocated array at aElem */
|
||||
- Fts3HashElem *pE = 0; /* Iterator variable */
|
||||
|
||||
for(pE=fts3HashFirst(&p->pendingTerms); pE; pE=fts3HashNext(pE)){
|
||||
char *zKey = (char *)fts3HashKey(pE);
|
||||
@@ -1276,7 +1276,7 @@ int sqlite3Fts3SegReaderPending(
|
||||
}
|
||||
|
||||
}else{
|
||||
- Fts3HashElem *pE = fts3HashFindElem(&p->pendingTerms, zTerm, nTerm);
|
||||
+ pE = fts3HashFindElem(&p->pendingTerms, zTerm, nTerm);
|
||||
if( pE ){
|
||||
aElem = &pE;
|
||||
nElem = 1;
|
Loading…
Reference in a new issue