mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/cups to 2.1.4-2
This commit is contained in:
parent
abbf9cb36e
commit
ef41044273
2 changed files with 56 additions and 4 deletions
|
@ -7,7 +7,7 @@
|
||||||
pkgbase="cups"
|
pkgbase="cups"
|
||||||
pkgname=('libcups' 'cups')
|
pkgname=('libcups' 'cups')
|
||||||
pkgver=2.1.4
|
pkgver=2.1.4
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
url="http://www.cups.org/"
|
url="http://www.cups.org/"
|
||||||
|
@ -23,6 +23,7 @@ source=(https://github.com/apple/cups/releases/download/release-${pkgver}/cups-$
|
||||||
cups-1.6.2-statedir.patch
|
cups-1.6.2-statedir.patch
|
||||||
cups-1.6.0-fix-install-perms.patch
|
cups-1.6.0-fix-install-perms.patch
|
||||||
# bugfixes
|
# bugfixes
|
||||||
|
cups-systemd-socket.patch
|
||||||
)
|
)
|
||||||
md5sums=('9f9bf6e3b9c20a3519b4dc409666d6e7'
|
md5sums=('9f9bf6e3b9c20a3519b4dc409666d6e7'
|
||||||
'fc8286f185e2cc5f7e1f6843bf193e2b'
|
'fc8286f185e2cc5f7e1f6843bf193e2b'
|
||||||
|
@ -31,7 +32,8 @@ md5sums=('9f9bf6e3b9c20a3519b4dc409666d6e7'
|
||||||
'1beb4896f217bc241bc08a422274ec0c'
|
'1beb4896f217bc241bc08a422274ec0c'
|
||||||
'90c30380d4c8cd48a908cfdadae1ea24'
|
'90c30380d4c8cd48a908cfdadae1ea24'
|
||||||
'451609db34f95209d64c38474de27ce1'
|
'451609db34f95209d64c38474de27ce1'
|
||||||
'5117f65342fcc69c6a506529e4daca9e')
|
'5117f65342fcc69c6a506529e4daca9e'
|
||||||
|
'25a618201dd4bbc73ba800da425000f1')
|
||||||
validpgpkeys=('3737FD0D0E63B30172440D2DDBA3A7AB08D76223') # CUPS.org (CUPS.org PGP key) <security@cups.org>
|
validpgpkeys=('3737FD0D0E63B30172440D2DDBA3A7AB08D76223') # CUPS.org (CUPS.org PGP key) <security@cups.org>
|
||||||
prepare() {
|
prepare() {
|
||||||
|
|
||||||
|
@ -49,8 +51,10 @@ prepare() {
|
||||||
# fix permissions on some files (by Gentoo) - alternative: cups-0755.patch by FC
|
# fix permissions on some files (by Gentoo) - alternative: cups-0755.patch by FC
|
||||||
patch -Np0 -i ${srcdir}/cups-1.6.0-fix-install-perms.patch
|
patch -Np0 -i ${srcdir}/cups-1.6.0-fix-install-perms.patch
|
||||||
|
|
||||||
# bug fixes
|
# bug fixes
|
||||||
|
# make sure network is up when starting and notify systemd - FC
|
||||||
|
patch -Np1 -i ${srcdir}/cups-systemd-socket.patch
|
||||||
|
|
||||||
# set MaxLogSize to 0 to prevent using cups internal log rotation
|
# set MaxLogSize to 0 to prevent using cups internal log rotation
|
||||||
sed -i -e '5i\ ' conf/cupsd.conf.in
|
sed -i -e '5i\ ' conf/cupsd.conf.in
|
||||||
sed -i -e '6i# Disable cups internal logging - use logrotate instead' conf/cupsd.conf.in
|
sed -i -e '6i# Disable cups internal logging - use logrotate instead' conf/cupsd.conf.in
|
||||||
|
|
48
extra/cups/cups-systemd-socket.patch
Normal file
48
extra/cups/cups-systemd-socket.patch
Normal file
|
@ -0,0 +1,48 @@
|
||||||
|
diff -up cups-2.0.2/scheduler/main.c.ustTJg cups-2.0.2/scheduler/main.c
|
||||||
|
--- cups-2.0.2/scheduler/main.c.ustTJg 2015-02-10 13:40:24.121547526 +0100
|
||||||
|
+++ cups-2.0.2/scheduler/main.c 2015-02-10 13:40:24.295545063 +0100
|
||||||
|
@@ -658,8 +658,15 @@ main(int argc, /* I - Number of comm
|
||||||
|
|
||||||
|
#if defined(HAVE_LAUNCHD) || defined(HAVE_SYSTEMD)
|
||||||
|
if (OnDemand)
|
||||||
|
+ {
|
||||||
|
cupsdAddEvent(CUPSD_EVENT_SERVER_STARTED, NULL, NULL, "Scheduler started on demand.");
|
||||||
|
- else
|
||||||
|
+# ifdef HAVE_SYSTEMD
|
||||||
|
+ sd_notifyf(0, "READY=1\n"
|
||||||
|
+ "STATUS=Scheduler is running...\n"
|
||||||
|
+ "MAINPID=%lu",
|
||||||
|
+ (unsigned long) getpid());
|
||||||
|
+# endif /* HAVE_SYSTEMD */
|
||||||
|
+ } else
|
||||||
|
#endif /* HAVE_LAUNCHD || HAVE_SYSTEMD */
|
||||||
|
if (fg)
|
||||||
|
cupsdAddEvent(CUPSD_EVENT_SERVER_STARTED, NULL, NULL, "Scheduler started in foreground.");
|
||||||
|
diff -up cups-2.0.2/scheduler/org.cups.cupsd.path.in.ustTJg cups-2.0.2/scheduler/org.cups.cupsd.path.in
|
||||||
|
--- cups-2.0.2/scheduler/org.cups.cupsd.path.in.ustTJg 2014-03-21 15:50:24.000000000 +0100
|
||||||
|
+++ cups-2.0.2/scheduler/org.cups.cupsd.path.in 2015-02-10 13:40:24.295545063 +0100
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
Description=CUPS Scheduler
|
||||||
|
|
||||||
|
[Path]
|
||||||
|
-PathExists=@CUPS_CACHEDIR@/org.cups.cupsd
|
||||||
|
+PathExistsGlob=@CUPS_REQUESTS@/d*
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
WantedBy=multi-user.target
|
||||||
|
diff -up cups-2.0.2/scheduler/org.cups.cupsd.service.in.ustTJg cups-2.0.2/scheduler/org.cups.cupsd.service.in
|
||||||
|
--- cups-2.0.2/scheduler/org.cups.cupsd.service.in.ustTJg 2014-10-21 13:55:01.000000000 +0200
|
||||||
|
+++ cups-2.0.2/scheduler/org.cups.cupsd.service.in 2015-02-10 13:40:24.296545049 +0100
|
||||||
|
@@ -1,10 +1,11 @@
|
||||||
|
[Unit]
|
||||||
|
Description=CUPS Scheduler
|
||||||
|
Documentation=man:cupsd(8)
|
||||||
|
+After=network.target
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
ExecStart=@sbindir@/cupsd -l
|
||||||
|
-Type=simple
|
||||||
|
+Type=notify
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
Also=org.cups.cupsd.socket org.cups.cupsd.path
|
Loading…
Reference in a new issue