mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
aur updates
This commit is contained in:
parent
021ffaae60
commit
efab620d52
12 changed files with 42 additions and 127 deletions
|
@ -1,8 +1,9 @@
|
|||
# Maintainer: dacoit <dacoit at tuta.io>
|
||||
# Maintainer: AXVill
|
||||
# Contributor: dacoit <dacoit at tuta.io>
|
||||
# Contributor: xjpvictor Huang <ke [AT] xjpvictor [DOT] info>
|
||||
# Contributor: uuwe
|
||||
pkgname=openswan
|
||||
pkgver=2.6.43.1
|
||||
pkgver=2.6.47
|
||||
pkgrel=1
|
||||
pkgdesc='Open Source implementation of IPsec for the Linux operating system'
|
||||
url='https://www.openswan.org'
|
||||
|
@ -12,6 +13,7 @@ depends=('gmp' 'perl' 'iproute2')
|
|||
makedepends=('flex' 'bison')
|
||||
optdepends=('python2')
|
||||
conflicts=('ipsec-tools')
|
||||
options=('!makeflags')
|
||||
backup=('etc/ipsec.conf'
|
||||
'etc/ipsec.d/policies/'{block,clear,clear-or-private,private,private-or-clear})
|
||||
source=("http://download.openswan.org/openswan/openswan-${pkgver}.tar.gz"
|
||||
|
@ -57,5 +59,6 @@ package() {
|
|||
# fix python2
|
||||
sed -i '1s|python|python2|' "$pkgdir/usr/lib/openswan/verify"
|
||||
}
|
||||
md5sums=('dafa77db8be28d7ae32c5ac2a45966eb'
|
||||
md5sums=('54aa71adb46e4f1b07f3db534540058a'
|
||||
'd8b465c10838c72e31329d65011002b6')
|
||||
|
||||
|
|
|
@ -2,19 +2,22 @@
|
|||
|
||||
pkgname=owfs
|
||||
pkgver=3.1p0
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim."
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.owfs.org/"
|
||||
license=('GPL')
|
||||
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
|
||||
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
|
||||
"systemd_journal.patch")
|
||||
depends=('avahi' 'fuse' 'perl')
|
||||
makedepends=('swig')
|
||||
sha1sums=('f82bf91e4f78a667c09a44d486139f1359f0950c')
|
||||
sha1sums=('f82bf91e4f78a667c09a44d486139f1359f0950c'
|
||||
'02aa7d70e6ed3e6dc309a89b512038362272d8ac')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
sed -i -e 's|<libusb.h>|<libusb-1.0/libusb.h>|' "module/owlib/src/include/ow.h"
|
||||
patch -p1 < ../systemd_journal.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
12
aur/owfs/systemd_journal.patch
Normal file
12
aur/owfs/systemd_journal.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Naur a/src/scripts/systemd/owfs.service.in b/src/scripts/systemd/owfs.service.in
|
||||
--- a/src/scripts/systemd/owfs.service.in 2015-01-11 01:31:33.000000000 +0000
|
||||
+++ b/src/scripts/systemd/owfs.service.in 2016-05-25 12:19:24.082429561 +0100
|
||||
@@ -3,7 +3,7 @@
|
||||
Documentation=man:owfs(1)
|
||||
|
||||
[Service]
|
||||
-ExecStart=@bindir@/owfs --server=127.0.0.1 --allow_other /run/owfs
|
||||
+ExecStart=@bindir@/owfs --error_print=2 --server=127.0.0.1 --allow_other /run/owfs
|
||||
ExecStop=/usr/bin/umount /run/owfs
|
||||
RuntimeDirectory=owfs
|
||||
|
|
@ -4,9 +4,9 @@
|
|||
|
||||
_pkgname=pithos
|
||||
pkgname=$_pkgname-git
|
||||
pkgver=1.1.1.r43.gb325db4
|
||||
pkgver=1.1.1.r80.g2edf730
|
||||
pkgrel=1
|
||||
pkgdesc='Pandora Internet Radio player for GNOME'
|
||||
pkgdesc='Native Pandora Radio client'
|
||||
arch=('any')
|
||||
url="https://pithos.github.io/"
|
||||
license=('GPL3')
|
||||
|
@ -22,11 +22,8 @@ optdepends=('libkeybinder3: for media keys plugin'
|
|||
makedepends=('git' 'automake' 'autoconf' 'intltool')
|
||||
provides=("$_pkgname")
|
||||
conflicts=("$_pkgname-bzr" "$_pkgname")
|
||||
install="$pkgname.install"
|
||||
sha256sums=('5b3bb0f5a3cfe676eb716f3728ba3ba606e6eaa205b7f2050ba8ab9e6ded98d5'
|
||||
'SKIP')
|
||||
|
||||
source=("$pkgname.install" "git+https://github.com/pithos/pithos.git")
|
||||
sha256sums=('SKIP')
|
||||
source=('git+https://github.com/pithos/pithos.git')
|
||||
|
||||
pkgver() {
|
||||
cd "$srcdir/$_pkgname"
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
post_install() {
|
||||
update-desktop-database -q
|
||||
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
|
||||
glib-compile-schemas usr/share/glib-2.0/schemas
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install $1
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
post_install $1
|
||||
}
|
|
@ -1,42 +0,0 @@
|
|||
# Maintainer: Xavier Devlamynck <magicrhesus@ouranos.be>
|
||||
# Contributor: Marti Raudsepp <marti@juffo.org>
|
||||
#Contributor: Travis Hegner <travis.hegner@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - set endianness for ARM
|
||||
|
||||
pkgname=pjproject
|
||||
pkgver=2.4.5
|
||||
pkgrel=1
|
||||
pkgdesc="Open source SIP stack and media stack"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.pjsip.org/"
|
||||
license=('GPL')
|
||||
depends=('openssl' 'portaudio' 'speex' 'alsa-lib' 'libsamplerate' 'util-linux-ng' 'ffmpeg' 'libsrtp')
|
||||
makedepends=('e2fsprogs' 'python')
|
||||
install=pjproject.install
|
||||
source=(http://www.pjsip.org/release/${pkgver}/pjproject-${pkgver}.tar.bz2
|
||||
ffmpeg.patch
|
||||
arm.patch)
|
||||
sha256sums=('086f5e70dcaee312b66ddc24dac6ef85e6f1fec4eed00ff2915cebe0ee3cdd8d'
|
||||
'7393f742cccbbcf1ed9d04dbc0bcb506970dd6e1c410f881a169d98fc376e95d'
|
||||
'ad3c26950003da0b2db2fa532e1340828e05cbd6e336f1f6d96850d90d297ffa')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
export CXXFLAGS="${CXXFLAGS} -fPIC"
|
||||
export CFLAGS="${CXXFLAGS}"
|
||||
#patch -p1 < ${srcdir}/ffmpeg.patch
|
||||
patch -p1 -i ../arm.patch
|
||||
#./configure --prefix=/usr --with-external-speex --with-external-pa --disable-oss --enable-shared --disable-opencore-amr
|
||||
./configure --prefix=/usr --with-external-speex --with-external-srtp --with-external-pa --with-external-gsm --disable-oss --enable-shared --disable-opencore-amr --disable-v4l2 --disable-video --disable-sound
|
||||
echo "#define PJ_HAS_IPV6 1" >> "${srcdir}/${pkgname}-${pkgver}/pjlib/include/pj/config_site.h"
|
||||
make -j1 dep
|
||||
make -j1
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
make -j1 DESTDIR=${pkgdir} install
|
||||
install -D -m755 pjsip-apps/bin/pjsua-*gnu* ${pkgdir}/usr/bin/pjsua
|
||||
}
|
|
@ -1,15 +0,0 @@
|
|||
diff -urN a/pjlib/include/pj/config.h b/pjlib/include/pj/config.h
|
||||
--- a/pjlib/include/pj/config.h 2014-03-14 00:58:10.000000000 -0600
|
||||
+++ b/pjlib/include/pj/config.h 2014-04-16 15:02:24.469462764 -0600
|
||||
@@ -244,9 +244,8 @@
|
||||
# define PJ_M_ARMV4 1
|
||||
# define PJ_M_NAME "armv4"
|
||||
# define PJ_HAS_PENTIUM 0
|
||||
-# if !PJ_IS_LITTLE_ENDIAN && !PJ_IS_BIG_ENDIAN
|
||||
-# error Endianness must be declared for this processor
|
||||
-# endif
|
||||
+# define PJ_IS_LITTLE_ENDIAN 1
|
||||
+# define PJ_IS_BIG_ENDIAN 0
|
||||
|
||||
#elif defined (PJ_M_POWERPC) || defined(__powerpc) || defined(__powerpc__) || \
|
||||
defined(__POWERPC__) || defined(__ppc__) || defined(_M_PPC) || \
|
|
@ -1,12 +0,0 @@
|
|||
diff -aur pjproject-2.2.orig/pjmedia/src/pjmedia/ffmpeg_util.h pjproject-2.2/pjmedia/src/pjmedia/ffmpeg_util.h
|
||||
--- pjproject-2.2.orig/pjmedia/src/pjmedia/ffmpeg_util.h 2011-07-19 05:42:28.000000000 +0200
|
||||
+++ pjproject-2.2/pjmedia/src/pjmedia/ffmpeg_util.h 2014-03-08 11:30:57.675023916 +0100
|
||||
@@ -22,6 +22,8 @@
|
||||
* that use ffmpeg. This is not a public API.
|
||||
*/
|
||||
|
||||
+#define CodecID AVCodecID
|
||||
+
|
||||
#ifndef __PJMEDIA_FFMPEG_UTIL_H__
|
||||
#define __PJMEDIA_FFMPEG_UTIL_H__
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
post_install() {
|
||||
cat << EOF
|
||||
==>
|
||||
==> To use py_pjsua (Python bindings for PJSUA),
|
||||
==> install 'alsa-lib', 'e2fsprogs', and 'python'
|
||||
==>
|
||||
EOF
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
|
||||
op=$1
|
||||
shift
|
||||
[ "$(type -t "$op")" = "function" ] && $op "$@"
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,7 +1,7 @@
|
|||
# Contributor: Johannes Dewender arch at JonnyJD dot net
|
||||
pkgname=('python-configshell-fb' 'python2-configshell-fb')
|
||||
_pkgname=configshell-fb
|
||||
pkgver=1.1.fb19
|
||||
pkgver=1.1.fb20
|
||||
pkgrel=1
|
||||
pkgdesc="python framework for building simple CLI applications (free branch)"
|
||||
arch=('any')
|
||||
|
@ -10,7 +10,7 @@ license=('Apache')
|
|||
options=()
|
||||
makedepends=('python-setuptools' 'python2-setuptools')
|
||||
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz)
|
||||
sha256sums=('7aabcd10c407909895634f2b217fba2ef22c5023292edf10353748068cbe315e')
|
||||
sha256sums=('4a9f4b59ccd256a1c4d4c270be43798853a91d9fec29bd0ba006b88b7476f383')
|
||||
|
||||
package_python-configshell-fb() {
|
||||
depends=('python-pyparsing' 'python-urwid')
|
||||
|
|
|
@ -1,18 +1,18 @@
|
|||
# Contributor: Johannes Dewender arch at JonnyJD dot net
|
||||
pkgname=('python-rtslib-fb' 'python2-rtslib-fb')
|
||||
_pkgname=rtslib-fb
|
||||
pkgver=2.1.fb59
|
||||
pkgrel=1
|
||||
pkgver=2.1.fb60
|
||||
pkgrel=2
|
||||
pkgdesc="free branch version of the LIO target API"
|
||||
arch=('any')
|
||||
url="https://github.com/agrover/rtslib-fb"
|
||||
license=('Apache')
|
||||
makedepends=('python-setuptools' 'python2-setuptools')
|
||||
makedepends=('python-setuptools' 'python2-setuptools' 'python-pyudev' 'python2-pyudev')
|
||||
backup=()
|
||||
options=()
|
||||
install=
|
||||
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz target.service)
|
||||
sha256sums=('a50338f397c868d04f44f489959c0286e83bdcfb02f025af4335686eabe792f0'
|
||||
sha256sums=('11b664f02219e5108c4a996f5bc7445500912cff5696b3f51be2f6a1b243e957'
|
||||
'74b9e5c11eab1781aa8b43680b429080ae800fbcdafd29626791b5426a4cdea8')
|
||||
|
||||
prepare() {
|
||||
|
@ -22,7 +22,7 @@ prepare() {
|
|||
|
||||
|
||||
package_python-rtslib-fb() {
|
||||
depends=('python' 'python-six')
|
||||
depends=('python' 'python-six' 'python-pyudev')
|
||||
conflicts=('python2-rtslib' 'targetcli-fb<=2.1.fb31')
|
||||
|
||||
cd "$srcdir/$_pkgname-$pkgver"
|
||||
|
@ -41,7 +41,7 @@ package_python-rtslib-fb() {
|
|||
}
|
||||
|
||||
package_python2-rtslib-fb() {
|
||||
depends=('python2' 'python2-six')
|
||||
depends=('python2' 'python2-six' 'python2-pyudev')
|
||||
conflicts=('python2-rtslib')
|
||||
|
||||
cd "$srcdir/$_pkgname-$pkgver"
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# Contributor: Johannes Dewender arch at JonnyJD dot net
|
||||
pkgname=targetcli-fb
|
||||
pkgver=2.1.fb42
|
||||
pkgrel=2
|
||||
pkgver=2.1.fb43
|
||||
pkgrel=1
|
||||
pkgdesc="free branch of the targetcli LIO administration shell (iSCSI + Co)"
|
||||
arch=('any')
|
||||
url="https://github.com/agrover/targetcli-fb"
|
||||
|
@ -17,7 +17,7 @@ backup=()
|
|||
options=()
|
||||
install=
|
||||
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$pkgname-$pkgver.tar.gz)
|
||||
sha256sums=('b4fbae4c41e333b5aadd029f00dc59b8522d88594bea1ad6901f24daf495ecdc')
|
||||
sha256sums=('63e7c85df26ffd2b1ef34e9113585d7eb8b3fd8d4bf84ebe025a14bf518e7459')
|
||||
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue