diff --git a/core/linux-mvebu/PKGBUILD b/core/linux-mvebu/PKGBUILD
index 7a3bca196..3f5827f02 100644
--- a/core/linux-mvebu/PKGBUILD
+++ b/core/linux-mvebu/PKGBUILD
@@ -9,7 +9,7 @@ _srcname=linux-3.12
 _kernelname=${pkgbase#linux}
 _desc="Marvell SOCs with Device Tree support"
 pkgver=3.12.6
-pkgrel=1
+pkgrel=2
 arch=('armv7h')
 url="http://www.kernel.org/"
 license=('GPL2')
@@ -26,8 +26,8 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
 md5sums=('cc6ee608854e0da4b64f6c1ff8b6398c'
          '9e75be8b127e58f1a76c0015eabb12ae'
          'SKIP'
-         'e9bf0da9952e9a835481054609badf3b'
-         '6179d15ca204bcb3aebdfd880390a84d'
+         '9b3e68a6e8ee929542457750ef634d15'
+         '8eb20ef02a6e25da0604848e3ed8f139'
          '911bffe9c261ca5b91dd0a083d99e81f'
          '3ad860d0d6daedc82091ea29c9730b95'
          '02cce6b8f88c4392f552b14d0bf2e71c')
diff --git a/core/linux-mvebu/config b/core/linux-mvebu/config
index 8bf79f6e6..0fe4b50fa 100644
--- a/core/linux-mvebu/config
+++ b/core/linux-mvebu/config
@@ -80,7 +80,10 @@ CONFIG_TICK_CPU_ACCOUNTING=y
 # CONFIG_IRQ_TIME_ACCOUNTING is not set
 CONFIG_BSD_PROCESS_ACCT=y
 CONFIG_BSD_PROCESS_ACCT_V3=y
-# CONFIG_TASKSTATS is not set
+CONFIG_TASKSTATS=y
+CONFIG_TASK_DELAY_ACCT=y
+CONFIG_TASK_XACCT=y
+CONFIG_TASK_IO_ACCOUNTING=y
 
 #
 # RCU Subsystem