extra/qt5-base to 5.13.0-6

This commit is contained in:
Kevin Mihelich 2019-07-01 02:00:37 +00:00
parent 2019e8a6ac
commit efe4d01740
2 changed files with 23 additions and 6 deletions

View file

@ -8,9 +8,9 @@
pkgbase=qt5-base
pkgname=(qt5-base qt5-xcb-private-headers)
_qtver=5.12.4
_qtver=5.13.0
pkgver=${_qtver/-/}
pkgrel=2
pkgrel=6
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@ -33,10 +33,12 @@ groups=('qt' 'qt5')
_pkgfqn="${pkgbase/5-/}-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
qtbase-qxcbwindow.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=0c183117"
qtbug-76440.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=6d61b10")
sha256sums=('20fbc7efa54ff7db9552a7a2cdf9047b80253c1933c834f35b0bc5c1ae021195'
qtbase-zlib-compression.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=cbdc9a77"
virtualbox-focus.patch)
sha256sums=('ff6964b3b528cd3b1d21bcf3470006e8e5cbe69591923f982871d886ea0488fe'
'51878fdf91d3f191fb4e19cd9ec3fc4c564bbf1eabe92802b40db2ec8ad1d646'
'0b0bfa3490098a3e195517b68d8b602f79be4170428f882e4a7583302d4be463')
'9300d8ab7abe4145e92eea75178a26ad3d5a71b0646665c3776ca2c375dd1233'
'2c6444203cc6f0b96d3ba2752d26a20da78e98ff728ba930129724ba6006c2e9')
prepare() {
cd ${_pkgfqn}
@ -49,7 +51,8 @@ prepare() {
mkspecs/common/g++-unix.conf
patch -p1 -i ../qtbase-qxcbwindow.patch # Fix NVIDIA freeze
patch -p1 -i ../qtbug-76440.patch # Fix crashes on multi-screen systems
patch -p1 -i ../qtbase-zlib-compression.patch # Change the default compression back to zlib for backwards compatibility
patch -p1 -i ../virtualbox-focus.patch # Fix virtualbox constantly stealing focus https://bugreports.qt.io/browse/QTBUG-76742
}
build() {
@ -72,6 +75,7 @@ build() {
-dbus-linked \
-system-harfbuzz \
-journald \
-no-mimetype-database \
-no-use-gold-linker \
-no-reduce-relocations \
-no-sse2 \

View file

@ -0,0 +1,13 @@
diff --git a/src/plugins/platforms/xcb/qxcbwindow.cpp b/src/plugins/platforms/xcb/qxcbwindow.cpp
index 9382488b74..1bf1ab268d 100644
--- a/src/plugins/platforms/xcb/qxcbwindow.cpp
+++ b/src/plugins/platforms/xcb/qxcbwindow.cpp
@@ -848,7 +848,7 @@ void QXcbWindow::doFocusOut()
connection()->setFocusWindow(nullptr);
relayFocusToModalWindow();
// Do not set the active window to nullptr if there is a FocusIn coming.
- connection()->focusInTimer().start(400);
+ connection()->focusInTimer().start(200);
}
struct QtMotifWmHints {