mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/vigra to 1.11.1-10
This commit is contained in:
parent
16f3d51a71
commit
efee33f544
2 changed files with 25 additions and 3 deletions
|
@ -9,7 +9,7 @@
|
|||
pkgbase=vigra
|
||||
pkgname=('vigra' 'vigra-doc')
|
||||
pkgver=1.11.1
|
||||
pkgrel=8
|
||||
pkgrel=10
|
||||
pkgdesc="Computer vision library"
|
||||
arch=('x86_64')
|
||||
url="https://ukoethe.github.io/vigra/"
|
||||
|
@ -20,15 +20,18 @@ makedepends=(# runtime deps
|
|||
'cmake' 'boost' 'python-numpy')
|
||||
checkdepends=('python-nose')
|
||||
source=("https://github.com/ukoethe/vigra/releases/download/Version-${pkgver//./-}/vigra-${pkgver}-src.tar.gz"
|
||||
'fix-incorrect-template-parameter-type.patch')
|
||||
'fix-incorrect-template-parameter-type.patch' 'py3.7.diff')
|
||||
sha256sums=('a5564e1083f6af6a885431c1ee718bad77d11f117198b277557f8558fa461aaf'
|
||||
'f151f902483dfa2b1f3d431f54bb161300cf184158c9f416fa653d19ab363cc4')
|
||||
'f151f902483dfa2b1f3d431f54bb161300cf184158c9f416fa653d19ab363cc4'
|
||||
'8fcdcce50c377be44387cbd4a001dadf5e03b32483de55c05a359c887e95a05b')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
cd ${pkgbase}-${pkgver}
|
||||
# https://github.com/ukoethe/vigra/issues/414
|
||||
patch -Np1 -i ../fix-incorrect-template-parameter-type.patch
|
||||
# python 3.7 compat
|
||||
patch -Np1 -i ../py3.7.diff
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
19
community/vigra/py3.7.diff
Normal file
19
community/vigra/py3.7.diff
Normal file
|
@ -0,0 +1,19 @@
|
|||
diff -u -r vigra-1.11.1/vigranumpy/src/core/vigranumpycore.cxx vigra-1.11.1-py3.7/vigranumpy/src/core/vigranumpycore.cxx
|
||||
--- vigra-1.11.1/vigranumpy/src/core/vigranumpycore.cxx 2017-05-19 17:01:08.000000000 +0200
|
||||
+++ vigra-1.11.1-py3.7/vigranumpy/src/core/vigranumpycore.cxx 2018-07-29 18:29:46.514547076 +0200
|
||||
@@ -59,10 +59,14 @@
|
||||
Py_ssize_t size = PyUnicode_GET_DATA_SIZE(s.ptr());
|
||||
const char * data = PyUnicode_AS_DATA(s.ptr());
|
||||
return checksum(data, size);
|
||||
-#else
|
||||
+#elif (PY_MAJOR_VERSION == 3) && (PY_MINOR_VERSION < 7)
|
||||
Py_ssize_t size = 0;
|
||||
char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
|
||||
return checksum(data, size);
|
||||
+#else
|
||||
+ Py_ssize_t size = 0;
|
||||
+ const char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
|
||||
+ return checksum(data, size);
|
||||
#endif
|
||||
}
|
||||
|
Loading…
Reference in a new issue