mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
parent
fb3e91a7a6
commit
f0059dacb3
6 changed files with 363 additions and 14 deletions
|
@ -1,7 +1,7 @@
|
|||
From 831eeefaebc489ecb64f945cfa62f79771be3bf5 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 4 Jul 2017 11:54:39 -0600
|
||||
Subject: [PATCH 1/4] ARM toolchain fixes
|
||||
Subject: [PATCH 1/5] ARM toolchain fixes
|
||||
|
||||
---
|
||||
chromium/build/toolchain/linux/BUILD.gn | 24 ++++++++++--------------
|
||||
|
@ -54,5 +54,5 @@ index fa8b17e9db3..7398b7556ec 100644
|
|||
toolchain_args = {
|
||||
current_cpu = "arm"
|
||||
--
|
||||
2.33.0
|
||||
2.37.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 895dec8c2d626f176cb85af81c09c7bf30e2ad43 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 1 Jul 2019 07:10:36 -0600
|
||||
Subject: [PATCH 2/4] Fix ARM skia ICE
|
||||
Subject: [PATCH 2/5] Fix ARM skia ICE
|
||||
|
||||
---
|
||||
chromium/third_party/skia/third_party/skcms/src/Transform_inl.h | 2 +-
|
||||
|
@ -21,5 +21,5 @@ index 2dcf717f3b7..8e1acb01fee 100644
|
|||
#else
|
||||
#define MAYBE_NOINLINE
|
||||
--
|
||||
2.33.0
|
||||
2.37.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From a3a795afdd386242fa115309c5fd349b0095bfdd Mon Sep 17 00:00:00 2001
|
||||
From: Yuki Shiino <yukishiino@chromium.org>
|
||||
Date: Mon, 5 Oct 2020 11:01:57 +0000
|
||||
Subject: [PATCH 3/4] bind-gen: Support --single_process flag in
|
||||
Subject: [PATCH 3/5] bind-gen: Support --single_process flag in
|
||||
generate_bindings.py
|
||||
|
||||
Error messages of generate_bindings.py are often hard to read
|
||||
|
@ -153,5 +153,5 @@ index 96a9ebccdbf..528d1b2f61d 100644
|
|||
for task in tasks:
|
||||
dispatch_table[task](task_queue)
|
||||
--
|
||||
2.33.0
|
||||
2.37.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 67b6ede8c7b82dfddc53b945945a5d4c9e2ad9c3 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 2 Feb 2021 13:58:59 -0700
|
||||
Subject: [PATCH 4/4] Run blink bindings generation single threaded
|
||||
Subject: [PATCH 4/5] Run blink bindings generation single threaded
|
||||
|
||||
When not single threaded this process will eat all the RAM.
|
||||
---
|
||||
|
@ -21,5 +21,5 @@ index 6a457ced15a..09f1250d173 100644
|
|||
rebase_path(web_idl_database, root_build_dir),
|
||||
"--root_src_dir",
|
||||
--
|
||||
2.33.0
|
||||
2.37.0
|
||||
|
||||
|
|
|
@ -0,0 +1,345 @@
|
|||
From 0908105c5a7fb5d3f0b644b37811f82934cccf60 Mon Sep 17 00:00:00 2001
|
||||
From: Yichao Yu <yyc1992@gmail.com>
|
||||
Date: Tue, 19 Jul 2022 23:58:46 -0400
|
||||
Subject: [PATCH 5/5] Backport of 16k page support on aarch64
|
||||
|
||||
---
|
||||
.../address_space_randomization.h | 15 ++++++
|
||||
.../page_allocator_constants.h | 51 +++++++++++++++++-
|
||||
.../partition_address_space.cc | 6 +++
|
||||
.../partition_allocator/partition_alloc.cc | 2 +-
|
||||
.../partition_alloc_constants.h | 5 +-
|
||||
.../address_space_randomization.h | 15 ++++++
|
||||
.../partition_allocator/page_allocator.cc | 8 +++
|
||||
.../page_allocator_constants.h | 52 ++++++++++++++++++-
|
||||
.../partition_allocator/partition_alloc.cc | 2 +-
|
||||
.../partition_alloc_constants.h | 5 +-
|
||||
10 files changed, 153 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/chromium/base/allocator/partition_allocator/address_space_randomization.h b/chromium/base/allocator/partition_allocator/address_space_randomization.h
|
||||
index e77003eab25..31ac05b86f5 100644
|
||||
--- a/chromium/base/allocator/partition_allocator/address_space_randomization.h
|
||||
+++ b/chromium/base/allocator/partition_allocator/address_space_randomization.h
|
||||
@@ -119,6 +119,21 @@ AslrMask(uintptr_t bits) {
|
||||
return AslrAddress(0x20000000ULL);
|
||||
}
|
||||
|
||||
+ #elif defined(OS_LINUX)
|
||||
+
|
||||
+ // Linux on arm64 can use 39, 42, 48, or 52-bit user space, depending on
|
||||
+ // page size and number of levels of translation pages used. We use
|
||||
+ // 39-bit as base as all setups should support this, lowered to 38-bit
|
||||
+ // as ASLROffset() could cause a carry.
|
||||
+ PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE uintptr_t
|
||||
+ ASLRMask() {
|
||||
+ return AslrMask(38);
|
||||
+ }
|
||||
+ PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE uintptr_t
|
||||
+ ASLROffset() {
|
||||
+ return AslrAddress(0x1000000000ULL);
|
||||
+ }
|
||||
+
|
||||
#else
|
||||
|
||||
// ARM64 on Linux has 39-bit user space. Use 38 bits since ASLROffset()
|
||||
diff --git a/chromium/base/allocator/partition_allocator/page_allocator_constants.h b/chromium/base/allocator/partition_allocator/page_allocator_constants.h
|
||||
index c42fe2835ff..dc7486608b9 100644
|
||||
--- a/chromium/base/allocator/partition_allocator/page_allocator_constants.h
|
||||
+++ b/chromium/base/allocator/partition_allocator/page_allocator_constants.h
|
||||
@@ -24,6 +24,31 @@
|
||||
// elimination.
|
||||
#define PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR __attribute__((const))
|
||||
|
||||
+#elif defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+// This should work for all POSIX (if needed), but currently all other
|
||||
+// supported OS/architecture combinations use either hard-coded values
|
||||
+// (such as x86) or have means to determine these values without needing
|
||||
+// atomics (such as macOS on arm64).
|
||||
+
|
||||
+// Page allocator constants are run-time constant
|
||||
+#define PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR __attribute__((const))
|
||||
+
|
||||
+#include <unistd.h>
|
||||
+#include <atomic>
|
||||
+
|
||||
+namespace base::internal {
|
||||
+
|
||||
+// Holds the current page size and shift, where size = 1 << shift
|
||||
+// Use PageAllocationGranularity(), PageAllocationGranularityShift()
|
||||
+// to initialize and retrieve these values safely.
|
||||
+struct PageCharacteristics {
|
||||
+ std::atomic<int> size;
|
||||
+ std::atomic<int> shift;
|
||||
+};
|
||||
+extern PageCharacteristics page_characteristics;
|
||||
+
|
||||
+} // namespace base::internal
|
||||
+
|
||||
#else
|
||||
|
||||
// When defined, page size constants are fixed at compile time. When not
|
||||
@@ -36,11 +61,17 @@
|
||||
|
||||
#endif
|
||||
|
||||
+namespace base {
|
||||
+// Forward declaration, implementation below
|
||||
+PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE size_t
|
||||
+PageAllocationGranularity();
|
||||
+}
|
||||
+
|
||||
namespace {
|
||||
|
||||
#if !defined(OS_APPLE)
|
||||
|
||||
-constexpr ALWAYS_INLINE int PageAllocationGranularityShift() {
|
||||
+PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE int PageAllocationGranularityShift() {
|
||||
#if defined(OS_WIN) || defined(ARCH_CPU_PPC64)
|
||||
// Modern ppc64 systems support 4kB (shift = 12) and 64kB (shift = 16) page
|
||||
// sizes. Since 64kB is the de facto standard on the platform and binaries
|
||||
@@ -49,6 +80,15 @@ constexpr ALWAYS_INLINE int PageAllocationGranularityShift() {
|
||||
return 16; // 64kB
|
||||
#elif defined(_MIPS_ARCH_LOONGSON)
|
||||
return 14; // 16kB
|
||||
+#elif defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+ // arm64 supports 4kb (shift = 12), 16kb (shift = 14), and 64kb (shift = 16)
|
||||
+ // page sizes. Retrieve from or initialize cache.
|
||||
+ int shift = base::internal::page_characteristics.shift.load(std::memory_order_relaxed);
|
||||
+ if (UNLIKELY(shift == 0)) {
|
||||
+ shift = __builtin_ctz((int)base::PageAllocationGranularity());
|
||||
+ base::internal::page_characteristics.shift.store(shift, std::memory_order_relaxed);
|
||||
+ }
|
||||
+ return shift;
|
||||
#else
|
||||
return 12; // 4kB
|
||||
#endif
|
||||
@@ -64,6 +104,15 @@ PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE size_t
|
||||
PageAllocationGranularity() {
|
||||
#if defined(OS_APPLE)
|
||||
return vm_page_size;
|
||||
+#elif defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+ // arm64 supports 4kb, 16kb, and 64kb page sizes. Retrieve from or
|
||||
+ // initialize cache.
|
||||
+ int size = internal::page_characteristics.size.load(std::memory_order_relaxed);
|
||||
+ if (UNLIKELY(size == 0)) {
|
||||
+ size = getpagesize();
|
||||
+ internal::page_characteristics.size.store(size, std::memory_order_relaxed);
|
||||
+ }
|
||||
+ return size;
|
||||
#else
|
||||
return 1ULL << PageAllocationGranularityShift();
|
||||
#endif
|
||||
diff --git a/chromium/base/allocator/partition_allocator/partition_address_space.cc b/chromium/base/allocator/partition_allocator/partition_address_space.cc
|
||||
index 03883bcb113..90efc51c838 100644
|
||||
--- a/chromium/base/allocator/partition_allocator/partition_address_space.cc
|
||||
+++ b/chromium/base/allocator/partition_allocator/partition_address_space.cc
|
||||
@@ -75,6 +75,12 @@ void PartitionAddressSpace::UninitForTesting() {
|
||||
internal::AddressPoolManager::GetInstance()->ResetForTesting();
|
||||
}
|
||||
|
||||
+#if defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+
|
||||
+PageCharacteristics page_characteristics;
|
||||
+
|
||||
+#endif // defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+
|
||||
#endif // defined(PA_HAS_64_BITS_POINTERS)
|
||||
|
||||
} // namespace internal
|
||||
diff --git a/chromium/base/allocator/partition_allocator/partition_alloc.cc b/chromium/base/allocator/partition_allocator/partition_alloc.cc
|
||||
index daeb6d5cb17..7c434b5e697 100644
|
||||
--- a/chromium/base/allocator/partition_allocator/partition_alloc.cc
|
||||
+++ b/chromium/base/allocator/partition_allocator/partition_alloc.cc
|
||||
@@ -522,7 +522,7 @@ static size_t PartitionPurgePage(internal::PartitionPage<thread_safe>* page,
|
||||
#if defined(PAGE_ALLOCATOR_CONSTANTS_ARE_CONSTEXPR)
|
||||
constexpr size_t kMaxSlotCount =
|
||||
(PartitionPageSize() * kMaxPartitionPagesPerSlotSpan) / SystemPageSize();
|
||||
-#elif defined(OS_APPLE)
|
||||
+#elif defined(OS_APPLE) || (defined(OS_LINUX) && defined(ARCH_CPU_ARM64))
|
||||
// It's better for slot_usage to be stack-allocated and fixed-size, which
|
||||
// demands that its size be constexpr. On OS_APPLE, PartitionPageSize() is
|
||||
// always SystemPageSize() << 2, so regardless of what the run time page size
|
||||
diff --git a/chromium/base/allocator/partition_allocator/partition_alloc_constants.h b/chromium/base/allocator/partition_allocator/partition_alloc_constants.h
|
||||
index c8268ec30a0..f03ba1e4ab4 100644
|
||||
--- a/chromium/base/allocator/partition_allocator/partition_alloc_constants.h
|
||||
+++ b/chromium/base/allocator/partition_allocator/partition_alloc_constants.h
|
||||
@@ -57,10 +57,11 @@ PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE int
|
||||
PartitionPageShift() {
|
||||
return 18; // 256 KiB
|
||||
}
|
||||
-#elif defined(OS_APPLE)
|
||||
+#elif defined(OS_APPLE) || \
|
||||
+ (defined(OS_LINUX) && defined(ARCH_CPU_ARM64))
|
||||
PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE int
|
||||
PartitionPageShift() {
|
||||
- return vm_page_shift + 2;
|
||||
+ return PageAllocationGranularityShift() + 2;
|
||||
}
|
||||
#else
|
||||
PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE int
|
||||
diff --git a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/address_space_randomization.h b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/address_space_randomization.h
|
||||
index 28c8271fd68..3957e0cdf76 100644
|
||||
--- a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/address_space_randomization.h
|
||||
+++ b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/address_space_randomization.h
|
||||
@@ -120,6 +120,21 @@ AslrMask(uintptr_t bits) {
|
||||
return AslrAddress(0x20000000ULL);
|
||||
}
|
||||
|
||||
+ #elif defined(OS_LINUX)
|
||||
+
|
||||
+ // Linux on arm64 can use 39, 42, 48, or 52-bit user space, depending on
|
||||
+ // page size and number of levels of translation pages used. We use
|
||||
+ // 39-bit as base as all setups should support this, lowered to 38-bit
|
||||
+ // as ASLROffset() could cause a carry.
|
||||
+ PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE uintptr_t
|
||||
+ ASLRMask() {
|
||||
+ return AslrMask(38);
|
||||
+ }
|
||||
+ PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE uintptr_t
|
||||
+ ASLROffset() {
|
||||
+ return AslrAddress(0x1000000000ULL);
|
||||
+ }
|
||||
+
|
||||
#else
|
||||
|
||||
// ARM64 on Linux has 39-bit user space. Use 38 bits since kASLROffset
|
||||
diff --git a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/page_allocator.cc b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/page_allocator.cc
|
||||
index 91d00d2fbca..597d5f84cb1 100644
|
||||
--- a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/page_allocator.cc
|
||||
+++ b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/page_allocator.cc
|
||||
@@ -255,5 +255,13 @@ uint32_t GetAllocPageErrorCode() {
|
||||
return s_allocPageErrorCode;
|
||||
}
|
||||
|
||||
+#if defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+
|
||||
+namespace internal {
|
||||
+PageCharacteristics page_characteristics;
|
||||
+}
|
||||
+
|
||||
+#endif // defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+
|
||||
} // namespace base
|
||||
} // namespace pdfium
|
||||
diff --git a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/page_allocator_constants.h b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/page_allocator_constants.h
|
||||
index fdc65ac47b7..f826308839d 100644
|
||||
--- a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/page_allocator_constants.h
|
||||
+++ b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/page_allocator_constants.h
|
||||
@@ -24,6 +24,31 @@
|
||||
// elimination.
|
||||
#define PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR __attribute__((const))
|
||||
|
||||
+#elif defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+// This should work for all POSIX (if needed), but currently all other
|
||||
+// supported OS/architecture combinations use either hard-coded values
|
||||
+// (such as x86) or have means to determine these values without needing
|
||||
+// atomics (such as macOS on arm64).
|
||||
+
|
||||
+// Page allocator constants are run-time constant
|
||||
+#define PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR __attribute__((const))
|
||||
+
|
||||
+#include <unistd.h>
|
||||
+#include <atomic>
|
||||
+
|
||||
+namespace pdfium::base::internal {
|
||||
+
|
||||
+// Holds the current page size and shift, where size = 1 << shift
|
||||
+// Use PageAllocationGranularity(), PageAllocationGranularityShift()
|
||||
+// to initialize and retrieve these values safely.
|
||||
+struct PageCharacteristics {
|
||||
+ std::atomic<int> size;
|
||||
+ std::atomic<int> shift;
|
||||
+};
|
||||
+extern PageCharacteristics page_characteristics;
|
||||
+
|
||||
+} // namespace base::internal
|
||||
+
|
||||
#else
|
||||
|
||||
// When defined, page size constants are fixed at compile time. When not
|
||||
@@ -37,11 +62,18 @@
|
||||
#endif
|
||||
|
||||
namespace pdfium {
|
||||
+
|
||||
+namespace base {
|
||||
+// Forward declaration, implementation below
|
||||
+PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE size_t
|
||||
+PageAllocationGranularity();
|
||||
+}
|
||||
+
|
||||
namespace {
|
||||
|
||||
#if !defined(OS_APPLE)
|
||||
|
||||
-constexpr ALWAYS_INLINE int PageAllocationGranularityShift() {
|
||||
+PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE int PageAllocationGranularityShift() {
|
||||
#if defined(OS_WIN) || defined(ARCH_CPU_PPC64)
|
||||
// Modern ppc64 systems support 4kB (shift = 12) and 64kB (shift = 16) page
|
||||
// sizes. Since 64kB is the de facto standard on the platform and binaries
|
||||
@@ -50,6 +82,15 @@ constexpr ALWAYS_INLINE int PageAllocationGranularityShift() {
|
||||
return 16; // 64kB
|
||||
#elif defined(_MIPS_ARCH_LOONGSON)
|
||||
return 14; // 16kB
|
||||
+#elif defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+ // arm64 supports 4kb (shift = 12), 16kb (shift = 14), and 64kb (shift = 16)
|
||||
+ // page sizes. Retrieve from or initialize cache.
|
||||
+ int shift = base::internal::page_characteristics.shift.load(std::memory_order_relaxed);
|
||||
+ if (UNLIKELY(shift == 0)) {
|
||||
+ shift = __builtin_ctz((int)base::PageAllocationGranularity());
|
||||
+ base::internal::page_characteristics.shift.store(shift, std::memory_order_relaxed);
|
||||
+ }
|
||||
+ return shift;
|
||||
#else
|
||||
return 12; // 4kB
|
||||
#endif
|
||||
@@ -65,6 +106,15 @@ PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE size_t
|
||||
PageAllocationGranularity() {
|
||||
#if defined(OS_APPLE)
|
||||
return vm_page_size;
|
||||
+#elif defined(OS_LINUX) && defined(ARCH_CPU_ARM64)
|
||||
+ // arm64 supports 4kb, 16kb, and 64kb page sizes. Retrieve from or
|
||||
+ // initialize cache.
|
||||
+ int size = internal::page_characteristics.size.load(std::memory_order_relaxed);
|
||||
+ if (UNLIKELY(size == 0)) {
|
||||
+ size = getpagesize();
|
||||
+ internal::page_characteristics.size.store(size, std::memory_order_relaxed);
|
||||
+ }
|
||||
+ return size;
|
||||
#else
|
||||
return 1ULL << PageAllocationGranularityShift();
|
||||
#endif
|
||||
diff --git a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/partition_alloc.cc b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/partition_alloc.cc
|
||||
index 2e5e87fa7e6..89b9f6217a6 100644
|
||||
--- a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/partition_alloc.cc
|
||||
+++ b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/partition_alloc.cc
|
||||
@@ -486,7 +486,7 @@ static size_t PartitionPurgePage(internal::PartitionPage* page, bool discard) {
|
||||
#if defined(PAGE_ALLOCATOR_CONSTANTS_ARE_CONSTEXPR)
|
||||
constexpr size_t kMaxSlotCount =
|
||||
(PartitionPageSize() * kMaxPartitionPagesPerSlotSpan) / SystemPageSize();
|
||||
-#elif defined(OS_APPLE)
|
||||
+#elif defined(OS_APPLE) || (defined(OS_LINUX) && defined(ARCH_CPU_ARM64))
|
||||
// It's better for slot_usage to be stack-allocated and fixed-size, which
|
||||
// demands that its size be constexpr. On OS_APPLE, PartitionPageSize() is
|
||||
// always SystemPageSize() << 2, so regardless of what the run time page size
|
||||
diff --git a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/partition_alloc_constants.h b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/partition_alloc_constants.h
|
||||
index 71d63ba4146..a6d83626741 100644
|
||||
--- a/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/partition_alloc_constants.h
|
||||
+++ b/chromium/third_party/pdfium/third_party/base/allocator/partition_allocator/partition_alloc_constants.h
|
||||
@@ -50,10 +50,11 @@ PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE int
|
||||
PartitionPageShift() {
|
||||
return 18; // 256 KiB
|
||||
}
|
||||
-#elif defined(OS_APPLE)
|
||||
+#elif defined(OS_APPLE) || \
|
||||
+ (defined(OS_LINUX) && defined(ARCH_CPU_ARM64))
|
||||
PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE int
|
||||
PartitionPageShift() {
|
||||
- return vm_page_shift + 2;
|
||||
+ return PageAllocationGranularityShift() + 2;
|
||||
}
|
||||
#else
|
||||
PAGE_ALLOCATOR_CONSTANTS_DECLARE_CONSTEXPR ALWAYS_INLINE int
|
||||
--
|
||||
2.37.0
|
||||
|
|
@ -5,6 +5,7 @@
|
|||
# - patch for chromium GN
|
||||
# - patch for chromium skia
|
||||
# - patch for chromium to run blink bindings generation single threaded
|
||||
# - patch for chromium to backport 16k page support
|
||||
# - build v7 with -j4
|
||||
|
||||
highmem=1
|
||||
|
@ -12,7 +13,7 @@ highmem=1
|
|||
pkgname=qt5-webengine
|
||||
_basever=5.15.5
|
||||
pkgver=5.15.10
|
||||
pkgrel=2
|
||||
pkgrel=2.1
|
||||
arch=('x86_64')
|
||||
url='https://www.qt.io'
|
||||
license=('LGPL3' 'LGPL2.1' 'BSD')
|
||||
|
@ -34,7 +35,8 @@ source=(git+https://code.qt.io/qt/qtwebengine.git#tag=v${pkgver}-lts
|
|||
0001-ARM-toolchain-fixes.patch
|
||||
0002-Fix-ARM-skia-ICE.patch
|
||||
0003-bind-gen-Support-single_process-flag-in-generate_bin.patch
|
||||
0004-Run-blink-bindings-generation-single-threaded.patch)
|
||||
0004-Run-blink-bindings-generation-single-threaded.patch
|
||||
0005-Backport-of-16k-page-support-on-aarch64.patch)
|
||||
sha256sums=('SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
|
@ -43,10 +45,11 @@ sha256sums=('SKIP'
|
|||
'c50d3019626183e753c53a997dc8a55938847543aa3178d4c51f377be741c693'
|
||||
'5e3a3c4711d964d5152a04059a2b5c1d14bb13dd29bce370120f60e85b476b6f'
|
||||
'cf9be3ffcc3b3cd9450b1ff13535ff7d76284f73173412d097a6ab487463a379'
|
||||
'81b7a62368f40d757b165b88df4813413f30db797e4f93a84dd75e12e1ebd679'
|
||||
'298037fcbc132f1539616cdf6149ad5da104f8e2345a9c1af1e7bf8b0dd52c70'
|
||||
'b878770648437c9bc24023b1d5a47bcd51382d7142b695864c3379826511bcd9'
|
||||
'e447f5d2635f8f32914c912d7f99b38726c1541334f3a2c1a8ca2dbde565a7de')
|
||||
'888dcb27b6cc9ac6e926a59707cc298a0d4ff24b5461a14d8c5dd4ab70e8b759'
|
||||
'4d09377b181a1bd9d84c0e45e8edae7b43c5af92b9375ef8cdbb1be06ec75436'
|
||||
'a2dda475d7064e627f4b60bde3539a25f9b520881628b62192bfa8d705dd965e'
|
||||
'1ee30297739637763e1e36ac65a9b504e161ef2c2cd9ac8bc01d071ff3b284bf'
|
||||
'fcf7ff60b2a78dc1ae1e93f8d15744b6d90e64eeebc5979385b92b85e4e3f079')
|
||||
options=(debug)
|
||||
|
||||
prepare() {
|
||||
|
@ -75,6 +78,7 @@ prepare() {
|
|||
patch -p1 -i ${srcdir}/0002-Fix-ARM-skia-ICE.patch
|
||||
patch -p1 -i ${srcdir}/0003-bind-gen-Support-single_process-flag-in-generate_bin.patch
|
||||
patch -p1 -i ${srcdir}/0004-Run-blink-bindings-generation-single-threaded.patch
|
||||
patch -p1 -i ${srcdir}/0005-Backport-of-16k-page-support-on-aarch64.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue