mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/busybox to 1.24.2-2
This commit is contained in:
parent
e4c3961404
commit
f0193a4a37
2 changed files with 7 additions and 40 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgname=busybox
|
||||
pkgver=1.24.2
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="Utilities for rescue and embedded systems"
|
||||
arch=("i686" "x86_64")
|
||||
url="http://www.busybox.net"
|
||||
|
@ -15,16 +15,9 @@ license=('GPL')
|
|||
makedepends=("make" "gcc" "sed" "ncurses")
|
||||
install=busybox.install
|
||||
source=("$url/downloads/$pkgname-$pkgver.tar.bz2"
|
||||
"config"
|
||||
ifplugd.patch)
|
||||
"config")
|
||||
md5sums=('2eaae519cac1143bcf583636a745381f'
|
||||
'86035b9208a5358b885fbf6b87a0735d'
|
||||
'187adc8319e45be12d79e8db2c514d74')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
# patch -p1 <$srcdir/ifplugd.patch
|
||||
}
|
||||
'86035b9208a5358b885fbf6b87a0735d')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
@ -38,4 +31,8 @@ build() {
|
|||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
install -Dm755 busybox $pkgdir/usr/bin/busybox
|
||||
install -Dm644 docs/busybox.1 $pkgdir/usr/share/man/man1/busybox.1
|
||||
for doc in BusyBox.html BusyBox.txt; do
|
||||
install -Dm644 docs/$doc $pkgdir/usr/share/doc/$pkgname/$doc
|
||||
done
|
||||
}
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
networking/ifplugd.c | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/networking/ifplugd.c b/networking/ifplugd.c
|
||||
index b578f4c..8fad69a 100644
|
||||
--- a/networking/ifplugd.c
|
||||
+++ b/networking/ifplugd.c
|
||||
@@ -34,16 +34,17 @@
|
||||
#include "libbb.h"
|
||||
|
||||
#include "fix_u32.h"
|
||||
-#include <linux/if.h>
|
||||
-#include <linux/mii.h>
|
||||
-#include <linux/ethtool.h>
|
||||
#ifdef HAVE_NET_ETHERNET_H
|
||||
# include <net/ethernet.h>
|
||||
#endif
|
||||
+#include <syslog.h>
|
||||
+
|
||||
+#include <linux/if.h>
|
||||
+#include <linux/mii.h>
|
||||
+#include <linux/ethtool.h>
|
||||
#include <linux/netlink.h>
|
||||
#include <linux/rtnetlink.h>
|
||||
#include <linux/sockios.h>
|
||||
-#include <syslog.h>
|
||||
|
||||
#define __user
|
||||
#include <linux/wireless.h>
|
||||
|
Loading…
Reference in a new issue