mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/hplip: add patches
This commit is contained in:
parent
47ef3663b0
commit
f0276fa75c
2 changed files with 34 additions and 0 deletions
23
extra/hplip/fix_install.patch
Normal file
23
extra/hplip/fix_install.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- hplip-3.18.7/Makefile.am 2018-07-15 22:08:37.000000000 +0200
|
||||
+++ hplip-3.18.7/Makefile.am.new 2018-08-08 19:54:20.671794852 +0200
|
||||
@@ -680,14 +680,14 @@
|
||||
install-data-hook:
|
||||
if HPLIP_BUILD
|
||||
if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/" \) ]; then \
|
||||
- cp prnt/hpcups/libImageProcessor-x86_64.so $(libdir)/ ; \
|
||||
- chmod 775 $(libdir)/libImageProcessor-x86_64.so ; \
|
||||
- ln -sf $(libdir)/libImageProcessor-x86_64.so $(libdir)/libImageProcessor.so ; \
|
||||
+ cp prnt/hpcups/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/ ; \
|
||||
+ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_64.so ; \
|
||||
+ ln -sf $(libdir)/libImageProcessor-x86_64.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
|
||||
fi; \
|
||||
if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/" \) ]; then \
|
||||
- cp prnt/hpcups/libImageProcessor-x86_32.so $(libdir)/ ; \
|
||||
- chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
|
||||
- ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
|
||||
+ cp prnt/hpcups/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/ ; \
|
||||
+ chmod 775 $(DESTDIR)$(libdir)/libImageProcessor-x86_32.so ; \
|
||||
+ ln -sf $(libdir)/libImageProcessor-x86_32.so $(DESTDIR)$(libdir)/libImageProcessor.so ; \
|
||||
fi
|
||||
if !HPLIP_CLASS_DRIVER
|
||||
# If scanner build, add hpaio entry to sane dll.conf.
|
11
extra/hplip/python.patch
Normal file
11
extra/hplip/python.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- hplip-3.18.7/base/utils.py 2018-07-15 22:08:37.000000000 +0200
|
||||
+++ hplip-3.18.7/base/utils.py.new 2018-08-08 21:46:48.721947940 +0200
|
||||
@@ -265,7 +265,7 @@
|
||||
try:
|
||||
names = os.listdir(root)
|
||||
except os.error:
|
||||
- raise StopIteration
|
||||
+ return
|
||||
|
||||
pattern = pattern or '*'
|
||||
pat_list = pattern.split(';')
|
Loading…
Reference in a new issue