mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/cmus
This commit is contained in:
parent
424032287e
commit
f041936274
2 changed files with 97 additions and 0 deletions
24
community/cmus/13-atomic_ld.patch
Normal file
24
community/cmus/13-atomic_ld.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
Description: Pass LDLIBS to the linker
|
||||
Needed to pass -latomic at the end so that we can fix a FTBFS on various
|
||||
architectures.
|
||||
Author: Ryan Kavanagh <rak@debian.org>
|
||||
Origin: Debian
|
||||
Bug-Debian: http://bugs.debian.org/935678
|
||||
Forwarded: no
|
||||
Reviewed-by: Ryan Kavanagh <rak@debian.org>
|
||||
Last-Update: 2019-09-07
|
||||
---
|
||||
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
||||
Index: cmus/Makefile
|
||||
===================================================================
|
||||
--- cmus.orig/Makefile 2019-09-07 10:02:00.152453147 -0400
|
||||
+++ cmus/Makefile 2019-09-07 10:24:55.009937454 -0400
|
||||
@@ -22,7 +22,7 @@
|
||||
FFMPEG_LIBS += $(shell pkg-config --libs libswresample)
|
||||
|
||||
CMUS_LIBS = $(PTHREAD_LIBS) $(NCURSES_LIBS) $(ICONV_LIBS) $(DL_LIBS) $(DISCID_LIBS) \
|
||||
- -lm $(COMPAT_LIBS) $(LIBSYSTEMD_LIBS)
|
||||
+ -lm $(COMPAT_LIBS) $(LIBSYSTEMD_LIBS) $(LDLIBS)
|
||||
|
||||
command_mode.o input.o main.o ui_curses.o op/pulse.lo: .version
|
||||
command_mode.o input.o main.o ui_curses.o op/pulse.lo: CFLAGS += -DVERSION=\"$(VERSION)\"
|
73
community/cmus/PKGBUILD
Normal file
73
community/cmus/PKGBUILD
Normal file
|
@ -0,0 +1,73 @@
|
|||
# Maintainer: Xyne <ca dot archlinux at xyne, backwards>
|
||||
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
|
||||
# Contributor: Aaron Griffin <aaron@archlinux.org>
|
||||
# Contributor: dorphell <dorphell@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch from debian, export LDLIBS to explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgname=cmus
|
||||
pkgver=2.8.0
|
||||
pkgrel=5
|
||||
pkgdesc='Feature-rich ncurses-based music player'
|
||||
arch=('x86_64')
|
||||
url="https://cmus.github.io/"
|
||||
license=('GPL')
|
||||
depends=('ncurses' 'libdiscid')
|
||||
makedepends=(
|
||||
'faad2'
|
||||
'ffmpeg'
|
||||
'flac'
|
||||
'jack'
|
||||
'libao'
|
||||
'libcdio-paranoia'
|
||||
'libmad'
|
||||
'libmodplug'
|
||||
'libmp4v2'
|
||||
'libmpcdec'
|
||||
'libpulse'
|
||||
'libsamplerate'
|
||||
'libvorbis'
|
||||
'opusfile>=0.12'
|
||||
'wavpack'
|
||||
)
|
||||
optdepends=('alsa-lib: for ALSA output plugin support'
|
||||
'libao: for AO output plugin support'
|
||||
'libpulse: for PulseAudio output plugin support'
|
||||
'faad2: for AAC input plugin support'
|
||||
'ffmpeg: for ffmpeg input plugin support'
|
||||
'flac: for flac input plugin support'
|
||||
'jack: for jack plugin support'
|
||||
'libmad: for mp3 input plugin support'
|
||||
'libmodplug: for modplug input plugin support'
|
||||
'libmp4v2: for mp4 input plugin support'
|
||||
'libmpcdec: for musepack input plugin support'
|
||||
'libsamplerate: for sampe rate converter support'
|
||||
'libvorbis: for vorbis input plugin support'
|
||||
'libcdio-paranoia: for cdio support'
|
||||
'opusfile: for opus input plugin support'
|
||||
'wavpack: for wavpack input plugin support')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/cmus/cmus/archive/v${pkgver}.tar.gz"
|
||||
'13-atomic_ld.patch')
|
||||
sha256sums=('756ce2c6241b2104dc19097488225de559ac1802a175be0233cfb6fbc02f3bd2'
|
||||
'8526dc4649a90513b66ed46cf675e2bc5d0d553f0e3eb438f2dcd317858c64e3')
|
||||
|
||||
prepare() {
|
||||
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
patch -p1 -i ../13-atomic_ld.patch
|
||||
export LDLIBS="-latomic"
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
./configure prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
make DESTDIR="$pkgdir" install
|
||||
install -Dm644 contrib/_cmus "$pkgdir"/usr/share/zsh/site-functions/_cmus
|
||||
}
|
Loading…
Reference in a new issue