mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/qt3 to 3.3.8-20
This commit is contained in:
parent
295a249020
commit
f0c3b76555
2 changed files with 111 additions and 51 deletions
|
@ -1,8 +1,9 @@
|
||||||
# $Id: PKGBUILD 114776 2011-03-15 23:09:15Z andrea $
|
# $Id: PKGBUILD 123699 2011-05-12 15:47:03Z andrea $
|
||||||
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
|
# Maintainer:
|
||||||
|
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
|
||||||
# Contributor: John Proctor <jproctor@prium.net>
|
# Contributor: John Proctor <jproctor@prium.net>
|
||||||
|
|
||||||
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
|
# ALARM: Kevin Mihelich <kevin@plugapps.com>
|
||||||
# - added arm.patch to fix compiling on ARM with GCC >= 4
|
# - added arm.patch to fix compiling on ARM with GCC >= 4
|
||||||
# Source: http://lists.trolltech.com/qt-embedded-interest/2007-03/msg00003.html
|
# Source: http://lists.trolltech.com/qt-embedded-interest/2007-03/msg00003.html
|
||||||
|
|
||||||
|
@ -10,20 +11,29 @@ plugrel=1
|
||||||
|
|
||||||
pkgname=qt3
|
pkgname=qt3
|
||||||
pkgver=3.3.8
|
pkgver=3.3.8
|
||||||
pkgrel=19
|
pkgrel=20
|
||||||
pkgdesc="The QT gui toolkit."
|
pkgdesc="The QT3 gui toolkit"
|
||||||
arch=(i686 x86_64)
|
arch=('i686' 'x86_64')
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
url="http://www.trolltech.com/products/qt/index.html"
|
url="http://www.trolltech.com/products/qt/index.html"
|
||||||
pkgfqn=qt-x11-free-${pkgver}
|
pkgfqn=qt-x11-free-${pkgver}
|
||||||
install=qt.install
|
install=qt.install
|
||||||
depends=('libpng>=1.4.0' 'libxmu' 'libxcursor' 'libxinerama' 'mesa' \
|
depends=('libpng' 'libxmu' 'libxcursor' 'libxinerama' 'mesa' 'libxft'
|
||||||
'libxft' 'libxrandr' 'libmng>=1.0.10-3')
|
'libxrandr' 'libmng')
|
||||||
makedepends=('mysql' 'postgresql>=8.2.3' 'unixodbc' 'sqlite3')
|
makedepends=('mysql' 'postgresql' 'unixodbc' 'sqlite3')
|
||||||
optdepends=('libmysqlclient' 'postgresql-libs' 'unixodbc')
|
optdepends=('libmysqlclient' 'postgresql-libs' 'unixodbc')
|
||||||
source=(ftp://ftp.trolltech.com/qt/source/${pkgfqn}.tar.bz2 qt3-png14.patch qt.profile \
|
source=("ftp://ftp.trolltech.com/qt/source/${pkgfqn}.tar.bz2"
|
||||||
qt-copy-kde-patches.tar.bz2 qt-patches.tar.bz2 utf8-bug-qt3.diff \
|
qt3-png14.patch
|
||||||
qt-font-default-subst.diff mysql.patch eastern_asian_languagues.diff qt-odbc.patch arm.patch)
|
qt.profile
|
||||||
|
qt-copy-kde-patches.tar.bz2
|
||||||
|
qt-patches.tar.bz2
|
||||||
|
utf8-bug-qt3.diff
|
||||||
|
qt-font-default-subst.diff
|
||||||
|
mysql.patch
|
||||||
|
eastern_asian_languagues.diff
|
||||||
|
qt-odbc.patch
|
||||||
|
gcc-4.6.patch
|
||||||
|
arm.patch)
|
||||||
options=(!libtool)
|
options=(!libtool)
|
||||||
md5sums=('cf3c43a7dfde5bfb76f8001102fe6e85'
|
md5sums=('cf3c43a7dfde5bfb76f8001102fe6e85'
|
||||||
'1dc671df42b9030dbdf68bb61cd3375e'
|
'1dc671df42b9030dbdf68bb61cd3375e'
|
||||||
|
@ -35,6 +45,7 @@ md5sums=('cf3c43a7dfde5bfb76f8001102fe6e85'
|
||||||
'7d40ed1bd40d33d8b9b27a2076a5d22a'
|
'7d40ed1bd40d33d8b9b27a2076a5d22a'
|
||||||
'616f1f3029cf8375256ad6a406de3549'
|
'616f1f3029cf8375256ad6a406de3549'
|
||||||
'2178ca88dfd75a230918593b30eb0dbe'
|
'2178ca88dfd75a230918593b30eb0dbe'
|
||||||
|
'75177de5b08e1efd437c887c6e606c5b'
|
||||||
'88933d4af283bd5e8ff1b99f0dc35225')
|
'88933d4af283bd5e8ff1b99f0dc35225')
|
||||||
|
|
||||||
# qt-copy-kde-patches come from http://websvn.kde.org/trunk/qt-copy/patches/
|
# qt-copy-kde-patches come from http://websvn.kde.org/trunk/qt-copy/patches/
|
||||||
|
@ -42,33 +53,36 @@ md5sums=('cf3c43a7dfde5bfb76f8001102fe6e85'
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
unset QMAKESPEC
|
unset QMAKESPEC
|
||||||
export QTDIR=${srcdir}/$pkgfqn
|
export QTDIR="${srcdir}"/$pkgfqn
|
||||||
export PATH=${QTDIR}/bin:${PATH}
|
export PATH=${QTDIR}/bin:${PATH}
|
||||||
export LD_LIBRARY_PATH=${QTDIR}/lib:${LD_LIBRARY_PATH}
|
export LD_LIBRARY_PATH=${QTDIR}/lib:${LD_LIBRARY_PATH}
|
||||||
export QMAKESPEC=$QTDIR/mkspecs/linux-g++
|
export QMAKESPEC=$QTDIR/mkspecs/linux-g++
|
||||||
cd ${srcdir}/$pkgfqn
|
cd "${srcdir}"/$pkgfqn
|
||||||
# apply qt patches from kde.org
|
# apply qt patches from kde.org
|
||||||
for i in ../qt-copy-kde-patches/*; do
|
for i in ../qt-copy-kde-patches/*; do
|
||||||
patch -Np0 -i $i || return 1
|
patch -Np0 -i $i
|
||||||
done
|
done
|
||||||
# apply other qt patches and one security fix from debian/gentoo
|
# apply other qt patches and one security fix from debian/gentoo
|
||||||
for i in ../qt-patches/*; do
|
for i in ../qt-patches/*; do
|
||||||
patch -Np1 -i $i || return 1
|
patch -Np1 -i $i
|
||||||
done
|
done
|
||||||
# fix utf8 bug
|
# fix utf8 bug
|
||||||
patch -Np0 -i ../utf8-bug-qt3.diff || return 1
|
patch -p0 -i "${srcdir}"/utf8-bug-qt3.diff
|
||||||
# fix asia fonts
|
# fix asia fonts
|
||||||
patch -Np0 -i ../qt-font-default-subst.diff || return 1
|
patch -p0 -i "${srcdir}"/qt-font-default-subst.diff
|
||||||
# fix segfaults on exit when using mysql DB driver
|
# fix segfaults on exit when using mysql DB driver
|
||||||
patch -Np0 -i ../mysql.patch || return 1
|
patch -p0 -i "${srcdir}"/mysql.patch
|
||||||
# fix CJK font/chars select error (FS#11245)
|
# fix CJK font/chars select error (FS#11245)
|
||||||
patch -p1 -i ${srcdir}/eastern_asian_languagues.diff || return 1
|
patch -p1 -i "${srcdir}"/eastern_asian_languagues.diff
|
||||||
# fix build problem against new unixODBC
|
# fix build problem against new unixODBC
|
||||||
patch -p1 -i ${srcdir}/qt-odbc.patch || return 1
|
patch -p1 -i "${srcdir}"/qt-odbc.patch
|
||||||
|
# fix build with gcc 4.6.0
|
||||||
|
patch -p1 -i "${srcdir}"/gcc-4.6.patch
|
||||||
|
|
||||||
|
patch -p0 -i "${srcdir}"/qt3-png14.patch
|
||||||
|
# Arch Linux ARM patch
|
||||||
|
patch -p1 -i ${srcdir}/arm.patch || return 1
|
||||||
|
|
||||||
patch -p0 -i ${srcdir}/qt3-png14.patch || return 1
|
|
||||||
# PlugApps ARM patch
|
|
||||||
patch -p1 -i ${srcdir}/arm.patch || return1
|
|
||||||
# start compiling qt
|
# start compiling qt
|
||||||
sed -i 's|-cp -P -f|-cp -L -f|' qmake/Makefile.unix
|
sed -i 's|-cp -P -f|-cp -L -f|' qmake/Makefile.unix
|
||||||
rm -rf doc/html examples tutorial
|
rm -rf doc/html examples tutorial
|
||||||
|
@ -87,41 +101,54 @@ build() {
|
||||||
else unset ARCH
|
else unset ARCH
|
||||||
fi
|
fi
|
||||||
|
|
||||||
./configure -prefix /opt/qt -platform linux-g++$ARCH \
|
./configure -prefix /opt/qt \
|
||||||
-system-zlib -qt-gif -release -shared -sm -nis -thread -stl \
|
-platform linux-g++$ARCH \
|
||||||
|
-system-zlib \
|
||||||
|
-qt-gif \
|
||||||
|
-release \
|
||||||
|
-shared \
|
||||||
|
-sm \
|
||||||
|
-nis \
|
||||||
|
-thread \
|
||||||
|
-stl \
|
||||||
-system-lib{png,jpeg,mng} \
|
-system-lib{png,jpeg,mng} \
|
||||||
-no-g++-exceptions -plugin-sql-{mysql,psql,sqlite,odbc}
|
-no-g++-exceptions \
|
||||||
|
-plugin-sql-{mysql,psql,sqlite,odbc}
|
||||||
|
|
||||||
# fix /opt/qt/lib path
|
# fix /opt/qt/lib path
|
||||||
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/src/Makefile
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" "${srcdir}"/$pkgfqn/src/Makefile
|
||||||
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/tools/designer/designer/Makefile
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" "${srcdir}"/$pkgfqn/tools/designer/designer/Makefile
|
||||||
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/tools/designer/editor/Makefile
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" "${srcdir}"/$pkgfqn/tools/designer/editor/Makefile
|
||||||
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/tools/assistant/lib/Makefile
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" "${srcdir}"/$pkgfqn/tools/assistant/lib/Makefile
|
||||||
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" ${srcdir}/$pkgfqn/tools/designer/uilib/Makefile
|
[ "$CARCH" = "x86_64" ] && sed -i "s|/opt/qt/lib64|/opt/qt/lib|g" "${srcdir}"/$pkgfqn/tools/designer/uilib/Makefile
|
||||||
|
|
||||||
cd ${srcdir}/$pkgfqn
|
cd "${srcdir}"/$pkgfqn
|
||||||
make -C qmake || return 1
|
make -C qmake
|
||||||
cd ${srcdir}/$pkgfqn/plugins/src/sqldrivers/mysql
|
cd "${srcdir}"/$pkgfqn/plugins/src/sqldrivers/mysql
|
||||||
${srcdir}/$pkgfqn/bin/qmake -o Makefile "INCPATH+=/usr/include/mysql" "LIBS+=-L/usr/lib/mysql -lmysqlclient" mysql.pro
|
"${srcdir}"/$pkgfqn/bin/qmake -o Makefile "INCPATH+=/usr/include/mysql" "LIBS+=-L/usr/lib/mysql -lmysqlclient" mysql.pro
|
||||||
cd ${srcdir}/$pkgfqn/plugins/src/sqldrivers/psql
|
cd "${srcdir}"/$pkgfqn/plugins/src/sqldrivers/psql
|
||||||
${srcdir}/$pkgfqn/bin/qmake -o Makefile "INCPATH+=/usr/src/include /usr/include/postgresql/server" "LIBS+=-L/usr/lib -lpq" psql.pro
|
"${srcdir}"/$pkgfqn/bin/qmake -o Makefile "INCPATH+=/usr/src/include /usr/include/postgresql/server" "LIBS+=-L/usr/lib -lpq" psql.pro
|
||||||
|
|
||||||
cd ${srcdir}/$pkgfqn
|
cd "${srcdir}"/$pkgfqn
|
||||||
# fix the broken makefiles
|
# fix the broken makefiles
|
||||||
#sed -i 's|[[:space:]]*strip.*doc/html.*$|#|g' src/Makefile
|
#sed -i 's|[[:space:]]*strip.*doc/html.*$|#|g' src/Makefile
|
||||||
make || return 1
|
make
|
||||||
make INSTALL_ROOT=${pkgdir} install
|
}
|
||||||
rm -rf ${pkgdir}/opt/qt/{phrasebooks,templates,translations}
|
|
||||||
sed -i "s|-L${srcdir}/$pkgfqn/lib ||g" ${pkgdir}/opt/qt/lib/*.prl
|
package() {
|
||||||
install -D -m755 qmake/qmake ${pkgdir}/opt/qt/bin/qmake
|
cd "${srcdir}"/$pkgfqn
|
||||||
install -D -m755 ${srcdir}/qt.profile ${pkgdir}/etc/profile.d/qt3.sh
|
make INSTALL_ROOT="${pkgdir}" install
|
||||||
ln -sf /opt/qt/bin/qtconfig ${pkgdir}/opt/qt/bin/qt3config
|
rm -rf "${pkgdir}"/opt/qt/{phrasebooks,templates,translations}
|
||||||
rm -f ${pkgdir}/opt/qt/mkspecs/linux-g++$ARCH/linux-g++$ARCH
|
sed -i "s|-L${srcdir}/$pkgfqn/lib ||g" "${pkgdir}"/opt/qt/lib/*.prl
|
||||||
|
install -D -m755 qmake/qmake "${pkgdir}"/opt/qt/bin/qmake
|
||||||
|
install -D -m755 "${srcdir}"/qt.profile "${pkgdir}"/etc/profile.d/qt3.sh
|
||||||
|
ln -sf /opt/qt/bin/qtconfig "${pkgdir}"/opt/qt/bin/qt3config
|
||||||
|
rm -f "${pkgdir}"/opt/qt/mkspecs/linux-g++$ARCH/linux-g++$ARCH
|
||||||
|
|
||||||
# install man pages
|
# install man pages
|
||||||
mkdir -p ${pkgdir}/opt/qt/man
|
install -d -m755 "${pkgdir}"/opt/qt/man
|
||||||
cp -r ${srcdir}/$pkgfqn/doc/man/{man1,man3} ${pkgdir}/opt/qt/man/
|
cp -r "${srcdir}"/$pkgfqn/doc/man/{man1,man3} "${pkgdir}"/opt/qt/man/
|
||||||
|
|
||||||
install -d -m755 ${pkgdir}/etc/ld.so.conf.d/
|
install -d -m755 "${pkgdir}"/etc/ld.so.conf.d/
|
||||||
echo '/opt/qt/lib' > ${pkgdir}/etc/ld.so.conf.d/qt3.conf
|
echo '/opt/qt/lib' > "${pkgdir}"/etc/ld.so.conf.d/qt3.conf
|
||||||
}
|
}
|
||||||
|
|
33
extra/qt3/gcc-4.6.patch
Normal file
33
extra/qt3/gcc-4.6.patch
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
diff -up qt-x11-free-3.3.8b/src/tools/qmap.h.cstddef qt-x11-free-3.3.8b/src/tools/qmap.h
|
||||||
|
--- qt-x11-free-3.3.8b/src/tools/qmap.h.cstddef 2008-01-15 13:09:13.000000000 -0600
|
||||||
|
+++ qt-x11-free-3.3.8b/src/tools/qmap.h 2011-01-30 21:14:29.275088725 -0600
|
||||||
|
@@ -49,6 +49,7 @@
|
||||||
|
#include "qvaluelist.h"
|
||||||
|
#endif // QT_H
|
||||||
|
|
||||||
|
+#include <cstddef>
|
||||||
|
#ifndef QT_NO_STL
|
||||||
|
#include <iterator>
|
||||||
|
#include <map>
|
||||||
|
diff -up qt-x11-free-3.3.8b/src/tools/qvaluelist.h.cstddef qt-x11-free-3.3.8b/src/tools/qvaluelist.h
|
||||||
|
--- qt-x11-free-3.3.8b/src/tools/qvaluelist.h.cstddef 2008-01-15 13:09:13.000000000 -0600
|
||||||
|
+++ qt-x11-free-3.3.8b/src/tools/qvaluelist.h 2011-01-30 21:14:01.765846592 -0600
|
||||||
|
@@ -47,6 +47,7 @@
|
||||||
|
#include "qdatastream.h"
|
||||||
|
#endif // QT_H
|
||||||
|
|
||||||
|
+#include <cstddef>
|
||||||
|
#ifndef QT_NO_STL
|
||||||
|
#include <iterator>
|
||||||
|
#include <list>
|
||||||
|
diff -up qt-x11-free-3.3.8b/src/tools/qvaluevector.h.cstddef qt-x11-free-3.3.8b/src/tools/qvaluevector.h
|
||||||
|
--- qt-x11-free-3.3.8b/src/tools/qvaluevector.h.cstddef 2008-01-15 13:09:13.000000000 -0600
|
||||||
|
+++ qt-x11-free-3.3.8b/src/tools/qvaluevector.h 2011-01-30 21:14:01.765846592 -0600
|
||||||
|
@@ -45,6 +45,7 @@
|
||||||
|
#include "qdatastream.h"
|
||||||
|
#endif // QT_H
|
||||||
|
|
||||||
|
+#include <cstddef>
|
||||||
|
#ifndef QT_NO_STL
|
||||||
|
#include <vector>
|
||||||
|
#endif
|
Loading…
Reference in a new issue