extra/meson to 0.44.1-1

This commit is contained in:
Kevin Mihelich 2018-02-22 00:26:04 +00:00
parent 5ef907b987
commit f0eb0ba0d9
2 changed files with 3 additions and 41 deletions

View file

@ -1,33 +0,0 @@
From 67d5488753911b06b80afd57066e36b4eddec892 Mon Sep 17 00:00:00 2001
Message-Id: <67d5488753911b06b80afd57066e36b4eddec892.1517146929.git.jan.steffens@gmail.com>
In-Reply-To: <89d4decc9cdda01590c2a734c0f58924bcf30777.1517146929.git.jan.steffens@gmail.com>
References: <89d4decc9cdda01590c2a734c0f58924bcf30777.1517146929.git.jan.steffens@gmail.com>
From: Matthias Klumpp <matthias@tenstral.net>
Date: Sun, 7 Jan 2018 17:57:43 +0100
Subject: [PATCH 2/2] d: Detect recent DMD compilers
They now are published by the D Language Foundation, and not Digital
Mars. Therefore, their signature has changed slightly.
(We can not check for 'DMD', because that string appears in every
compiler version output to denote the frontend version used by the
compiler).
---
mesonbuild/environment.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mesonbuild/environment.py b/mesonbuild/environment.py
index 0cb1450e..7fa4732a 100644
--- a/mesonbuild/environment.py
+++ b/mesonbuild/environment.py
@@ -725,7 +725,7 @@ class Environment:
return compilers.LLVMDCompiler(exelist, version, is_cross)
elif 'gdc' in out:
return compilers.GnuDCompiler(exelist, version, is_cross)
- elif 'Digital Mars' in out:
+ elif 'The D Language Foundation' in out or 'Digital Mars' in out:
return compilers.DmdDCompiler(exelist, version, is_cross)
raise EnvironmentException('Unknown compiler "' + ' '.join(exelist) + '"')
--
2.16.1

View file

@ -7,8 +7,8 @@
# - remove checkdepend on dmd
pkgname=meson
pkgver=0.44.0
pkgrel=2
pkgver=0.44.1
pkgrel=1
pkgdesc='High productivity build system'
url='http://mesonbuild.com/'
arch=('any')
@ -22,12 +22,10 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt4' 'qt5-b
'qt5-tools' 'libwmf' 'valgrind')
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
0001-tests-skip-objc-nsstring-test-if-gnustep-is-not-inst.patch
0002-d-Detect-recent-DMD-compilers.patch
arch-meson)
sha512sums=('9aefa52d92d7750528e9a9236f19131c8e58bfc21212595c311f4e2787ad40bb53d6085f52283cad13923ddf12da1a59067d48424c72ace47fc127978d1af2ff'
sha512sums=('1ecccccfa24ec2c5c144f8c13fd95d250b59cb22b79676a2a1a6f9ed30a7b08adb71d5882b2d4421d07689ad6dd6d6aef139ac33f628e55a1d428cbc40b4d93e'
'SKIP'
'04a0f113ba5f1ae57591fad3f5ecf812ef88b8809b4ffe063e82f6548e728a1a7bd51c171a948873884c2631fc10a9cd141f56de22cd7cf766cdb74996840eec'
'b38af817966e60db19c1efcc5e8e4f1b822925bf823b0a68c33eb0bfd0aa4ccff1439e352d8df032d0a189cd0ff37fb7dcefe0ed7a272e45f963f7e3d0b63f0f'
'b9f86ded46ad7fc4c4cbd997bd2210e363f02189377d9159cae4a52d0bd8bb9e02de1680bc76f63ecd923922f9cbdba40efbe09231dc24fc1d445ed97c2f5132')
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
@ -36,9 +34,6 @@ prepare() {
# Skip gnustep tests
patch -Np1 -i ../0001-tests-skip-objc-nsstring-test-if-gnustep-is-not-inst.patch
# Fix for recent DMD
patch -Np1 -i ../0002-d-Detect-recent-DMD-compilers.patch
}
build() {