extra/qt5-base to 5.13.2-1

This commit is contained in:
Kevin Mihelich 2019-11-02 15:30:02 +00:00
parent 76699ef734
commit f10ab5d192
2 changed files with 4 additions and 20 deletions

View file

@ -8,9 +8,9 @@
pkgbase=qt5-base
pkgname=(qt5-base qt5-xcb-private-headers)
_qtver=5.13.1
_qtver=5.13.2
pkgver=${_qtver/-/}
pkgrel=2
pkgrel=1
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@ -31,10 +31,8 @@ optdepends=('qt5-svg: to use SVG icon themes'
conflicts=('qtchooser')
groups=('qt' 'qt5')
_pkgfqn="${pkgbase/5-/}-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
qtbug-77364.patch)
sha256sums=('110cd08cdacab26274bf2519d3508046616c0b638f0d2f5e00bc8bad87469eab'
'dc742814ab0c1b63da5916d96e3ef01fa96007c385ed033ae5b3a8cd8608c119')
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
sha256sums=('26b6b686d66a7ad28eaca349e55e2894e5a735f3831e45f2049e93b1daa92121')
prepare() {
cd ${_pkgfqn}
@ -45,8 +43,6 @@ prepare() {
mkspecs/common/gcc-base.conf
sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
mkspecs/common/g++-unix.conf
patch -p1 -i ../qtbug-77364.patch # Fix keyboard input in webengine
}
build() {

View file

@ -1,12 +0,0 @@
diff --git a/src/widgets/kernel/qwidget.cpp b/src/widgets/kernel/qwidget.cpp
index 04290a4ce1..27773d5762 100644
--- a/src/widgets/kernel/qwidget.cpp
+++ b/src/widgets/kernel/qwidget.cpp
@@ -6446,7 +6446,7 @@ void QWidget::setFocusProxy(QWidget * w)
if (changingAppFocusWidget) {
QWidget *newDeepestFocusProxy = d_func()->deepestFocusProxy();
- QApplicationPrivate::focus_widget = newDeepestFocusProxy ? newDeepestFocusProxy : this;
+ QApplicationPrivate::setFocusWidget(newDeepestFocusProxy ? newDeepestFocusProxy : this, Qt::NoFocusReason);
}
}