mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
removed extra/pyqt5
This commit is contained in:
parent
ea9c846acb
commit
f12334c31e
2 changed files with 0 additions and 135 deletions
|
@ -1,118 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
|
||||
# Contributor: Yichao Yu <yyc1992@gmail.com>
|
||||
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
|
||||
# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix qreal on ARM
|
||||
|
||||
pkgbase=pyqt5
|
||||
pkgname=pyqt5
|
||||
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
|
||||
pkgver=5.3.2
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
|
||||
license=('GPL')
|
||||
makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
|
||||
'python2-dbus' 'python-dbus' 'qt5-multimedia' 'qt5-tools'
|
||||
'qt5-svg' 'qt5-serialport')
|
||||
source=("http://downloads.sourceforge.net/project/pyqt/PyQt5/PyQt-${pkgver}/PyQt-gpl-${pkgver}.tar.gz"
|
||||
'fix_qreal_check.diff')
|
||||
md5sums=('81ef608fa4f3961918106d0ca07aa68a'
|
||||
'24100c64ed373dfd55a0c050f3989524')
|
||||
|
||||
prepare() {
|
||||
cd PyQt-gpl-${pkgver}
|
||||
|
||||
patch -p1 -i ../fix_qreal_check.diff
|
||||
}
|
||||
|
||||
build() {
|
||||
cp -r PyQt-gpl-${pkgver} Py2Qt-gpl-${pkgver}
|
||||
|
||||
cd PyQt-gpl-${pkgver}
|
||||
python3 configure.py \
|
||||
--confirm-license \
|
||||
-v /usr/share/sip/PyQt5 \
|
||||
--qsci-api \
|
||||
-q /usr/bin/qmake-qt5
|
||||
|
||||
# Thanks Gerardo for the rpath fix
|
||||
find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
|
||||
|
||||
make
|
||||
|
||||
### Python2 version ###
|
||||
cd ../Py2Qt-gpl-${pkgver}
|
||||
python2 configure.py \
|
||||
--confirm-license \
|
||||
-v /usr/share/sip/Py2-PyQt5 \
|
||||
--qsci-api \
|
||||
-q /usr/bin/qmake-qt5
|
||||
|
||||
# Thanks Gerardo for the rpath fix
|
||||
find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package_pyqt5-common(){
|
||||
pkgdesc="Common PyQt files shared between python-pyqt5 and python2-pyqt5"
|
||||
depends=('qt5-base')
|
||||
|
||||
cd PyQt-gpl-${pkgver}
|
||||
make -C pyrcc DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
|
||||
make -C pylupdate DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
install -Dm644 PyQt5.api "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
|
||||
}
|
||||
|
||||
package_python-pyqt5(){
|
||||
pkgdesc="A set of Python 3.x bindings for the Qt5 toolkit"
|
||||
depends=('python-sip' 'pyqt5-common' 'python' 'python')
|
||||
optdepends=('python-opengl: enable OpenGL 3D graphics in PyQt applications'
|
||||
'python-dbus: for python-dbus mainloop support'
|
||||
'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
|
||||
'qt5-tools: QtHelp, QtDesigner'
|
||||
'qt5-svg: QtSvg'
|
||||
'qt5-webkit: QtWebKit, QtWebKitWidgets'
|
||||
'qt5-xmlpatterns: QtXmlPatterns'
|
||||
'qt5-declarative: QtQml, qmlplugin'
|
||||
'qt5-serialport: QtSerialPort')
|
||||
|
||||
cd PyQt-gpl-${pkgver}
|
||||
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
|
||||
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Provided by pyqt-common
|
||||
rm "${pkgdir}"/usr/bin/{pylupdate5,pyrcc5}
|
||||
rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
|
||||
}
|
||||
|
||||
package_python2-pyqt5(){
|
||||
pkgdesc="A set of Python 2.x bindings for the Qt5 toolkit"
|
||||
depends=('python2-sip' 'pyqt5-common' 'python2')
|
||||
optdepends=('python2-opengl: enable OpenGL 3D graphics in PyQt applications'
|
||||
'python-dbus: for python-dbus mainloop support'
|
||||
'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
|
||||
'qt5-tools: QtHelp, QtDesigner'
|
||||
'qt5-svg: QtSvg'
|
||||
'qt5-webkit: QtWebKit, QtWebKitWidgets'
|
||||
'qt5-xmlpatterns: QtXmlPatterns'
|
||||
'qt5-declarative: QtQml, qmlplugin'
|
||||
'qt5-serialport: QtSerialPort')
|
||||
|
||||
cd Py2Qt-gpl-${pkgver}
|
||||
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
|
||||
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix conflicts with python-pyqt5
|
||||
mv "${pkgdir}"/usr/bin/{,python2-}pyuic5
|
||||
|
||||
rm "${pkgdir}"/usr/bin/{pylupdate5,pyrcc5}
|
||||
rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpyqt5.so
|
||||
rm "${pkgdir}"/usr/lib/qt/plugins/PyQt5/libpyqt5qmlplugin.so
|
||||
rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt5.api
|
||||
}
|
|
@ -1,17 +0,0 @@
|
|||
diff -urN a/configure.py b/configure.py
|
||||
--- a/configure.py 2014-03-14 08:38:18.000000000 -0600
|
||||
+++ b/configure.py 2014-03-28 14:55:32.379777351 -0600
|
||||
@@ -492,11 +492,8 @@
|
||||
#endif
|
||||
|
||||
#if QT_VERSION < 0x050200
|
||||
-// This is the test used in qglobal.h in Qt prior to v5.2. In v5.2 and later
|
||||
-// qreal is always double.
|
||||
-#if defined(QT_NO_FPU) || defined(Q_PROCESSOR_ARM) || defined(Q_OS_WINCE)
|
||||
- out << "PyQt_qreal_double\\n";
|
||||
-#endif
|
||||
+ if (sizeof (qreal) != sizeof (double))
|
||||
+ out << "PyQt_qreal_double\\n";
|
||||
#endif
|
||||
|
||||
return 0;
|
Loading…
Reference in a new issue