removed alarm/at91bootstrap-arietta

This commit is contained in:
Kevin Mihelich 2022-02-07 01:21:11 +00:00
parent 7611edb0ba
commit f1805a1368
3 changed files with 0 additions and 120 deletions

View file

@ -1,32 +0,0 @@
From 71e4b550ede1e546640056b38d0e93b9d0b20bc3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 13 Jun 2015 19:37:54 -0600
Subject: [PATCH 1/2] arietta dtb name fix
This sets the dtb name based on RAM size.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
board/at91sam9x5_arietta/at91sam9x5_arietta.c | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/board/at91sam9x5_arietta/at91sam9x5_arietta.c b/board/at91sam9x5_arietta/at91sam9x5_arietta.c
index 97851eb..eb3bf4a 100644
--- a/board/at91sam9x5_arietta/at91sam9x5_arietta.c
+++ b/board/at91sam9x5_arietta/at91sam9x5_arietta.c
@@ -238,7 +238,11 @@ static void sdcard_set_of_name_board(char *of_name)
{
//unsigned int cpu_board_id = get_cm_sn();
//unsigned int disp_board_id = get_dm_sn();
- strcpy(of_name, "acme-arietta");
+#ifdef CONFIG_RAM_128MB
+ strcpy(of_name, "dtbs/at91-arietta128");
+#else
+ strcpy(of_name, "dtbs/at91-arietta256");
+#endif
strcat(of_name, ".dtb");
}
--
2.6.1

View file

@ -1,25 +0,0 @@
From a198443121aa446161d04d04b669218f58f7b7e6 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 19 Oct 2015 19:04:18 -0600
Subject: [PATCH 2/2] fix for gcc 5
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 11062f0..d0d73d4 100644
--- a/Makefile
+++ b/Makefile
@@ -214,7 +214,7 @@ GC_SECTIONS=--gc-sections
NOSTDINC_FLAGS=-nostdinc -isystem $(shell $(CC) -print-file-name=include)
CPPFLAGS=$(NOSTDINC_FLAGS) -ffunction-sections -g -Os -Wall \
- -fno-stack-protector -fno-common \
+ -fno-stack-protector -fno-common -fgnu89-inline \
-I$(INCL) -Iinclude -Ifs/include \
-DAT91BOOTSTRAP_VERSION=\"$(VERSION)$(REV)$(SCMINFO)\" -DCOMPILE_TIME="\"$(DATE)\""
--
2.6.1

View file

@ -1,63 +0,0 @@
# AT91Boostrap: Arietta G25
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
buildarch=2
pkgbase=at91bootstrap-arietta
pkgname=("${pkgbase}-128" "${pkgbase}-256")
pkgver=v3.7.r25.g3f957ce
pkgrel=1
arch=('arm')
url="https://github.com/tanzilli/at91bootstrap"
makedepends=('git' 'bc')
license=('GPL')
source=("git+https://github.com/tanzilli/at91bootstrap.git"
'0001-arietta-dtb-name-fix.patch'
'0002-fix-for-gcc-5.patch')
md5sums=('SKIP'
'48707263a58bfaf566641bbcf080fdea'
'b6e82a87eda88cc63f1df3965e9e544f')
pkgver() {
cd at91bootstrap
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
)
}
prepare() {
cd at91bootstrap
git apply ../0001-arietta-dtb-name-fix.patch
git apply ../0002-fix-for-gcc-5.patch
}
build() {
cd at91bootstrap
unset LDFLAGS CFLAGS CXXFLAGS
make mrproper
make arietta-128m_defconfig
make
cp binaries/at91sam9x5_arietta-sdcardboot-linux-zimage-dt-3.7.bin boot128.bin
make clean
make arietta-256m_defconfig
make
cp binaries/at91sam9x5_arietta-sdcardboot-linux-zimage-dt-3.7.bin boot256.bin
}
package_at91bootstrap-arietta-128() {
pkgdesc="AT91Boostrap for Arietta G25 128MB"
mkdir -p "${pkgdir}"/boot
cp at91bootstrap/boot128.bin "${pkgdir}"/boot/boot.bin
}
package_at91bootstrap-arietta-256() {
pkgdesc="AT91Boostrap for Arietta G25 256MB"
mkdir -p "${pkgdir}"/boot
cp at91bootstrap/boot256.bin "${pkgdir}"/boot/boot.bin
}