mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/linux-tools to 5.3-1
This commit is contained in:
parent
5651522f16
commit
f1c9cdee3c
5 changed files with 53 additions and 18 deletions
|
@ -1,4 +1,4 @@
|
|||
From afe2e788d1da5d246b1453444d2d9d7dba767cb9 Mon Sep 17 00:00:00 2001
|
||||
From 61bd66f4424d5f216a23c19b1b6133323fc4f6ba Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 14 Jul 2019 21:34:17 -0600
|
||||
Subject: [PATCH] perf: fix debug printf for 32-bit
|
||||
|
@ -9,10 +9,10 @@ Subject: [PATCH] perf: fix debug printf for 32-bit
|
|||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tools/perf/util/session.c b/tools/perf/util/session.c
|
||||
index 54cf163347f7..aceb703e676d 100644
|
||||
index 37efa1f43d8b..db34760a07bf 100644
|
||||
--- a/tools/perf/util/session.c
|
||||
+++ b/tools/perf/util/session.c
|
||||
@@ -76,7 +76,7 @@ static int perf_session__process_compressed_event(struct perf_session *session,
|
||||
@@ -82,7 +82,7 @@ static int perf_session__process_compressed_event(struct perf_session *session,
|
||||
session->decomp_last = decomp;
|
||||
}
|
||||
|
||||
|
@ -22,18 +22,18 @@ index 54cf163347f7..aceb703e676d 100644
|
|||
return 0;
|
||||
}
|
||||
diff --git a/tools/perf/util/zstd.c b/tools/perf/util/zstd.c
|
||||
index 23bdb9884576..f4382ed3c432 100644
|
||||
index d2202392ffdb..290f048963d6 100644
|
||||
--- a/tools/perf/util/zstd.c
|
||||
+++ b/tools/perf/util/zstd.c
|
||||
@@ -100,7 +100,7 @@ size_t zstd_decompress_stream(struct zstd_data *data, void *src, size_t src_size
|
||||
ret = ZSTD_decompressStream(data->dstream, &output, &input);
|
||||
if (ZSTD_isError(ret)) {
|
||||
pr_err("failed to decompress (B): %ld -> %ld : %s\n",
|
||||
- src_size, output.size, ZSTD_getErrorName(ret));
|
||||
+ (long)src_size, (long)output.size, ZSTD_getErrorName(ret));
|
||||
pr_err("failed to decompress (B): %ld -> %ld, dst_size %ld : %s\n",
|
||||
- src_size, output.size, dst_size, ZSTD_getErrorName(ret));
|
||||
+ (long)src_size, (long)output.size, (long)dst_size, ZSTD_getErrorName(ret));
|
||||
break;
|
||||
}
|
||||
output.dst = dst + output.pos;
|
||||
--
|
||||
2.21.0
|
||||
2.23.0
|
||||
|
||||
|
|
|
@ -21,7 +21,7 @@ pkgname=(
|
|||
'gpio-utils'
|
||||
'iio-utils'
|
||||
)
|
||||
pkgver=5.2
|
||||
pkgver=5.3
|
||||
pkgrel=1
|
||||
license=('GPL2')
|
||||
arch=('x86_64')
|
||||
|
@ -39,21 +39,28 @@ makedepends+=('pciutils')
|
|||
makedepends+=('glib2' 'sysfsutils' 'udev')
|
||||
# tmon deps
|
||||
makedepends+=('ncurses')
|
||||
# bpf deps
|
||||
makedepends+=('python-docutils')
|
||||
groups=("$pkgbase")
|
||||
source=("https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-${pkgver}.tar.xz"
|
||||
"https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-$pkgver.1.xz"
|
||||
# "https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-$pkgver.1.xz"
|
||||
'0001-perf-fix-debug-printf-for-32-bit.patch'
|
||||
'cpupower.default'
|
||||
'cpupower.systemd'
|
||||
'cpupower.service'
|
||||
'usbipd.service')
|
||||
md5sums=('ddf994de00d7b18395886dd9b30b9262'
|
||||
'a45be902d46625f7b554f17bab3686f0'
|
||||
'79157a49024739b249e8f16e5b31eb31'
|
||||
'usbipd.service'
|
||||
'hv_fcopy_daemon.service'
|
||||
'hv_kvp_daemon.service'
|
||||
'hv_vss_daemon.service')
|
||||
md5sums=('c99feaade8047339528fb066ec5f8a49'
|
||||
'8533ebc2c4ff61269cb37f6f28eb9705'
|
||||
'56883c159381ba89e50ab8ea65efec77'
|
||||
'34f5ecc19770a1abbcd0fd65bfd1f065'
|
||||
'86c4e419e4ba80835c330d49ba3f56ad'
|
||||
'bb35634f480325a78b943f7e10165e86')
|
||||
'bb35634f480325a78b943f7e10165e86'
|
||||
'4295fa68fcc26865030075bb59e9214c'
|
||||
'340c26526370a07daef713a7a48918d5'
|
||||
'436df78f98a765efccd9e224bdbdc2a5')
|
||||
|
||||
prepare() {
|
||||
cd linux-$pkgver
|
||||
|
@ -134,9 +141,7 @@ build() {
|
|||
msg2 'bpf'
|
||||
pushd linux-$pkgver/tools/bpf
|
||||
# doesn't compile when we don't first compile bpftool in its directory
|
||||
cd bpftool
|
||||
make
|
||||
cd ..
|
||||
make -C bpftool all doc
|
||||
make
|
||||
popd
|
||||
}
|
||||
|
@ -266,6 +271,7 @@ package_hyperv() {
|
|||
cd linux-$pkgver/tools/hv
|
||||
for _p in hv_fcopy_daemon hv_kvp_daemon hv_vss_daemon; do
|
||||
install -Dm755 "$_p" "$pkgdir/usr/bin/$_p"
|
||||
install -Dm644 "$srcdir/$_p.service" "$pkgdir/usr/lib/systemd/system/$_p.service"
|
||||
done
|
||||
install -dm755 "$pkgdir/usr/lib/hyperv/kvp_scripts"
|
||||
}
|
||||
|
@ -295,6 +301,8 @@ package_bpf() {
|
|||
# fix bpftool hard written path
|
||||
mv "$pkgdir"/usr/sbin/bpftool "$pkgdir"/usr/bin/bpftool
|
||||
rmdir "$pkgdir"/usr/sbin
|
||||
# install man pages
|
||||
make -C bpftool doc-install prefix=/usr DESTDIR="$pkgdir"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
9
community/linux-tools/hv_fcopy_daemon.service
Normal file
9
community/linux-tools/hv_fcopy_daemon.service
Normal file
|
@ -0,0 +1,9 @@
|
|||
[Unit]
|
||||
Description=Hyper-V file copy service (FCOPY)
|
||||
ConditionPathExists=/dev/vmbus/hv_fcopy
|
||||
|
||||
[Service]
|
||||
ExecStart=/usr/bin/hv_fcopy_daemon -n
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
9
community/linux-tools/hv_kvp_daemon.service
Normal file
9
community/linux-tools/hv_kvp_daemon.service
Normal file
|
@ -0,0 +1,9 @@
|
|||
[Unit]
|
||||
Description=Hyper-V key-value pair (KVP)
|
||||
ConditionPathExists=/dev/vmbus/hv_kvp
|
||||
|
||||
[Service]
|
||||
ExecStart=/usr/bin/hv_kvp_daemon -n
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
9
community/linux-tools/hv_vss_daemon.service
Normal file
9
community/linux-tools/hv_vss_daemon.service
Normal file
|
@ -0,0 +1,9 @@
|
|||
[Unit]
|
||||
Description=Hyper-V volume shadow copy service (VSS)
|
||||
ConditionPathExists=/dev/vmbus/hv_vss
|
||||
|
||||
[Service]
|
||||
ExecStart=/usr/bin/hv_vss_daemon -n
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
Loading…
Reference in a new issue