mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/firefox to 45.0-1
This commit is contained in:
parent
ded11bc49f
commit
f1e5e3f875
3 changed files with 38 additions and 153 deletions
|
@ -10,14 +10,14 @@
|
|||
highmem=1
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=44.0.2
|
||||
pkgrel=2
|
||||
pkgver=45.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone web browser from mozilla.org"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL' 'LGPL')
|
||||
url="https://www.mozilla.org/firefox/"
|
||||
depends=('gtk3' 'gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
|
||||
'dbus-glib' 'alsa-lib' 'ffmpeg2.8' 'desktop-file-utils' 'hicolor-icon-theme'
|
||||
'dbus-glib' 'alsa-lib' 'ffmpeg' 'desktop-file-utils' 'hicolor-icon-theme'
|
||||
'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite' 'ttf-font')
|
||||
makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'gconf'
|
||||
'xorg-server-xvfb' 'libpulse' 'inetutils')
|
||||
|
@ -30,16 +30,16 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
|
|||
firefox.desktop
|
||||
firefox-install-dir.patch
|
||||
vendor.js
|
||||
firefox-quicktime.patch
|
||||
firefox-symbolic.svg
|
||||
firefox-fixed-loading-icon.png
|
||||
no-neon.patch
|
||||
189d4b0f9f23.patch::https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/raw-rev/189d4b0f9f23)
|
||||
sha256sums=('0bb28841a9268c50cbb239f759f16f55b3a624f679c68965158beaa0a83a2d9e'
|
||||
sha256sums=('36ab0f09b1b1df071a8aafa673c6286d99c18dc06cecbb70d1bb2021fbf379f1'
|
||||
'9011ffcd6eb2868d0363c216d0b28faf64bb746e8de200726a6ca7013a99106e'
|
||||
'c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826'
|
||||
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
|
||||
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
|
||||
'6b731ca36e7688aeb24685da702e0af0475e6671072fc96464fbbed49d0bbd50'
|
||||
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
|
||||
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
|
||||
'6d0c1c9ca28b20d206ce24ca84f4d4e3f5d062a2e9cb7445fcb6c2cfea959b4a'
|
||||
'cbd14ac4839062f4437d1db7cfd5fb9aaadb6786dc63612b219106e01000aafd')
|
||||
|
@ -64,9 +64,6 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
|
|||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1244523
|
||||
patch -Np1 -i ../firefox-quicktime.patch
|
||||
|
||||
cp ../mozconfig .mozconfig
|
||||
patch -Np1 -i ../firefox-install-dir.patch
|
||||
|
||||
|
@ -127,6 +124,8 @@ package() {
|
|||
"$pkgdir/usr/share/icons/hicolor/192x192/apps/firefox.png"
|
||||
install -Dm644 browser/branding/official/content/about-logo@2x.png \
|
||||
"$pkgdir/usr/share/icons/hicolor/384x384/apps/firefox.png"
|
||||
install -Dm644 ../firefox-symbolic.svg \
|
||||
"$pkgdir/usr/share/icons/hicolor/symbolic/apps/firefox-symbolic.svg"
|
||||
|
||||
install -Dm644 ../firefox.desktop \
|
||||
"$pkgdir/usr/share/applications/firefox.desktop"
|
||||
|
|
|
@ -1,144 +0,0 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User John Lin <jolin@mozilla.com>
|
||||
# Date 1447265580 -3600
|
||||
# Node ID aeb7ece8cbd40280f27ec3631f4f9e5b8b52c5a9
|
||||
# Parent 22d372a893d764554af0edb7e47f817af93b2114
|
||||
Bug 1211802 - Recognize 'avc?' as mp4 video. r=jya
|
||||
|
||||
diff --git a/toolkit/components/mediasniffer/nsMediaSniffer.cpp b/toolkit/components/mediasniffer/nsMediaSniffer.cpp
|
||||
--- a/toolkit/components/mediasniffer/nsMediaSniffer.cpp
|
||||
+++ b/toolkit/components/mediasniffer/nsMediaSniffer.cpp
|
||||
@@ -36,16 +36,17 @@ nsMediaSnifferEntry nsMediaSniffer::sSni
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF\xFF\x00\x00\x00\x00\xFF\xFF\xFF\xFF", "RIFF\x00\x00\x00\x00WAVE", AUDIO_WAV),
|
||||
// mp3 with ID3 tags, the string "ID3".
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF", "ID3", AUDIO_MP3)
|
||||
};
|
||||
|
||||
// For a complete list of file types, see http://www.ftyps.com/index.html
|
||||
nsMediaSnifferEntry sFtypEntries[] = {
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF", "mp4", VIDEO_MP4), // Could be mp41 or mp42.
|
||||
+ PATTERN_ENTRY("\xFF\xFF\xFF", "avc", VIDEO_MP4), // Could be avc1, avc2, ...
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF", "3gp", VIDEO_3GPP), // Could be 3gp4, 3gp5, ...
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF\xFF", "M4A ", AUDIO_MP4),
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF\xFF", "M4P ", AUDIO_MP4)
|
||||
};
|
||||
|
||||
static bool MatchesBrands(const uint8_t aData[4], nsACString& aSniffedType)
|
||||
{
|
||||
for (size_t i = 0; i < mozilla::ArrayLength(sFtypEntries); ++i) {
|
||||
|
||||
|
||||
# HG changeset patch
|
||||
# User Jean-Yves Avenard <jyavenard@mozilla.com>
|
||||
# Date 1454373529 -39600
|
||||
# Node ID f7d66b2782266c066f2efecc9f066af01472ffb5
|
||||
# Parent b237f1bffcfd9b7c7da767ffa54dbf4ed7b68321
|
||||
Bug 1244523: P1. Allow video/quicktime mimetype. r=cpearce
|
||||
|
||||
It's just like video/mp4
|
||||
|
||||
|
||||
diff --git a/dom/media/fmp4/MP4Decoder.cpp b/dom/media/fmp4/MP4Decoder.cpp
|
||||
--- a/dom/media/fmp4/MP4Decoder.cpp
|
||||
+++ b/dom/media/fmp4/MP4Decoder.cpp
|
||||
@@ -102,16 +102,17 @@ MP4Decoder::CanHandleMediaType(const nsA
|
||||
const bool isMP4Audio = aMIMETypeExcludingCodecs.EqualsASCII("audio/mp4") ||
|
||||
aMIMETypeExcludingCodecs.EqualsASCII("audio/x-m4a");
|
||||
const bool isMP4Video =
|
||||
// On B2G, treat 3GPP as MP4 when Gonk PDM is available.
|
||||
#ifdef MOZ_GONK_MEDIACODEC
|
||||
aMIMETypeExcludingCodecs.EqualsASCII(VIDEO_3GPP) ||
|
||||
#endif
|
||||
aMIMETypeExcludingCodecs.EqualsASCII("video/mp4") ||
|
||||
+ aMIMETypeExcludingCodecs.EqualsASCII("video/quicktime") ||
|
||||
aMIMETypeExcludingCodecs.EqualsASCII("video/x-m4v");
|
||||
if (!isMP4Audio && !isMP4Video) {
|
||||
return false;
|
||||
}
|
||||
|
||||
nsTArray<nsCString> codecMimes;
|
||||
if (aCodecs.IsEmpty()) {
|
||||
// No codecs specified. Assume AAC/H.264
|
||||
|
||||
|
||||
# HG changeset patch
|
||||
# User Jean-Yves Avenard <jyavenard@mozilla.com>
|
||||
# Date 1454373530 -39600
|
||||
# Node ID b0c3e8efafc8aa13935d023762e26495fc9b99a9
|
||||
# Parent f7d66b2782266c066f2efecc9f066af01472ffb5
|
||||
Bug 1244523: [mp4] P2. Have sniffer recognise ftyp qt subtype. r=cpearce
|
||||
|
||||
|
||||
diff --git a/toolkit/components/mediasniffer/nsMediaSniffer.cpp b/toolkit/components/mediasniffer/nsMediaSniffer.cpp
|
||||
--- a/toolkit/components/mediasniffer/nsMediaSniffer.cpp
|
||||
+++ b/toolkit/components/mediasniffer/nsMediaSniffer.cpp
|
||||
@@ -37,17 +37,18 @@ nsMediaSnifferEntry nsMediaSniffer::sSni
|
||||
};
|
||||
|
||||
// For a complete list of file types, see http://www.ftyps.com/index.html
|
||||
nsMediaSnifferEntry sFtypEntries[] = {
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF", "mp4", VIDEO_MP4), // Could be mp41 or mp42.
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF", "avc", VIDEO_MP4), // Could be avc1, avc2, ...
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF", "3gp", VIDEO_3GPP), // Could be 3gp4, 3gp5, ...
|
||||
PATTERN_ENTRY("\xFF\xFF\xFF\xFF", "M4A ", AUDIO_MP4),
|
||||
- PATTERN_ENTRY("\xFF\xFF\xFF\xFF", "M4P ", AUDIO_MP4)
|
||||
+ PATTERN_ENTRY("\xFF\xFF\xFF\xFF", "M4P ", AUDIO_MP4),
|
||||
+ PATTERN_ENTRY("\xFF\xFF\xFF\xFF", "qt ", VIDEO_MP4),
|
||||
};
|
||||
|
||||
static bool MatchesBrands(const uint8_t aData[4], nsACString& aSniffedType)
|
||||
{
|
||||
for (size_t i = 0; i < mozilla::ArrayLength(sFtypEntries); ++i) {
|
||||
const auto& currentEntry = sFtypEntries[i];
|
||||
bool matched = true;
|
||||
MOZ_ASSERT(currentEntry.mLength <= 4, "Pattern is too large to match brand strings.");
|
||||
|
||||
|
||||
# HG changeset patch
|
||||
# User Jean-Yves Avenard <jyavenard@mozilla.com>
|
||||
# Date 1454373533 -39600
|
||||
# Node ID 15d15d76aae97b14717eded043ea73cc81fe50e6
|
||||
# Parent b0c3e8efafc8aa13935d023762e26495fc9b99a9
|
||||
Bug 1244523: [mp4] P3. Skip four bytes when we hit a zero length box, r=kentuckyfriedtakahe
|
||||
|
||||
Similar to bug 1180101, but don't handle only the last box in the file.
|
||||
|
||||
|
||||
diff --git a/media/libstagefright/frameworks/av/media/libstagefright/MPEG4Extractor.cpp b/media/libstagefright/frameworks/av/media/libstagefright/MPEG4Extractor.cpp
|
||||
--- a/media/libstagefright/frameworks/av/media/libstagefright/MPEG4Extractor.cpp
|
||||
+++ b/media/libstagefright/frameworks/av/media/libstagefright/MPEG4Extractor.cpp
|
||||
@@ -646,24 +646,24 @@ static bool ValidInputSize(int32_t size)
|
||||
// frame. This is a reasonable cut-off for a lossy codec,
|
||||
// combined with the current Firefox limit to 5k video.
|
||||
return (size > 0 && size <= 4 * (1920 * 1080) * 3 / 2);
|
||||
}
|
||||
|
||||
status_t MPEG4Extractor::parseChunk(off64_t *offset, int depth) {
|
||||
ALOGV("entering parseChunk %lld/%d", *offset, depth);
|
||||
uint32_t hdr[2];
|
||||
- ssize_t nbytes;
|
||||
- if ((nbytes = mDataSource->readAt(*offset, hdr, 8)) < 8) {
|
||||
- if (nbytes == 4) {
|
||||
- if (!hdr[0]) {
|
||||
- *offset += 4;
|
||||
- return OK;
|
||||
- }
|
||||
- }
|
||||
+ if (mDataSource->readAt(*offset, hdr, 4) < 4) {
|
||||
+ return ERROR_IO;
|
||||
+ }
|
||||
+ if (!hdr[0]) {
|
||||
+ *offset += 4;
|
||||
+ return OK;
|
||||
+ }
|
||||
+ if (mDataSource->readAt(*offset + 4, hdr + 1, 4) < 4) {
|
||||
return ERROR_IO;
|
||||
}
|
||||
uint64_t chunk_size = ntohl(hdr[0]);
|
||||
uint32_t chunk_type = ntohl(hdr[1]);
|
||||
off64_t data_offset = *offset + 8;
|
||||
|
||||
if (chunk_size == 1) {
|
||||
if (mDataSource->readAt(*offset + 8, &chunk_size, 8) < 8) {
|
||||
|
30
extra/firefox/firefox-symbolic.svg
Normal file
30
extra/firefox/firefox-symbolic.svg
Normal file
|
@ -0,0 +1,30 @@
|
|||
<?xml version='1.0' encoding='UTF-8' standalone='no'?>
|
||||
<!-- Created with Inkscape (http://www.inkscape.org/) -->
|
||||
|
||||
<svg xmlns:cc='http://creativecommons.org/ns#' xmlns:dc='http://purl.org/dc/elements/1.1/' sodipodi:docname='firefox-symbolic.svg' height='16' id='svg7384' xmlns:inkscape='http://www.inkscape.org/namespaces/inkscape' xmlns:osb='http://www.openswatchbook.org/uri/2009/osb' xmlns:rdf='http://www.w3.org/1999/02/22-rdf-syntax-ns#' xmlns:sodipodi='http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd' xmlns:svg='http://www.w3.org/2000/svg' version='1.1' inkscape:version='0.91 r13725' width='16' xmlns='http://www.w3.org/2000/svg'>
|
||||
<metadata id='metadata90'>
|
||||
<rdf:RDF>
|
||||
<cc:Work rdf:about=''>
|
||||
<dc:format>image/svg+xml</dc:format>
|
||||
<dc:type rdf:resource='http://purl.org/dc/dcmitype/StillImage'/>
|
||||
<dc:title>Gnome Symbolic Icon Theme</dc:title>
|
||||
</cc:Work>
|
||||
</rdf:RDF>
|
||||
</metadata>
|
||||
<sodipodi:namedview inkscape:bbox-paths='true' bordercolor='#666666' borderopacity='1' inkscape:current-layer='layer9' inkscape:cx='-10.975734' inkscape:cy='233.73843' gridtolerance='10' inkscape:guide-bbox='true' guidetolerance='10' id='namedview88' inkscape:object-nodes='false' inkscape:object-paths='false' objecttolerance='10' pagecolor='#555753' inkscape:pageopacity='1' inkscape:pageshadow='2' showborder='false' showgrid='false' showguides='true' inkscape:snap-bbox='true' inkscape:snap-bbox-midpoints='false' inkscape:snap-global='true' inkscape:snap-grids='true' inkscape:snap-nodes='true' inkscape:snap-others='false' inkscape:snap-to-guides='true' inkscape:window-height='1403' inkscape:window-maximized='1' inkscape:window-width='2560' inkscape:window-x='2560' inkscape:window-y='0' inkscape:zoom='1'>
|
||||
<inkscape:grid empspacing='2' enabled='true' id='grid4866' originx='-222.00001' originy='-381.99852' snapvisiblegridlinesonly='true' spacingx='1px' spacingy='1px' type='xygrid' visible='true'/>
|
||||
</sodipodi:namedview>
|
||||
<title id='title9167'>Gnome Symbolic Icon Theme</title>
|
||||
<defs id='defs7386'>
|
||||
<linearGradient id='linearGradient7212' osb:paint='solid'>
|
||||
<stop id='stop7214' offset='0' style='stop-color:#000000;stop-opacity:1;'/>
|
||||
</linearGradient>
|
||||
</defs>
|
||||
<g inkscape:groupmode='layer' id='layer9' inkscape:label='apps' style='display:inline' transform='translate(-463.00021,164.99852)'>
|
||||
|
||||
<path inkscape:connector-curvature='0' d='M 469.05437,-154.9679 Z' id='path17747' style='fill:none;stroke:#000000;stroke-width:0.99851286px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1'/>
|
||||
<path inkscape:connector-curvature='0' d='M 469.08553,-154.9054 Z' id='path17749' style='fill:none;stroke:#000000;stroke-width:0.99851286px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1'/>
|
||||
<path inkscape:connector-curvature='0' d='m 473.0627,-162.9375 c -0.41568,-0.0182 -0.62813,0.0274 -0.625,0.0312 0.006,0.008 1.72988,0.32697 2.03125,0.75 0,0 -0.71915,0.007 -1.4375,0.21875 -0.0325,0.01 2.64053,0.33122 3.1875,3.0625 0,0 -0.29354,-0.64386 -0.65625,-0.75 0.23852,0.74134 0.16466,2.17583 -0.0625,2.875 -0.0292,0.0899 -0.0525,-0.38762 -0.5,-0.59375 0.14332,1.04923 -0.006,2.6978 -0.71875,3.15625 -0.0555,0.0357 0.43942,-1.64894 0.0937,-1 -2.06368,3.2325 -4.50486,1.31102 -5.5,0.625 0.79871,0.19996 1.80035,0.0704 2.125,-0.15625 0.49572,-0.34615 0.79916,-0.59107 1.0625,-0.53125 0.26322,0.0601 0.42318,-0.22934 0.21875,-0.46875 -0.20466,-0.23989 -0.70268,-0.55471 -1.375,-0.375 -0.47415,0.12687 -1.04057,0.54268 -1.9375,0 -0.7652,-0.46319 -0.67076,-0.69942 -0.67076,-0.93907 0,-0.23977 0.21387,-0.59107 0.59375,-0.53125 0.0851,0.0134 0.15074,0.009 0.1875,0 0.18483,0.0422 0.35743,0.0964 0.53125,0.1875 0.008,-0.2241 -0.0292,-0.87345 -0.15625,-1.23012 0.0106,0.004 0.0289,0.011 0.0312,0 0.0384,-0.17687 1.05477,-0.18386 1.37388,-0.59643 0.20404,-0.26362 0.14073,-0.79683 0.14073,-0.79683 l -1,0 c -0.52354,0.002 -0.97244,-0.75086 -1.01451,-0.85669 0.11444,-0.62597 0.48612,-0.83952 1.01451,-1.14331 -0.39748,-0.003 -0.18871,0 -1,0 -0.52875,0 -0.84718,0.36158 -1.01451,0.54956 -0.70058,-0.16587 -1.38144,-0.25227 -1.86049,-0.0609 -0.22125,-0.22941 -0.39604,-0.80055 -0.42188,-1.48863 0,0 -1.20486,0.73864 -1.07812,2.55113 -0.002,0.14904 -0.0499,0.21348 -0.0625,0.3125 -0.13061,0.22845 -0.1553,0.40492 -0.125,0.375 -0.0656,0.13627 -0.15391,0.28402 -0.21875,0.46875 -0.0149,0.0362 -0.0495,0.0463 -0.0625,0.0937 -0.009,0.0322 0.002,0.0638 0,0.0937 -0.11512,0.36099 -0.21516,0.98244 -0.3125,1.54262 0,0 0.12424,-0.51425 0.3125,-0.88637 -0.15639,0.54353 -0.26211,1.54974 -0.1875,2.73012 0,0 0.015,-0.20429 0.0625,-0.5 0.0465,0.80102 0.25925,1.72737 0.84375,2.75 1.46152,2.5575 3.89248,3.68885 6.4375,3.46875 0.44516,-0.0296 0.89639,-0.10834 1.34375,-0.21875 5.92923,-1.46449 5.28125,-8.78118 5.28125,-8.78118 l -0.15625,1.09375 c 0,0 -0.24147,-1.99977 -0.53125,-2.75 -0.44412,-1.14957 -0.62372,-1.15791 -0.625,-1.15625 0.29743,0.77226 0.21875,1.1875 0.21875,1.1875 0,0 -0.51279,-1.43939 -1.90625,-1.90625 -0.82515,-0.27632 -1.45932,-0.38807 -1.875,-0.40625 z' id='path159-6' sodipodi:nodetypes='sccccccccccsccccscccccscccccccccccccccccccccccccccs' style='fill:#bebebe;fill-opacity:1;stroke:none'/>
|
||||
<path inkscape:connector-curvature='0' d='m 470.87695,-164.01953 c -0.83043,0.0139 -1.67042,0.17659 -2.48047,0.5 l -0.46289,0.18359 c 0.66083,0.79767 1.84339,0.43951 1.84339,0.43951 2.50802,-0.52344 5.12427,0.6034 6.44177,2.89252 1.49591,2.59908 0.85463,5.89258 -1.50586,7.74219 -2.36049,1.84961 -5.71108,1.68349 -7.87695,-0.39062 -2.16588,-2.07412 -2.47623,-5.41522 -0.73047,-7.85352 l 0.29101,-0.40625 -0.81445,-0.58203 -0.29101,0.40625 c -2.03104,2.83673 -1.66628,6.74516 0.85351,9.1582 2.5198,2.41305 6.43934,2.60693 9.18555,0.45508 2.74621,-2.15185 3.49621,-6.00355 1.75586,-9.02734 -1.30527,-2.26785 -3.7177,-3.55935 -6.20899,-3.51758 z' id='path22109' sodipodi:nodetypes='ccccsssccccsssc' style='color:#000000;font-style:normal;font-variant:normal;font-weight:normal;font-stretch:normal;font-size:medium;line-height:normal;font-family:sans-serif;text-indent:0;text-align:start;text-decoration:none;text-decoration-line:none;text-decoration-style:solid;text-decoration-color:#000000;letter-spacing:normal;word-spacing:normal;text-transform:none;direction:ltr;block-progression:tb;writing-mode:lr-tb;baseline-shift:baseline;text-anchor:start;white-space:normal;clip-rule:nonzero;display:inline;overflow:visible;visibility:visible;opacity:1;isolation:auto;mix-blend-mode:normal;color-interpolation:sRGB;color-interpolation-filters:linearRGB;solid-color:#000000;solid-opacity:1;fill:#bebebe;fill-opacity:1;fill-rule:nonzero;stroke:none;stroke-width:0.99999994;stroke-linecap:square;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1;marker:none;paint-order:normal;color-rendering:auto;image-rendering:auto;shape-rendering:auto;text-rendering:auto;enable-background:accumulate'/>
|
||||
</g>
|
||||
</svg>
|
After Width: | Height: | Size: 6.8 KiB |
Loading…
Reference in a new issue