extra/digikam to 5.4.0-1

This commit is contained in:
Kevin Mihelich 2017-01-10 01:47:08 +00:00
parent 4c2ded7485
commit f2089c4ec0
3 changed files with 40 additions and 15 deletions

View file

@ -1,4 +1,4 @@
From 9e291325f5d2568834fd0d590e5e99af129d9518 Mon Sep 17 00:00:00 2001
From 9b37ca152cbae4b86ce2b93f7b1af58f092d1ccf Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 5 Jul 2016 18:47:56 -0600
Subject: [PATCH] optionally enable OpenGL
@ -9,18 +9,18 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3e64b5..1dabead 100644
index 89e0682..b60d0b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,6 +104,7 @@ option(ENABLE_KFILEMETADATASUPPORT "Build digiKam with KDE files indexer suppor
@@ -105,6 +105,7 @@ option(ENABLE_KFILEMETADATASUPPORT "Build digiKam with KDE files indexer suppor
option(ENABLE_AKONADICONTACTSUPPORT "Build digiKam with KDE Mail Contacts support (default=OFF)" OFF)
option(ENABLE_MEDIAPLAYER "Build digiKam with QtMultimedia support (default=OFF)" OFF)
option(ENABLE_MEDIAPLAYER "Build digiKam with Media Player support (default=OFF)" OFF)
option(ENABLE_DBUS "Build digiKam with DBUS support (default=ON)" ON)
+option(ENABLE_OPENGL "Build digiKam with OpenGL support (default=ON)" ON)
option(ENABLE_APPSTYLES "Build digiKam with support for changing the widget application style (default=OFF)" OFF)
# Mysql support options (experimental):
@@ -286,7 +287,7 @@ else()
@@ -293,7 +294,7 @@ else()
endif()
# decide if Presentation tool can be built with OpenGL
@ -30,5 +30,5 @@ index d3e64b5..1dabead 100644
elseif()
set(HAVE_OPENGL FALSE)
--
2.9.2
2.10.2

View file

@ -9,28 +9,32 @@
pkgbase=digikam
pkgname=('digikam' 'kipi-plugins')
_pkgver=5.3.0
_pkgver=5.4.0
pkgver=${_pkgver//-/_} # for beta versions
pkgrel=6
pkgrel=1
pkgdesc="Digital photo management application for KDE"
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.digikam.org/"
makedepends=('extra-cmake-modules' 'libkipi' 'libksane' 'liblqr' 'opencv' 'boost'
'doxygen' 'lensfun' 'eigen' 'kdoctools' 'marble' 'kdesignerplugin'
'kfilemetadata' 'akonadi-contacts' 'qt5-multimedia' 'threadweaver' 'kcalcore'
'kfilemetadata' 'akonadi-contacts' 'qtav' 'threadweaver' 'kcalcore'
'knotifyconfig' 'libmediawiki' 'libkvkontakte')
source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${_pkgver}.tar.xz"
source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${_pkgver}.tar.xz" digikam-find-qtav.patch
'0001-optionally-enable-OpenGL.patch')
sha1sums=('3a62f6efdfafc37341626cbf0225cd7adc9d0633'
'95169d438884b1650a4c11e1ca44ae7ad5096a89')
sha1sums=('6c58ee30cd84b40acf4427f1bb9dbb8b891eb894'
'b170e5eab5a8c40d1c8c8f2d2cfe5e911ad66939'
'eb78bedfc8465c34b2c08d239085ccaf2e745d71')
prepare() {
mkdir -p build
# Fix QtAV location
cd $pkgname-$pkgver
patch -p1 -i ../digikam-find-qtav.patch
# OpenGL switch
cd ${pkgname}-${_pkgver}/core
patch -p1 -i ${srcdir}/0001-optionally-enable-OpenGL.patch
patch -p1 -d core -i ${srcdir}/0001-optionally-enable-OpenGL.patch
}
build() {
@ -54,7 +58,7 @@ build() {
package_digikam() {
pkgdesc="Digital photo management application for KDE"
depends=('liblqr' 'libkipi' 'lensfun' 'opencv' 'akonadi-contacts'
'knotifyconfig' 'libksane' 'kfilemetadata' 'qt5-multimedia' 'marble' 'threadweaver' 'kcalcore')
'knotifyconfig' 'libksane' 'kfilemetadata' 'qtav' 'marble' 'threadweaver' 'kcalcore')
optdepends=('kipi-plugins: export to various online services'
'hugin: panorama tool' 'qt5-imageformats: WEBP format support')

View file

@ -0,0 +1,21 @@
--- digikam-5.4.0/core/cmake/modules/FindQtAV.cmake.0 2017-01-09 22:56:43.303991660 +0000
+++ digikam-5.4.0/core/cmake/modules/FindQtAV.cmake 2017-01-09 22:57:24.843934106 +0000
@@ -24,15 +24,17 @@
HINTS ${_qt5_install_prefix} # For MXE
${_qt5_install_prefix}/../qt5/include # For Mageia
${_qt5_install_prefix}/../../include/qt5 # For Suse
+ ${_qt5_install_prefix}/../../include/qt
${_qt5_install_prefix}/../../../include/x86_64-linux-gnu/qt5 # For Debian
PATH_SUFFIXES QtAV
)
find_path(QTAV_WIDGETS_INCLUDE_DIR
NAMES QtAVWidgets.h
HINTS ${_qt5_install_prefix} # For MXE
${_qt5_install_prefix}/../qt5/include # For Mageia
${_qt5_install_prefix}/../../include/qt5 # For Suse
+ ${_qt5_install_prefix}/../../include/qt
${_qt5_install_prefix}/../../../include/x86_64-linux-gnu/qt5 # For Debian
PATH_SUFFIXES QtAVWidgets
)