From f20e49731f2cbac2196001f3338832b4d3102ba8 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 19 Jan 2021 15:05:36 +0000
Subject: [PATCH] extra/krita to 4.4.2-1

---
 extra/krita/PKGBUILD          | 18 ++++--------------
 extra/krita/krita-c++14.patch | 13 -------------
 2 files changed, 4 insertions(+), 27 deletions(-)
 delete mode 100644 extra/krita/krita-c++14.patch

diff --git a/extra/krita/PKGBUILD b/extra/krita/PKGBUILD
index b310316cb..5a239164d 100644
--- a/extra/krita/PKGBUILD
+++ b/extra/krita/PKGBUILD
@@ -4,9 +4,9 @@
 #  - remove makedepend on vc
 
 pkgname=krita
-_pkgver=4.4.1
+_pkgver=4.4.2
 pkgver=${_pkgver/-/}
-pkgrel=8
+pkgrel=1
 pkgdesc="Edit and paint images"
 arch=(x86_64)
 url="https://krita.org"
@@ -18,21 +18,11 @@ makedepends=(extra-cmake-modules kdoctools boost eigen poppler-qt5 opencolorio p
 optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations' 'opencolorio: for the LUT docker'
             "krita-plugin-gmic: G'MIC plugin" 'python-pyqt5: for the Python plugins' 'libheif: HEIF filter'
             'kseexpr: SeExpr generator layer' 'kimageformats: PSD support')
-source=("https://download.kde.org/stable/krita/$_pkgver/$pkgname-$_pkgver.tar.gz"{,.sig}
-         krita-kseexpr.patch::"https://invent.kde.org/graphics/krita/commit/bdebaf91.patch"
-         krita-c++14.patch)
-sha256sums=('6f2daf068e4e5cef8a738ab47da443dc82ad1463090a4a1544b35201272c3817'
-            'SKIP'
-            '6aeec0c8d6bc29ae81e7dd1d971663c32cc0137888da4a1b4f50a69fc4491d80'
-            'de84c3c1685e48392d4fb07daab56068cacfc2a846a52a9915b5f3e08357abd1')
+source=("https://download.kde.org/stable/krita/$_pkgver/$pkgname-$_pkgver.tar.gz")
+sha256sums=('9696aec56e759f3e1c22952ca17efdcac97003239f515f570ad9f07e36cb9792')
 validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD'  # Boudewijn Rempt <foundation@krita.org>
               'E9FB29E74ADEACC5E3035B8AB69EB4CF7468332F') # Dmitry Kazakov (main key) <dimula73@gmail.com>
 
-prepare() {
-  patch -d $pkgname-$pkgver -p1 -i ../krita-kseexpr.patch # Port to rebranded seexpr
-  patch -d $pkgname-$pkgver -p1 -i ../krita-c++14.patch # Fix build with boost 1.75
-}
-
 build() {
   cmake -B build -S $pkgname-$_pkgver \
     -DBUILD_TESTING=OFF \
diff --git a/extra/krita/krita-c++14.patch b/extra/krita/krita-c++14.patch
deleted file mode 100644
index 678ea0cb9..000000000
--- a/extra/krita/krita-c++14.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 48d445b030..fe9bcb4765 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -7,7 +7,7 @@ cmake_minimum_required(VERSION 3.0.0 FATAL_ERROR)
- set(MIN_QT_VERSION 5.9.0)
- set(MIN_FRAMEWORKS_VERSION 5.44.0)
- 
--set( CMAKE_CXX_STANDARD 11 )
-+set( CMAKE_CXX_STANDARD 14 )
- set( CMAKE_CXX_STANDARD_REQUIRED ON )
- 
-